View Issue Details

IDProjectCategoryView StatusLast Update
0034889FPCRTLpublic2019-02-16 13:52
ReporterMarco van de VoortAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version3.3.1Product Build 
Target Version3.2.0Fixed in Version3.3.1 
Summary0034889: assignfile with codepage
DescriptionDelphi has added a default parameter to assign to set codepage since XE2.

http://docwiki.embarcadero.com/Libraries/XE2/en/System.AssignFile
Steps To Reproduce
var f : text;
begin
  assignfile(f,'atext.txt',65001);
end.
TagsNo tags attached.
Fixed in Revision41342
FPCOldBugId0
FPCTarget
Attached Files

Activities

Michael Van Canneyt

2019-02-16 13:52

administrator   ~0114180

Added an overloaded version, since it is not clear what the default should be.

Issue History

Date Modified Username Field Change
2019-01-17 14:50 Marco van de Voort New Issue
2019-01-17 15:08 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-01-17 15:08 Michael Van Canneyt Status new => assigned
2019-02-16 13:52 Michael Van Canneyt Fixed in Revision => 41342
2019-02-16 13:52 Michael Van Canneyt Note Added: 0114180
2019-02-16 13:52 Michael Van Canneyt Status assigned => resolved
2019-02-16 13:52 Michael Van Canneyt Fixed in Version => 3.3.1
2019-02-16 13:52 Michael Van Canneyt Resolution open => fixed
2019-02-16 13:52 Michael Van Canneyt Target Version => 3.2.0