View Issue Details

IDProjectCategoryView StatusLast Update
0034892LazarusOtherpublic2019-08-11 10:22
ReporterValdir MarcosAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform32bitOSWindowsOS Version7 and 10
Product Version2.0RC3Product Build60092 
Target VersionFixed in Version 
Summary0034892: (lazbuild) package not found: c:\lazarus\source\lazarus\examples\hello.lp
DescriptionError message on building "lazbuild.lpr":
"Error: (lazbuild) package not found: c:\lazarus\source\lazarus\examples\hello.lp".


The only reference to "hello" is on line 51 of "lazbuild.lpi":
------------------
    <RunParams>
      <local>
        <FormatVersion Value="1"/>
        <CommandLineParams Value="c:/lazarus/source/lazarus/examples/hello.lpi"/>
        <LaunchingApplication PathPlusParams="/usr/X11R6/bin/xterm -T 'Lazarus Run Output' -e $(LazarusDir)/tools/runwait.sh $(TargetCmdLine)"/>
      </local>
    </RunParams>
------------------


I neither have the path "c:/lazarus/source/lazarus/examples/" nor the file "hello.lp", but I have the path "c:/lazarus/examples/" which contains the files:
c:\lazarus\examples\hello.lpi
c:\lazarus\examples\hello.pp
c:\lazarus\examples\helloform.pp
Steps To ReproduceOpen the project "c:\lazarus\ide\lazbuild.lpr" on Lazarus and build it with F9.
Additional InformationMaybe, there is also some linking:
-----------------
Error: (lazbuild) package not found: c:\lazarus\source\lazarus\examples\hello.lp
i
Heap dump by heaptrc unit of C:\lazarus\lazbuild.exe
1830 memory blocks allocated : 545199/550952
1823 memory blocks freed : 544645/550368
7 unfreed memory blocks : 554
True heap size : 425984 (144 used in System startup)
True free heap : 424400
Should be : 424584
-----------------

Log text file is attached.
TagsNo tags attached.
Fixed in Revisionr61682
LazTarget-
WidgetsetWin32/Win64
Attached Files
  • lazbuild.log.txt (3,179 bytes)
    Error: (lazbuild) package not found: c:\lazarus\source\lazarus\examples\hello.lp
    i
    Heap dump by heaptrc unit of C:\lazarus\lazbuild.exe
    1830 memory blocks allocated : 545199/550952
    1823 memory blocks freed     : 544645/550368
    7 unfreed memory blocks : 554
    True heap size : 425984 (144 used in System startup)
    True free heap : 424400
    Should be : 424584
    Call trace for block $00325060 size 76
      $0045CE8C
      $0040A687  ERROR,  line 1851 of newlazbuild.lpr
      $00403CB4  BUILDFILE,  line 403 of newlazbuild.lpr
      $004082D3  RUN,  line 1464 of newlazbuild.lpr
      $0040A743  main,  line 1867 of newlazbuild.lpr
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $00324FA0 size 76
      $00403CA7  BUILDFILE,  line 403 of newlazbuild.lpr
      $004082D3  RUN,  line 1464 of newlazbuild.lpr
      $0040A743  main,  line 1867 of newlazbuild.lpr
      $004BA525  GETCFGFILECONTENT,  line 101 of idecmdline.pas
      $004BA6C1  GETPARAMSANDCFGFILE,  line 136 of idecmdline.pas
      $004BACA6  PARAMSANDCFGCOUNT,  line 182 of idecmdline.pas
      $004BAEB6  INITLOGGER,  line 388 of idecmdline.pas
      $004BAF38  IDECMDLINE_$$_init$,  line 396 of idecmdline.pas
      $00417944
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $002C4C30 size 57
      $0044FA09
      $00450B96
      $00403B18  BUILDFILE,  line 371 of newlazbuild.lpr
      $004082D3  RUN,  line 1464 of newlazbuild.lpr
      $0040A743  main,  line 1867 of newlazbuild.lpr
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $0029F818 size 32
      $00429E8E
      $0042A29F
      $00428D4F
      $00408EC5  PARSEPARAMETERS,  line 1615 of newlazbuild.lpr
      $0040822F  RUN,  line 1459 of newlazbuild.lpr
      $0040A743  main,  line 1867 of newlazbuild.lpr
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $00345998 size 57
      $004554F2
      $00454FA6
      $004BA91F  GETPARAMSANDCFGFILE,  line 163 of idecmdline.pas
      $004030F6  TOOLPARAMCOUNT,  line 217 of newlazbuild.lpr
      $004085C4  PARSEPARAMETERS,  line 1509 of newlazbuild.lpr
      $0040822F  RUN,  line 1459 of newlazbuild.lpr
      $0040A743  main,  line 1867 of newlazbuild.lpr
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $002ACF28 size 92
      $0040804D  CREATE,  line 1428 of newlazbuild.lpr
      $0040A739  main,  line 1866 of newlazbuild.lpr
      $004BAEB6  INITLOGGER,  line 388 of idecmdline.pas
      $004BAF38  IDECMDLINE_$$_init$,  line 396 of idecmdline.pas
      $00417944
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    Call trace for block $0035D9E0 size 164
      $0040A739  main,  line 1866 of newlazbuild.lpr
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
      $BAADF00D
    
    lazbuild.log.txt (3,179 bytes)

Activities

Valdir Marcos

2019-01-17 20:46

reporter  

lazbuild.log.txt (3,179 bytes)
Error: (lazbuild) package not found: c:\lazarus\source\lazarus\examples\hello.lp
i
Heap dump by heaptrc unit of C:\lazarus\lazbuild.exe
1830 memory blocks allocated : 545199/550952
1823 memory blocks freed     : 544645/550368
7 unfreed memory blocks : 554
True heap size : 425984 (144 used in System startup)
True free heap : 424400
Should be : 424584
Call trace for block $00325060 size 76
  $0045CE8C
  $0040A687  ERROR,  line 1851 of newlazbuild.lpr
  $00403CB4  BUILDFILE,  line 403 of newlazbuild.lpr
  $004082D3  RUN,  line 1464 of newlazbuild.lpr
  $0040A743  main,  line 1867 of newlazbuild.lpr
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $00324FA0 size 76
  $00403CA7  BUILDFILE,  line 403 of newlazbuild.lpr
  $004082D3  RUN,  line 1464 of newlazbuild.lpr
  $0040A743  main,  line 1867 of newlazbuild.lpr
  $004BA525  GETCFGFILECONTENT,  line 101 of idecmdline.pas
  $004BA6C1  GETPARAMSANDCFGFILE,  line 136 of idecmdline.pas
  $004BACA6  PARAMSANDCFGCOUNT,  line 182 of idecmdline.pas
  $004BAEB6  INITLOGGER,  line 388 of idecmdline.pas
  $004BAF38  IDECMDLINE_$$_init$,  line 396 of idecmdline.pas
  $00417944
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $002C4C30 size 57
  $0044FA09
  $00450B96
  $00403B18  BUILDFILE,  line 371 of newlazbuild.lpr
  $004082D3  RUN,  line 1464 of newlazbuild.lpr
  $0040A743  main,  line 1867 of newlazbuild.lpr
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $0029F818 size 32
  $00429E8E
  $0042A29F
  $00428D4F
  $00408EC5  PARSEPARAMETERS,  line 1615 of newlazbuild.lpr
  $0040822F  RUN,  line 1459 of newlazbuild.lpr
  $0040A743  main,  line 1867 of newlazbuild.lpr
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $00345998 size 57
  $004554F2
  $00454FA6
  $004BA91F  GETPARAMSANDCFGFILE,  line 163 of idecmdline.pas
  $004030F6  TOOLPARAMCOUNT,  line 217 of newlazbuild.lpr
  $004085C4  PARSEPARAMETERS,  line 1509 of newlazbuild.lpr
  $0040822F  RUN,  line 1459 of newlazbuild.lpr
  $0040A743  main,  line 1867 of newlazbuild.lpr
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $002ACF28 size 92
  $0040804D  CREATE,  line 1428 of newlazbuild.lpr
  $0040A739  main,  line 1866 of newlazbuild.lpr
  $004BAEB6  INITLOGGER,  line 388 of idecmdline.pas
  $004BAF38  IDECMDLINE_$$_init$,  line 396 of idecmdline.pas
  $00417944
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
Call trace for block $0035D9E0 size 164
  $0040A739  main,  line 1866 of newlazbuild.lpr
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
  $BAADF00D
lazbuild.log.txt (3,179 bytes)

Cyrax

2019-03-13 12:06

reporter   ~0114808

Does the 2.0 release (not release candidate) or the 2.0.x fixes branch work?

Bart Broersma

2019-03-13 12:16

developer   ~0114809

That line has been in the lpi file since at least 2010.
It's a runtime paramter and should not affect the build in anyway.

Bart Broersma

2019-03-13 12:23

developer   ~0114810

Fixes 2.0 r60663 builds just fine on my Win10 machine (fresh checkout).
Did you do a make clean before updating and building?

Cyrax

2019-03-13 12:41

reporter   ~0114812

Related post in the forum : http://forum.lazarus.freepascal.org/index.php/topic,39660.msg308467.html#msg308467

Valdir Marcos

2019-08-10 20:00

reporter   ~0117624

Error still persists on Lazarus 2.0.5 SVN 61666 2019-08-06 via fpcupdeluxe on a clean Windows 7 virtual machine.

Juha Manninen

2019-08-11 10:22

developer   ~0117636

I personally don't have problems compiling LazBuild but I removed the RunParams section from the project .lpi file anyway. It should not be needed there. A more logical place for run parameters is the session .lps file. Now a user's local run parameters are stored there by default.

If this change causes problems in some situation, please let me know.

Issue History

Date Modified Username Field Change
2019-01-17 20:46 Valdir Marcos New Issue
2019-01-17 20:46 Valdir Marcos File Added: lazbuild.log.txt
2019-03-13 12:06 Cyrax Note Added: 0114808
2019-03-13 12:16 Bart Broersma Note Added: 0114809
2019-03-13 12:23 Bart Broersma LazTarget => -
2019-03-13 12:23 Bart Broersma Note Added: 0114810
2019-03-13 12:23 Bart Broersma Status new => feedback
2019-03-13 12:41 Cyrax Note Added: 0114812
2019-08-10 20:00 Valdir Marcos Note Added: 0117624
2019-08-10 20:00 Valdir Marcos Status feedback => new
2019-08-11 10:16 Juha Manninen Assigned To => Juha Manninen
2019-08-11 10:16 Juha Manninen Status new => assigned
2019-08-11 10:22 Juha Manninen Status assigned => resolved
2019-08-11 10:22 Juha Manninen Resolution open => fixed
2019-08-11 10:22 Juha Manninen Fixed in Revision => r61682
2019-08-11 10:22 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2019-08-11 10:22 Juha Manninen Note Added: 0117636