View Issue Details

IDProjectCategoryView StatusLast Update
0034910LazarusPackagespublic2019-01-20 09:57
ReporterBenjamin Rosseaux Assigned ToStephano  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
Summary0034910: [Lazarus] Failing to build sparta packages ( specially sparta_mdi ), due to a faulted sparta_basicfakecustom.pas
DescriptionBuilding the sparta packages ( specially sparta_mdi ) fails, due to a faulted sparta_basicfakecustom.pas ( due to wrong visibility of some definitions ), where the other units can not lookup some needed things then. Patch for to fix is attached.
Steps To ReproduceTry to build Lazarus together with the sparta packages ( specially sparta_mdi ).
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0034816 resolvedJuha Manninen Packages The sparta_dockedformeditor could not be compiled and installed 

Activities

Benjamin Rosseaux

2019-01-20 06:49

reporter  

sparta_basicfakecustom.pas.patch (532 bytes)   
Index: components/sparta/mdi/source/sparta_basicfakecustom.pas
===================================================================
--- components/sparta/mdi/source/sparta_basicfakecustom.pas	(revision 60117)
+++ components/sparta/mdi/source/sparta_basicfakecustom.pas	(working copy)
@@ -23,6 +23,7 @@
   private
     FOnChangeHackedBounds: TNotifyEvent;
 
+  protected
     procedure SetOnChangeHackedBounds(const AValue: TNotifyEvent);
     function GetOnChangeHackedBounds: TNotifyEvent;
     function PositionDelta: TPoint;

Benjamin Rosseaux

2019-01-20 06:51

reporter   ~0113510

Okay, it seems, I overlooked the project field, sorry. So please correct it, if it's possible.

Issue History

Date Modified Username Field Change
2019-01-20 06:49 Benjamin Rosseaux New Issue
2019-01-20 06:49 Benjamin Rosseaux File Added: sparta_basicfakecustom.pas.patch
2019-01-20 06:51 Benjamin Rosseaux Note Added: 0113510
2019-01-20 08:47 Florian Project FPC => Lazarus
2019-01-20 09:51 Stephano Relationship added duplicate of 0034816
2019-01-20 09:57 Stephano LazTarget => -
2019-01-20 09:57 Stephano Status new => resolved
2019-01-20 09:57 Stephano Resolution open => duplicate
2019-01-20 09:57 Stephano Assigned To => Stephano