View Issue Details

IDProjectCategoryView StatusLast Update
0034982LazarusLCLpublic2019-02-01 14:01
ReporterReinhard BergerAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.1 (SVN)Product Buildr59603 
Target VersionFixed in Version 
Summary0034982: Appication not terminating and SigSev Error
DescriptionApplication.terminate does not terminate running program when some buttons are on the form.
Steps To Reproduce1.) Create a form
2.) Place some buttons on it (1 oder 2)
3.) Create a 2nd form

Add the following :

procedure TForm1.FormShow(Sender: TObject);
begin
     Form2.ShowModal;
     Application.Terminate;
end;



Additional InformationWorks correctly under GTK2 and Qt5.
Only under Qt4 the form still runs, even after the "application.terminate" command.

When trying to close "Form1" a sigsev appears
TagsNo tags attached.
Fixed in Revision60270,60271
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0034369 closedZeljan Rikalo TTreeview.items.addobject & Application.processmessages 

Activities

Reinhard Berger

2019-01-31 19:01

reporter  

Qt-terminate.zip (130,449 bytes)

Zeljan Rikalo

2019-02-01 10:29

developer   ~0113767

Please provide operating system and Qt4 version.

Zeljan Rikalo

2019-02-01 10:59

developer   ~0113768

Please test and close if ok.

Reinhard Berger

2019-02-01 12:33

reporter   ~0113771

Works now
Thankyou

Zeljan Rikalo

2019-02-01 13:33

developer   ~0113774

Note for me: This problem raised due to Application.MainForm is not yet fully visible and TQtWidgetSet.AppRun isn't started yet so no FMainTimerID, TWidgetSet.AppRun is called AFTER showing of main form. See TApplication.Run().
Event loop isn't started yet so using native events breaks such scenario.

Zeljan Rikalo

2019-02-01 13:34

developer   ~0113775

Please leave this open for now, I'll try to make it work even with native event filter.

Zeljan Rikalo

2019-02-01 14:01

developer   ~0113776

Fixed when used with QtUseNativeEventLoop define.

Issue History

Date Modified Username Field Change
2019-01-31 19:01 Reinhard Berger New Issue
2019-01-31 19:01 Reinhard Berger File Added: Qt-terminate.zip
2019-02-01 10:28 Zeljan Rikalo Assigned To => Zeljan Rikalo
2019-02-01 10:28 Zeljan Rikalo Status new => assigned
2019-02-01 10:29 Zeljan Rikalo LazTarget => -
2019-02-01 10:29 Zeljan Rikalo Note Added: 0113767
2019-02-01 10:29 Zeljan Rikalo Status assigned => feedback
2019-02-01 10:59 Zeljan Rikalo Fixed in Revision => 60270
2019-02-01 10:59 Zeljan Rikalo Note Added: 0113768
2019-02-01 10:59 Zeljan Rikalo Status feedback => resolved
2019-02-01 10:59 Zeljan Rikalo Resolution open => fixed
2019-02-01 12:33 Reinhard Berger Note Added: 0113771
2019-02-01 12:33 Reinhard Berger Status resolved => closed
2019-02-01 13:33 Zeljan Rikalo Note Added: 0113774
2019-02-01 13:33 Zeljan Rikalo Status closed => assigned
2019-02-01 13:33 Zeljan Rikalo Resolution fixed => reopened
2019-02-01 13:34 Zeljan Rikalo Note Added: 0113775
2019-02-01 13:56 Zeljan Rikalo Relationship added related to 0034369
2019-02-01 14:01 Zeljan Rikalo Fixed in Revision 60270 => 60270,60271
2019-02-01 14:01 Zeljan Rikalo Note Added: 0113776
2019-02-01 14:01 Zeljan Rikalo Status assigned => resolved
2019-02-01 14:01 Zeljan Rikalo Resolution reopened => fixed
2019-02-01 14:01 Zeljan Rikalo Status resolved => closed