View Issue Details

IDProjectCategoryView StatusLast Update
0034990FPCDocumentationpublic2019-02-01 17:23
ReporterKai BurghardtAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSGNU/LinuxOS Version4.2.0
Product Version3.0.4Product Build3.0.4+dfsg-11 [2017/12/30] 
Target Version3.2.0Fixed in Version3.3.1 
Summary0034990: minor spelling mistake in system.xml: “harmfull” (extraneous “L”)
Description“harmful” is spelled with one “L” only.
Tagsdocumentation
Fixed in Revision1553
FPCOldBugId
FPCTarget
Attached Files
  • system.xml.patch (539 bytes)
    --- system.xml~	2019-02-01 16:18:20.531602661 +0000
    +++ system.xml	2019-02-01 16:18:20.531602661 +0000
    @@ -6065,7 +6065,7 @@
     <short>Signed integer type with same size as Pointer.</short>
     <descr>
     <p><var>Ptrint</var> is a signed integer type which has always the same size as a
    -pointer. Ptrint is considered harmfull and should almost never be used in actual
    +pointer. Ptrint is considered harmful and should almost never be used in actual
     code, because pointers are normally unsigned. For example, consider the following
     code:
     </p>
    
    system.xml.patch (539 bytes)

Activities

Kai Burghardt

2019-02-01 17:19

reporter  

system.xml.patch (539 bytes)
--- system.xml~	2019-02-01 16:18:20.531602661 +0000
+++ system.xml	2019-02-01 16:18:20.531602661 +0000
@@ -6065,7 +6065,7 @@
 <short>Signed integer type with same size as Pointer.</short>
 <descr>
 <p><var>Ptrint</var> is a signed integer type which has always the same size as a
-pointer. Ptrint is considered harmfull and should almost never be used in actual
+pointer. Ptrint is considered harmful and should almost never be used in actual
 code, because pointers are normally unsigned. For example, consider the following
 code:
 </p>
system.xml.patch (539 bytes)

Michael Van Canneyt

2019-02-01 17:23

administrator   ~0113783

Checked and applied patch, thank you very much !

Issue History

Date Modified Username Field Change
2019-02-01 17:19 Kai Burghardt New Issue
2019-02-01 17:19 Kai Burghardt Status new => assigned
2019-02-01 17:19 Kai Burghardt Assigned To => Michael Van Canneyt
2019-02-01 17:19 Kai Burghardt File Added: system.xml.patch
2019-02-01 17:19 Kai Burghardt Tag Attached: documentation
2019-02-01 17:23 Michael Van Canneyt Fixed in Revision => 1553
2019-02-01 17:23 Michael Van Canneyt Note Added: 0113783
2019-02-01 17:23 Michael Van Canneyt Status assigned => resolved
2019-02-01 17:23 Michael Van Canneyt Fixed in Version => 3.3.1
2019-02-01 17:23 Michael Van Canneyt Resolution open => fixed
2019-02-01 17:23 Michael Van Canneyt Target Version => 3.2.0