View Issue Details

IDProjectCategoryView StatusLast Update
0035057LazarusWidgetsetpublic2019-06-13 14:51
ReporterTomášAssigned ToZeljan Rikalo 
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionopen 
Platformx86_64OSopenSUSEOS Version15.0
Product Version2.0Product Build 
Target VersionFixed in Version 
Summary0035057: Shell dialogs in QT5 widgetset causes AV after application is closed
DescriptionEvery dialog window that uses directory or file lists and is executed, causes AV after application is closed. I tried font dialog and it does not causes it. GTK2 works fine.

It doesn't matter if the dialog is placed on a form or created and freed locally, AC shows up always after app is closed.

I have QT v5.9.4 + libQt5Pas1 v2.0.0

I didn't have this issue with Lazarus 1.8.2 (QT v5.9.4 + libQt4Pas5 v2.5).

I think it's an issue with bindings to QT libraries.
Steps To Reproduce1.) Execute any shell dialog
2.) Close the dialog, no need to select a file or directory
3.) Close the application
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT5
Attached Files

Activities

Zeljan Rikalo

2019-02-10 18:11

developer   ~0114015

Please write what desktop environment are you using (kde,gnome etc) and what theme is used by Qt5.

Zeljan Rikalo

2019-02-10 18:14

developer   ~0114016

I cannot reproduce it here, Fedora 25 64bit.

Tomáš

2019-02-10 22:05

reporter   ~0114021

I found out it happens only in KDE (Plasma 5). GNOME or TWM have no issues. I guess this bug is outside of Lazarus / FPC...

Zeljan Rikalo

2019-02-11 08:31

developer   ~0114024

Do you use native dialogs or qt internal dialogs ?

Tomáš

2019-02-11 13:51

reporter   ~0114032

If native means from palette "Dialogs" then yes.

Zeljan Rikalo

2019-02-11 16:15

developer   ~0114039

No, native means that you're using qt5lcl with -dQT_NATIVE_DIALOGS compiled in, so on KDE qt5 lazarus app opens KDE open dialog, on win32 it opens native win32 dialog etc....

Tomáš

2019-02-11 18:21

reporter   ~0114041

-dQT_NATIVE_DIALOGS makes no difference (recompiled Lazarus or app). In GNOME was used different dialog, but in KDE the same one.

Should be "qt5lcl" an unit? I didn't find anything like it.

Zeljan Rikalo

2019-02-12 17:49

developer   ~0114055

No, -dQT_NATIVE_DIALOGS in lazarus build options is enough. If it's enabled you'll see KDE native open dialog, under Gnome you'll see Gtk2/3 open dialog.

Tomáš

2019-06-12 22:31

reporter   ~0116704

Tried once again in Lazarus 2.0.2 and the bug is still preserved. Even dialogs in Lazarus itself ("Open", "Save as").

Zeljan Rikalo

2019-06-13 14:51

developer   ~0116708

I cannot reproduce your problem - Fedora 25, Fedora 29, LinuxMint 19 all 64bit with various Qt5 versions (5.6..5.12)

Issue History

Date Modified Username Field Change
2019-02-10 12:30 Tomáš New Issue
2019-02-10 14:29 Zeljan Rikalo Assigned To => Zeljan Rikalo
2019-02-10 14:29 Zeljan Rikalo Status new => assigned
2019-02-10 18:11 Zeljan Rikalo LazTarget => -
2019-02-10 18:11 Zeljan Rikalo Note Added: 0114015
2019-02-10 18:11 Zeljan Rikalo Status assigned => feedback
2019-02-10 18:14 Zeljan Rikalo Note Added: 0114016
2019-02-10 22:05 Tomáš Note Added: 0114021
2019-02-10 22:05 Tomáš Status feedback => assigned
2019-02-11 08:31 Zeljan Rikalo Note Added: 0114024
2019-02-11 13:51 Tomáš Note Added: 0114032
2019-02-11 16:15 Zeljan Rikalo Note Added: 0114039
2019-02-11 18:21 Tomáš Note Added: 0114041
2019-02-12 17:49 Zeljan Rikalo Note Added: 0114055
2019-06-12 22:31 Tomáš Note Added: 0116704
2019-06-13 14:51 Zeljan Rikalo Note Added: 0116708