View Issue Details

IDProjectCategoryView StatusLast Update
0035094LazarusWidgetsetpublic2020-05-21 23:27
Reportersembit Assigned ToMichl  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformx86OSXUbuntu 
Product Version2.1 (SVN) 
Fixed in Version2.0.10 
Summary0035094: TSpeedButton, TStringGrid and TDBGrid do not react to left mouse click with first time
DescriptionIf you show a modal form by double-clicking or through the context menu, then the speed button and grid react to a click only from the second time. If the form is not modal or modal form is shown by pressing a button, then everything is fine.
Steps To Reproduce1. Run project.
2. Call conext menu of form and select menu item. Or double click.
3. Try click to speed button or grid. And then click again.
TagsNo tags attached.
Fixed in Revision63203
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0035720 closedMichl First mouse event is lost in new modal form shown from MouseDown event 

Activities

sembit

2019-02-15 16:55

reporter  

TestClick.tar.gz (129,081 bytes)

sembit

2019-02-19 19:27

reporter   ~0114270

In my opinion, the problem is somewhere in the DeliverMouseDownMessage procedure in the gtk2callback.inc file.

Through the crutch, the problem is solved.

procedure TForm2.FormShow(Sender: TObject);
begin
  FillChar(LastMouse, SizeOf(LastMouse), 0);
end;

Juha Manninen

2019-10-21 19:36

developer   ~0118757

Sembit, you studied the code and found a workaround. Could you please go a step further and fix the bug in LCL-GTK2 code and then provide a patch.

sembit

2019-10-23 19:39

reporter   ~0118781

Sorry, but for now I can only report errors.

Issue History

Date Modified Username Field Change
2019-02-15 16:55 sembit New Issue
2019-02-15 16:55 sembit File Added: TestClick.tar.gz
2019-02-19 19:27 sembit Note Added: 0114270
2019-06-15 18:50 Juha Manninen Relationship added related to 0035720
2019-10-21 19:36 Juha Manninen Note Added: 0118757
2019-10-21 22:34 Bart Broersma Category LCL => Widgetset
2019-10-21 22:34 Bart Broersma LazTarget => -
2019-10-21 22:34 Bart Broersma Widgetset GTK 2 => GTK 2
2019-10-23 19:39 sembit Note Added: 0118781
2020-05-21 23:27 Michl Assigned To => Michl
2020-05-21 23:27 Michl Status new => resolved
2020-05-21 23:27 Michl Resolution open => duplicate
2020-05-21 23:27 Michl Fixed in Version => 2.0.10
2020-05-21 23:27 Michl Fixed in Revision => 63203
2020-05-21 23:27 Michl Widgetset GTK 2 => GTK 2