View Issue Details

IDProjectCategoryView StatusLast Update
0035096LazarusLCLpublic2019-05-05 09:19
ReportersembitAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSXUbuntuOS Version18.04
Product Version2.1 (SVN)Product Build60416 
Target Version2.0.2Fixed in Version2.1 (SVN) 
Summary0035096: Flat TStringGrid do not redraw when form resize.
DescriptionWhen I resize a form, the grid does not redraw. Flat := True.
Steps To Reproduce1. Run project.
2. Try change form size.
TagsNo tags attached.
Fixed in Revision60734
LazTarget2.0.2
WidgetsetGTK 2
Attached Files

Activities

sembit

2019-02-15 20:12

reporter  

TestGrid.tar.gz (128,202 bytes)

accorp

2019-02-18 19:39

reporter   ~0114244

It is a regression caused by r54733 from 0031518.

Jesus Reyes

2019-03-20 10:32

developer   ~0114938

Last edited: 2019-03-20 10:39

View 2 revisions

Applied a GTK only solution as testing under windows didn't show the described problem, please test.

sembit

2019-05-05 09:19

reporter   ~0116021

Thanks!

Issue History

Date Modified Username Field Change
2019-02-15 20:12 sembit New Issue
2019-02-15 20:12 sembit File Added: TestGrid.tar.gz
2019-02-18 19:39 accorp Note Added: 0114244
2019-03-20 10:30 Jesus Reyes Assigned To => Jesus Reyes
2019-03-20 10:30 Jesus Reyes Status new => assigned
2019-03-20 10:32 Jesus Reyes Fixed in Revision => 60734
2019-03-20 10:32 Jesus Reyes LazTarget => 2.0.2
2019-03-20 10:32 Jesus Reyes Note Added: 0114938
2019-03-20 10:32 Jesus Reyes Status assigned => resolved
2019-03-20 10:32 Jesus Reyes Fixed in Version => 2.1 (SVN)
2019-03-20 10:32 Jesus Reyes Resolution open => fixed
2019-03-20 10:32 Jesus Reyes Target Version => 2.0.2
2019-03-20 10:39 Jesus Reyes Note Edited: 0114938 View Revisions
2019-05-05 09:19 sembit Status resolved => closed
2019-05-05 09:19 sembit Note Added: 0116021