View Issue Details

IDProjectCategoryView StatusLast Update
0035135LazarusWidgetsetpublic2019-04-30 07:34
ReporterWallabyAssigned ToMaxim Ganetsky 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.1 (SVN)Product Build60436 
Target VersionFixed in Version2.0.2 
Summary0035135: lclIsHandle remaining reference prevents building Cocoa
DescriptionWhen lclIsHandle was removed in trunk in r59015, there was an orphaned reference to it in components/opengl/glcocoanscontext.pas. The remaining reference was removed in r59037.

Now r59015 was merged into fixes_2_0, but r59037 was not merged. This results in the inability to build the IDE under macOS Cocoa due to the error:

lazarus/components/opengl/glcocoanscontext.pas(81,14) Error: (3058) There is no method in an ancestor class to be overridden: "lclIsHandle:Boolean;"

Kindly merge trunk r59037 into fixes_2_0.
TagsNo tags attached.
Fixed in Revision60794
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Alfred

2019-03-23 11:15

reporter   ~0114986

Bump

Maxim Ganetsky

2019-03-29 23:25

developer   ~0115114

Merged, thanks for the hint!

Issue History

Date Modified Username Field Change
2019-02-22 11:13 Wallaby New Issue
2019-03-23 11:15 Alfred Note Added: 0114986
2019-03-29 23:25 Maxim Ganetsky Fixed in Revision => 60794
2019-03-29 23:25 Maxim Ganetsky LazTarget => -
2019-03-29 23:25 Maxim Ganetsky Note Added: 0115114
2019-03-29 23:25 Maxim Ganetsky Status new => resolved
2019-03-29 23:25 Maxim Ganetsky Fixed in Version => 2.0.2
2019-03-29 23:25 Maxim Ganetsky Resolution open => fixed
2019-03-29 23:25 Maxim Ganetsky Assigned To => Maxim Ganetsky
2019-04-30 07:34 Wallaby Status resolved => closed