View Issue Details

IDProjectCategoryView StatusLast Update
0035141FPCCompilerpublic2019-02-28 23:10
ReporterKarl-Michael SchindlerAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformdarwinOSMac OS XOS Version10.5, 10.6
Product Version3.3.1Product Buildsvn revision 41416 
Target VersionFixed in Version3.3.1 
Summary0035141: svn revision 41416 breaks building sparc-linux
DescriptionAfter svn revision 41416 building the target sparc-linux breaks with

...
/BlaBla/FreePascal/compiler/ppcrosssparc -Fisparcgen -Ur -Tlinux -Psparc -XPsparc-linux- -Xr -Ur -Xs -O2 -n -Fi../inc -Fi../sparc -Fi../unix -Fisparc -FE. -FU/BlaBla/FreePascal/rtl/units/sparc-linux -ap -dsparc -dRELEASE ../inc/ctypes.pp
softfpu.pp(1461,5) Fatal: Internal error 2010052906
softfpu.pp(1461,5) Fatal: Internal error 2010052906
Fatal: Compilation aborted
softfpu.pp(1461,5) Fatal: Internal error 2010052906
make[5]: *** [Makefile:4052: softfpu.ppu] Fehler 1
make[5]: *** Es wird auf noch nicht beendete Prozesse gewartet....
Fatal: Compilation aborted
Fatal: Compilation aborted
make[5]: *** [Makefile:4056: sfpu128.ppu] Fehler 1
make[5]: *** [Makefile:4054: sfpux80.ppu] Fehler 1
make[5]: Verzeichnis „/BlaBla/FreePascal/rtl/linux“ wird verlassen
make[4]: *** [Makefile:2063: linux_all] Fehler 2
make[4]: Verzeichnis „/BlaBla/FreePascal/rtl“ wird verlassen
make[3]: *** [Makefile:4576: rtl] Fehler 2
make[3]: Verzeichnis „/BlaBla/FreePascal/compiler“ wird verlassen
make[2]: *** [Makefile:4483: cycle] Fehler 2
make[2]: Verzeichnis „/BlaBla/FreePascal/compiler“ wird verlassen
make[1]: *** [Makefile:2844: compiler_cycle] Fehler 2
make[1]: Verzeichnis „/BlaBla/FreePascal“ wird verlassen
make: *** [Makefile:2876: build-stamp.sparc-linux] Fehler 2
Steps To Reproducesvn up -r 41416
make clean all OPT=-ap OS_TARGET=linux CPU_TARGET=sparc
Additional InformationI do not think, it matters, but for the sake of completeness: Host ist macOS 10.14, bootstrap compiler is ppcx64 version 3.0.4 installed using fink.

I checked numerous other cpu-linux targets, but sparc-linux seems to be the only one. I did not test other sparc targets, since i have no binutils for them.

I also noticed that the internal error 2010052906 occurs at 2 places:

compiler/llvm/hlcgllvm.pas
compiler/cgobj.pas

Although the tests correspond, i am still surprised.
TagsNo tags attached.
Fixed in Revision41526
FPCOldBugId
FPCTarget
Attached Files

Activities

Jonas Maebe

2019-02-28 21:46

manager   ~0114522

Thanks, fixed.

Karl-Michael Schindler

2019-02-28 23:10

reporter   ~0114530

Fix confirmed. Thanks.

Issue History

Date Modified Username Field Change
2019-02-24 16:03 Karl-Michael Schindler New Issue
2019-02-28 21:46 Jonas Maebe Fixed in Revision => 41526
2019-02-28 21:46 Jonas Maebe Note Added: 0114522
2019-02-28 21:46 Jonas Maebe Status new => resolved
2019-02-28 21:46 Jonas Maebe Fixed in Version => 3.3.1
2019-02-28 21:46 Jonas Maebe Resolution open => fixed
2019-02-28 21:46 Jonas Maebe Assigned To => Jonas Maebe
2019-02-28 23:10 Karl-Michael Schindler Note Added: 0114530
2019-02-28 23:10 Karl-Michael Schindler Status resolved => closed