View Issue Details

IDProjectCategoryView StatusLast Update
0035168PackagesLCLpublic2020-06-06 20:31
ReporterKevin Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionunable to reproduce 
OSmacOS 
Product Version2.1 (SVN) 
Summary0035168: IDE Hangs when inserting comment
DescriptionThe IDE hangs completely (ie. I get the rainbow circle of death) when I try to enter a comment using '(*'.
Steps To Reproduce1. Place cursor where you want to start comment
2. enter the first character of the comment symbol, ie. '('
3. The IDE freezes with the rainbow circle of death

The only fix I have found is to force/quite Lazarus.
Additional InformationIt happens sometimes (generally in the same location, I have no idea why, obviously).
If I put a comment using '(*' at another location, there is a good chance it will work.

The code has many '(*.....*)' comment blocks.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Juha Manninen

2019-03-01 08:02

developer   ~0114533

> It happens sometimes (generally in the same location ...

Which location? You should give example source code and exact steps to reproduce.
It does not sound like a widgetset dependent problem. Did you test with other widgetsets?

Martin Friebe

2019-03-03 00:40

manager   ~0114590

Last edited: 2019-03-03 00:51

View 2 revisions

See Juha's comment.

Also, if you can not exact provide steps to reproduce, then please produce a backtrace.

1) Compile your IDE with debug info.
Menu: Tools > Configure build lazarus
Add the option: -gw -gl -Criot
And check "clean all"
Then build, and restart the IDE

2) When the IDE hangs.
Open a new terminal, start lldb (or gdb if you prefer).

Attach to the IDE
 process attach --name Lazarus

See: https://developer.apple.com/library/archive/documentation/IDEs/Conceptual/gdb_to_lldb_transition_guide/document/lldb-terminal-workflow-tutorial.html

LLDB should pause the IDE. Run

thread list

for each thread (replace 1 by the thread id)

thread select 1
thread backtrace

Provide the entire output, in a zipped text file.

Note at least some of the backtraces must have filename (ending in pas or pp) and line numbers.
If not, then the backtrace is not useful at all.

----------
Also run the IDE itself from a terminal, and report any output it prints to the terminal.

Something like
path/to/lazarus/Content/MacOs/lazarus

----------
Without either steps to reproduce, or a useful stacktrace it is not possible to do anything to fix the issue.
Further feedback may be required...

Bart Broersma

2019-12-16 11:43

developer   ~0119881

No feedback in a reasonable time, resolving.

Issue History

Date Modified Username Field Change
2019-03-01 01:29 Kevin New Issue
2019-03-01 08:02 Juha Manninen Note Added: 0114533
2019-03-03 00:40 Martin Friebe LazTarget => -
2019-03-03 00:40 Martin Friebe Note Added: 0114590
2019-03-03 00:40 Martin Friebe Status new => feedback
2019-03-03 00:51 Martin Friebe Note Edited: 0114590 View Revisions
2019-12-16 11:43 Bart Broersma Assigned To => Bart Broersma
2019-12-16 11:43 Bart Broersma Status feedback => resolved
2019-12-16 11:43 Bart Broersma Resolution open => unable to reproduce
2019-12-16 11:43 Bart Broersma Widgetset Cocoa => Cocoa
2019-12-16 11:43 Bart Broersma Note Added: 0119881