View Issue Details

IDProjectCategoryView StatusLast Update
0035201LazarusIDEpublic2019-03-09 12:30
ReporterJohn Shand Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSUSE Tumbleweed 
Product Version2.0 
Summary0035201: Lazarus Startup Error
DescriptionWhen you start this application i now get:

Cannot execute empty command-line in a message box.
Steps To ReproduceFind the Lazarus IDE shortcut and click on it
TagsNo tags attached.
Fixed in Revisionr60577
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0035184 closedMattias Gaertner error on startlazarus 

Activities

John Shand

2019-03-07 10:02

reporter   ~0114694

Last edited: 2019-03-07 10:03

View 2 revisions

FPC Version: 3.2.0 fixes build 41623

LAZARUS Version: 2.0.1 fixes build 60608

Cyrax

2019-03-07 10:10

reporter   ~0114695

Related bug report : https://bugs.freepascal.org/view.php?id=35184

John Shand

2019-03-07 10:46

reporter   ~0114696

exactly what i was experiencing. thanks

Mattias Gaertner

2019-03-07 11:56

manager   ~0114697

So, is this a duplicate of 35184?

Zeljan Rikalo

2019-03-07 12:52

developer   ~0114698

hm...he is using fixes r60608. Is r60577 merged into fixes ? @John can you test with trunk lazarus ?

John Shand

2019-03-07 23:27

reporter   ~0114705

works with trunk, but fixes branch isn't fixed yet

Juha Manninen

2019-03-08 13:18

developer   ~0114710

r60535 was merged to fixes branch, r60577 must be merged, too.
I added it to be merged here:
 http://wiki.freepascal.org/Lazarus_2.0_fixes_branch#Submitted_by_developer_.2F_committer.2C_tested.2C_waiting_to_be_merged

Please follow the wiki page and the SVN fixes branch.
Resolving this one.

John Shand

2019-03-09 09:03

reporter   ~0114733

Hey has this fixed issue been merged to the fixes branch yet? i still cannot start lazarus without a messagebox saying abort or ok

John Shand

2019-03-09 09:04

reporter   ~0114734

this is still not merged yet

Juha Manninen

2019-03-09 12:30

developer   ~0114738

It is marked for merging. Please read what I wrote.

Issue History

Date Modified Username Field Change
2019-03-07 10:01 John Shand New Issue
2019-03-07 10:02 John Shand Note Added: 0114694
2019-03-07 10:03 John Shand Note Edited: 0114694 View Revisions
2019-03-07 10:10 Cyrax Note Added: 0114695
2019-03-07 10:46 John Shand Note Added: 0114696
2019-03-07 11:56 Mattias Gaertner Note Added: 0114697
2019-03-07 12:52 Zeljan Rikalo Note Added: 0114698
2019-03-07 23:27 John Shand Note Added: 0114705
2019-03-08 00:36 Maxim Ganetsky LazTarget => -
2019-03-08 00:36 Maxim Ganetsky Summary Lazaarus Startup Error => Lazarus Startup Error
2019-03-08 13:10 Juha Manninen Relationship added duplicate of 0035184
2019-03-08 13:18 Juha Manninen Note Added: 0114710
2019-03-08 13:18 Juha Manninen Fixed in Revision => r60577
2019-03-08 13:18 Juha Manninen Status new => resolved
2019-03-08 13:18 Juha Manninen Resolution open => fixed
2019-03-08 13:18 Juha Manninen Assigned To => Juha Manninen
2019-03-09 09:03 John Shand Note Added: 0114733
2019-03-09 09:04 John Shand Note Added: 0114734
2019-03-09 09:04 John Shand Status resolved => assigned
2019-03-09 09:04 John Shand Resolution fixed => reopened
2019-03-09 12:30 Juha Manninen Note Added: 0114738
2019-03-09 12:30 Juha Manninen Status assigned => resolved
2019-03-09 12:30 Juha Manninen Resolution reopened => fixed