View Issue Details

IDProjectCategoryView StatusLast Update
0035246FPCDatabasepublic2019-10-09 07:26
ReporterArtemijAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.0.4Product Build 
Target VersionFixed in Version3.3.1 
Summary0035246: error on destroy transaction and connection
DescriptionHello! I found errors in the destruction of a transaction and the connection arises if after the start of the transaction the connection is broken.
Steps To Reproducebreak the connection to the server mysql at the time of execution SLEEP
(sample.pas:32)
TagsNo tags attached.
Fixed in Revision42944
FPCOldBugId
FPCTarget3.2.0
Attached Files

Relationships

parent of 0036148 resolvedMichael Van Canneyt Regression in MSSQL: transactions are not committed 
related to 0033737 resolvedMichael Van Canneyt TPQConnection.Close(true) doesn't work if connection to server is severed 

Activities

Artemij

2019-03-19 07:21

reporter  

sql_bug.zip (1,383 bytes)

Michael Van Canneyt

2019-03-19 09:33

administrator   ~0114921

If an exception occurs during close of the connection (because of a lost connection), this is normal.

Did you try setting ForcedClose:=True or calling

Close(True);

on the connection ?

Please try that and report back..

Michael Van Canneyt

2019-09-08 12:01

administrator   ~0117986

Did a fix, test program now runs OK

Issue History

Date Modified Username Field Change
2019-03-19 07:21 Artemij New Issue
2019-03-19 07:21 Artemij File Added: sql_bug.zip
2019-03-19 09:30 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-03-19 09:30 Michael Van Canneyt Status new => assigned
2019-03-19 09:33 Michael Van Canneyt Note Added: 0114921
2019-03-19 09:33 Michael Van Canneyt Status assigned => feedback
2019-09-08 12:01 Michael Van Canneyt Status feedback => resolved
2019-09-08 12:01 Michael Van Canneyt Resolution open => fixed
2019-09-08 12:01 Michael Van Canneyt Fixed in Version => 3.3.1
2019-09-08 12:01 Michael Van Canneyt Fixed in Revision => 42944
2019-09-08 12:01 Michael Van Canneyt FPCTarget => 3.2.0
2019-09-08 12:01 Michael Van Canneyt Note Added: 0117986
2019-09-08 12:14 Michael Van Canneyt Relationship added related to 0033737
2019-10-09 07:26 Ondrej Pokorny Relationship added parent of 0036148