View Issue Details

IDProjectCategoryView StatusLast Update
0035254LazarusIDEpublic2019-07-08 22:06
ReporterJulian PuhlAssigned ToJoost van der Sluis 
Status assignedResolutionopen 
Platformi386OSWindowsOS Version7
Product Version2.1 (SVN)Product Build60740 
Target VersionFixed in Version 
Summary0035254: Always getting "the Fppkg configuration is corrupt" setup dialog
DescriptionSince the last fpc package changes I always get this error. My fpc is located at E:\Coding\fpc_svn
The source is located at E:\Coding\fpc_svn\source and make installs to E:\Coding\fpc_svn. Every time I have to select E:\Coding\fpc_svn and then can run Lazarus. The default path which is shown is E:\Coding. I have no idea what broke this. It worked for years.
TagsNo tags attached.
Fixed in Revision
Attached Files


Julian Puhl

2019-04-11 09:38

reporter   ~0115419

Last edited: 2019-04-11 09:40

View 2 revisions

With the recent changes I am always getting the error:
"Warning: Failed to retrieve the version of the fpcmkcfg configuration tool. It is probably too old to create the configuration files. Make sure a recent version is installed and available in the path or alongside the compiler-executable."

But the mentioned tool supports -V and is current fpc trunk build. fpcmkcfg -V outputs "Version: 3.3.1".

I am unable to launch Lazarus anymore.

Bart Broersma

2019-04-11 18:06

developer   ~0115429

At some point in time it tested it version was above 3.3.1.
AFAIK it was resolved in trunk.

Julian Puhl

2019-04-19 11:29

reporter   ~0115670

With a fresh checkout from this morning (both fpc and lazarus) it shows a correct fppkg.cfg path, I can launch lazarus and everything works. I get this message for each launch, though:
"Datei: C:\Users\xxxxx\AppData\Local\FreePascal\fppkg\fppkg.cfg

Fehler: there is a problem with the Fppkg configuration. (Fppkg reports that the RTL is not installed.)

You could try to restore the configuration files automatically, or adapt the configuration file manually."

If I select "Restore Fppkg configuration" I still am getting the same error as in my initial report.

I'll try to debug and see what is happening here.

Also I see a problem with the fppkg.cfg path: I do have multiple fpc versions installed. E.g. 3.0.4 for the initial compilation step of the fpc svn version. But this probably is the wrong place to discuss that.

Julian Puhl

2019-04-19 13:27

reporter   ~0115671

I narrowed it down to "FindDefaultExecutablePath" which gets called by "FindFPCTool". The FPC 3.0.4 installation seems to have added its path to the windows environment "Path" variable. So every time "FindDefaultExecutablePath" returned the wrong path of the old fpc version. Now that I have removed the entry from the "Path" environment variable it works. This should probably get fixed?

Joost van der Sluis

2019-07-08 22:06

manager   ~0117117

FindFPCTool should use the path of the compiler that is configured in Lazarus? Doesn't it do that?

Issue History

Date Modified Username Field Change
2019-03-21 09:38 Julian Puhl New Issue
2019-04-11 09:38 Julian Puhl Note Added: 0115419
2019-04-11 09:40 Julian Puhl Note Edited: 0115419 View Revisions
2019-04-11 18:06 Bart Broersma Note Added: 0115429
2019-04-11 18:06 Bart Broersma Assigned To => Joost van der Sluis
2019-04-11 18:06 Bart Broersma Status new => assigned
2019-04-19 11:29 Julian Puhl Note Added: 0115670
2019-04-19 13:27 Julian Puhl Note Added: 0115671
2019-07-08 22:06 Joost van der Sluis Note Added: 0117117