View Issue Details

IDProjectCategoryView StatusLast Update
0035265FPCDocumentationpublic2019-03-26 22:20
ReporterKai BurghardtAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSGNU/LinuxOS Version4.2.0
Product Version3.0.4Product Build3.0.4+dfsg-11 [2017/12/30] 
Target Version3.2.0Fixed in Version3.3.1 
Summary0035265: documentation orthography unification: stick to American English spelling
DescriptionThroughout the documentation the words
* initializ.*
* finalized
* localized
* specializ.*
* summarize[sd]
* organized
are all written always with a Z. However, some words (see the attached patch) don't follow this AE-spelling dominance.
Tagsdocumentation
Fixed in Revision1571
FPCOldBugId
FPCTarget
Attached Files
  • doc.patch (5,298 bytes)
    --- ref.tex~	2019-03-24 01:37:00.184546085 +0000
    +++ ref.tex	2019-03-24 01:37:00.184546085 +0000
    @@ -296,8 +296,8 @@
     will accept any combination of upper or lower case letters for reserved words.
     
     We make a distinction between \tp and \delphi reserved words. In \var{TP} mode, 
    -only the \tp reserved words are recognised, but the \delphi ones can be redefined. 
    -By default, \fpc recognises the \delphi reserved words.
    +only the \tp reserved words are recognized, but the \delphi ones can be redefined. 
    +By default, \fpc recognizes the \delphi reserved words.
     
     \subsection{Turbo Pascal reserved words}
     \index{Reserved words!Turbo Pascal}
    @@ -12849,7 +12849,7 @@
     \end{verbatim}
     The assembler instructions between the \var{Asm} and \var{end} keywords will
     be inserted in the assembler generated by the compiler.
    -Conditionals can be used in assembler code, the compiler will recognise them,
    +Conditionals can be used in assembler code, the compiler will recognize them,
     and treat them as any other conditionals.
     
     %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
    --- prog.tex~	2019-03-24 01:37:00.184546085 +0000
    +++ prog.tex	2019-03-24 01:37:00.184546085 +0000
    @@ -1933,7 +1933,7 @@
     
     \subsection{\var{\protect\$DESCRIPTION} : Application description}
     
    -This switch is recognised for compatibility only, but is ignored completely
    +This switch is recognized for compatibility only, but is ignored completely
     by the compiler. At a later stage, this switch may be activated.
     
     \subsection{\var{\protect\$E} : Emulation of coprocessor}
    @@ -1990,7 +1990,7 @@
     
     \subsection{\var{\protect\$G} : Generate 80286 code}
     
    -This option is recognised for Turbo Pascal compatibility, but is ignored,
    +This option is recognized for Turbo Pascal compatibility, but is ignored,
     since the compiler works only on 32-bit and 64-bit processors.
     
     \subsection{\var{\protect\$IMAGEBASE} : Specify DLL image base location.}
    @@ -2034,7 +2034,7 @@
     \subsection{\var{\protect\$L} or \var{\protect\$LOCALSYMBOLS} : Local symbol information}
     
     This switch (not to be confused with the local \var{\{\$L file\}} file linking
    -directive) is recognised for Turbo Pascal compatibility, but is ignored.
    +directive) is recognized for Turbo Pascal compatibility, but is ignored.
     Generation of symbol information is controlled by the \var{\$D} switch.
     
     \subsection{\var{\protect\$LIBPREFIX} : Specify library filename prefix.}
    @@ -2241,13 +2241,13 @@
     
     \subsection{\var{\protect\$N} : Numeric processing }
     
    -This switch is recognised for Turbo Pascal compatibility, but is otherwise
    +This switch is recognized for Turbo Pascal compatibility, but is otherwise
     ignored, since the compiler always uses the coprocessor for floating point
     mathematics.
     
     \subsection{\var{\protect\$O} : Level 2 Optimizations }
     
    -In earlier versions of FPC, this switch was recognised for Turbo Pascal 
    +In earlier versions of FPC, this switch was recognized for Turbo Pascal 
     compatibility, but was otherwise ignored: The concept of overlay code 
     is not needed in 32-bit or 64-bit programs.
     
    @@ -6965,7 +6965,7 @@
     always stored in the ppu files. This means that it is possible to use a 
     generic RTL for WPO (or, in general, any compiled unit). It does mean that 
     the RTL itself will then not be optimised, the compiled program code and 
    -its units can be correctly optimised because the compiler knows everything 
    +its units can be correctly optimized because the compiler knows everything 
     it has to know about all RTL units.
     \item The generated WPO feedback file is plain text. The idea is that it should
     be easy to inspect this file by hand, and to add information to it produced
    @@ -7056,7 +7056,7 @@
     This option has 2 limitations:
     \begin{enumerate}
     \item Methods that are published, or getters/setters of published properties, can
    -never be optimised in this way, because they can always be referred to and
    +never be optimized in this way, because they can always be referred to and
     called via the RTTI (which the compiler cannot detect). 
     \item Such optimisations are not yet done for virtual class methods.
     \end{enumerate}
    @@ -8465,7 +8465,7 @@
     \subsection{Directory variables}
     
     The first set of variables controls the directories that are
    -recognised in the makefile. They should not be set in the
    +recognized in the makefile. They should not be set in the
     \file{Makefile.fpc} file, but can be specified on the command line.
     \begin{description}
     \item[INCDIR] This is a list of directories, separated by spaces, that will
    @@ -8486,7 +8486,7 @@
     
     \subsection{Compiler command line variables }
     The following variables can be set on the \file{make} command line,
    -they will be recognised and integrated in the compiler command line options.:
    +they will be recognized and integrated in the compiler command line options.:
     
     \begin{description}
     \item[CREATESMART] If this variable is defined, it tells the compiler to 
    @@ -9057,7 +9057,7 @@
     \end{verbatim}
     
     Some other command line options can be used, but the above are the
    -minimum. A list of recognised options can be found in \seet{FPCdefines}.
    +minimum. A list of recognized options can be found in \seet{FPCdefines}.
     
     \begin{FPCltable}{ll}{Possible defines when compiling FPC}{FPCdefines}
     Define & does what \\ \hline
    
    doc.patch (5,298 bytes)
  • ref.tex.patch (3,908 bytes)
    --- ref.tex~	2019-03-24 01:37:00.184546085 +0000
    +++ ref.tex	2019-03-24 16:10:19.083694320 +0000
    @@ -1117,7 +1117,7 @@
     \end{verbatim}
     Here \var{Func} is a function which returns a \var{Boolean} type.
     
    -This behaviour is controllable by the \var{\{\$B \}} compiler directive.
    +This behavior is controllable by the \var{\{\$B \}} compiler directive.
     \end{remark}
     
     \subsubsection{Enumeration types}
    @@ -1165,7 +1165,7 @@
     compiler error.
     \item Enumeration types are stored using a default, independent of the
     actual number of values: the compiler does not try to optimize for space.
    -This behaviour can be changed with the \var{\{\$PACKENUM n\}} compiler 
    +This behavior can be changed with the \var{\{\$PACKENUM n\}} compiler 
     directive, which tells the compiler the minimal number of bytes to be 
     used for enumeration types.
     For instance
    @@ -3297,7 +3297,7 @@
     \item Local initialized variables are initialized each time the procedure is
     entered.
     \end{itemize}
    -Note that the behaviour for local initialized variables is different from
    +Note that the behavior for local initialized variables is different from
     the one of a local typed constant. A local typed constant behaves like a
     global initialized variable.
     
    @@ -3320,7 +3320,7 @@
     \end{enumerate}
     \end{remark}
     
    -Note that the behaviour of zeroing out certain variables can result in invalid 
    +Note that the behavior of zeroing out certain variables can result in invalid 
     content for variables:
     \begin{verbatim}
     Type
    @@ -6960,7 +6960,7 @@
     home: >myb
     mya.DoLocalThings
     \end{verbatim}
    -This behaviour is dictated by safety and necessity:
    +This behavior is dictated by safety and necessity:
     \begin{enumerate}
     \item A programmer specializing a class has no way of knowing which local
     procedures are used, so he cannot accidentally 'override' it.
    @@ -8379,7 +8379,7 @@
     \begin{verbatim}
       a := g(3) + f(2);
     \end{verbatim}
    -\var{f(2)} may be executed before \var{g(3)}. This behaviour is distinctly
    +\var{f(2)} may be executed before \var{g(3)}. This behavior is distinctly
     different from \delphi{} or \tp{}.
     
     If one expression {\em must} be executed before the other, it is necessary
    @@ -8523,7 +8523,7 @@
       If F()=Addone then
         WriteLn ('Functions return same values ');
     \end{verbatim}
    -Remark that this last behaviour is not compatible with \delphi syntax. 
    +Remark that this last behavior is not compatible with \delphi syntax. 
     Switching on \var{Delphi} mode will allow you to use \delphi syntax.
     
     %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
    @@ -8581,7 +8581,7 @@
     boolean(100);
     Word(@Buffer);
     \end{verbatim}
    -This is compatible with \delphi or \tp behaviour.
    +This is compatible with \delphi or \tp behavior.
     
     %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
     % Variable typecasts
    @@ -8709,7 +8709,7 @@
     end; 
     \end{verbatim}
     By default, the address operator must be used if a value must be assigned
    -to a procedural type variable. This behaviour can be avoided by using the
    +to a procedural type variable. This behavior can be avoided by using the
     \var{-Mtp} or \var{-MDelphi} switches, which result in a more compatible 
     \delphi or \tp syntax.
     
    @@ -10427,7 +10427,7 @@
     \begin{verbatim}
     Something else
     \end{verbatim}
    -This behaviour is by design.
    +This behavior is by design.
     \end{remark}
     
     Constant parameters can also be untyped. See \sees{varparams} for more
    @@ -11775,7 +11775,7 @@
     Since the types of \var{Z} and \var{R} don't match the types in the
     operator definition.
     
    -The reason for this behaviour is that it is possible that a multiplication
    +The reason for this behavior is that it is possible that a multiplication
     is not always commutative. E.g. the multiplication of a \var{(n,m)} with a
     \var{(m,n)} matrix will result in a \var{(n,n)} matrix, while the
     multiplication of a \var{(m,n)} with a \var{(n,m)} matrix is a \var{(m,m)}
    
    ref.tex.patch (3,908 bytes)
  • prog.tex.patch (3,460 bytes)
    --- prog.tex~	2019-03-24 01:37:00.184546085 +0000
    +++ prog.tex	2019-03-24 16:10:19.083694320 +0000
    @@ -135,7 +135,7 @@
     Local directives can occur more than once in a unit or program,
     If they have a command line counterpart, the command line argument is
     restored as the default for each compiled file. The local directives
    -influence the compiler's behaviour from the moment they're encountered
    +influence the compiler's behavior from the moment they're encountered
     until the moment another switch annihilates their behaviour, or the end
     of the current unit or program is reached.
     
    @@ -625,7 +625,7 @@
     \var{\{\$H\}}: a \var{\{\$MODE DELPHI\}} directive implies a
     \var{\{\$H+\}} statement, all other modes switch it off. As a result,
     you should always put \var{\{\$H+\}} after a mode directive. 
    -This behaviour has changed, in older \fpc versions this was not so. 
    +This behavior has changed, in older \fpc versions this was not so. 
     
     \subsection{\var{\protect\$HINT} : Generate hint message}
     
    @@ -795,7 +795,7 @@
     
     The \var{\{\$I-\}} or \var{\{\$IOCHECKS OFF\}} directive tells the compiler
     not to generate input/output checking code in the program. By default, the
    -compiler generates I/O checking code. This behaviour can be controlled
    +compiler generates I/O checking code. This behavior can be controlled
     globally with the \var{-Ci} switch.
     
     When compiling using the \var{-Ci} compiler switch, the \fpc compiler inserts
    @@ -1469,7 +1469,7 @@
     When an overflow occurs, the run-time library will generate a run-time error 215: 
     it prints a message \var{Overflow at xxx}, and exits the program with exit code 215.
     
    -\begin{remark}Overflow checking behaviour is not the same as in
    +\begin{remark}Overflow checking behavior is not the same as in
     Turbo Pascal since all arithmetic operations are done via 32-bit or
     64-bit values. Furthermore, the \var{Inc()} and \var{Dec} standard system
     procedures {\em are} checked for overflow in \fpc, while in Turbo
    @@ -2759,7 +2759,7 @@
     In MacPas mode, compile time variables can be defined. They are distinct
     from symbols in that they have a value, and they are distinct from macros,
     in that they cannot be used to replace portions of the source text with
    -their value. Their behaviour is compatible with compile time variables 
    +their value. Their behavior is compatible with compile time variables 
     found in popular pascal compilers for Macintosh. 
     
     A compile time variable is defined like this:
    @@ -5651,7 +5651,7 @@
     \item[FreememSize] This function should release the memory pointed to by
     \var{P}. The argument \var{Size} is the expected size of the memory block
     pointed to by P. This should be disregarded, but can be used to check the
    -behaviour of the program.
    +behavior of the program.
     \item[AllocMem] Is the same as getmem, only the allocated memory should
     be filled with zeros before the call returns.
     \item[ReAllocMem] Should allocate a memory block of the specified \var{Size},
    @@ -5659,7 +5659,7 @@
     \var{P}, truncating this to the new size of needed. After that, the memory
     pointed to by P may be deallocated. The return value is a pointer to the
     new memory block. Note that \var{P} may be \var{Nil}, in which case the
    -behaviour is equivalent to \var{GetMem}.
    +behavior is equivalent to \var{GetMem}.
     \item[MemSize] should return the size of the memory block \var{P}.
     This function may return zero if the memory manager does not allow 
     to determine this information.
    
    prog.tex.patch (3,460 bytes)
  • user.tex.patch (1,898 bytes)
    --- user.tex~	2019-03-24 16:06:46.832551266 +0000
    +++ user.tex	2019-03-24 16:10:19.083694320 +0000
    @@ -891,7 +891,7 @@
     % Units libraries and smartlinking
     \section{Units, libraries and smartlinking}
     The \fpc compiler supports smartlinking and the creation of libraries.
    -However, the default behaviour is to compile each unit into one big object
    +However, the default behavior is to compile each unit into one big object
     file, which will be linked as a whole into your program.
     Shared libraries can be created on most platforms, although current level
     of FPC support may vary (they are e.g. not supported for GO32v2 and OS2
    @@ -2826,7 +2826,7 @@
     The \file{infile} parameter is the Pascal file to be processed, and will be written
     to \file{outfile}, overwriting an existing \file{outfile} if it exists.
     
    -Some options modify the behaviour of ptop:
    +Some options modify the behavior of ptop:
     
     \begin{description}
     \item[-h] Write an overview of the possible parameters and command line syntax.
    @@ -2845,7 +2845,7 @@
     \subsection{The ptop configuration file}
     
     Creating and distributing a configuration file for ptop is not necessary,
    -unless you want to modify the standard behaviour of \file{ptop}. The configuration
    +unless you want to modify the standard behavior of \file{ptop}. The configuration
     file is never preloaded, so if you want to use it you should always specify
     it with a \var{-c ptop.cfg} parameter.
     
    @@ -4037,7 +4037,7 @@
     \begin{itemize}
     \item if you call \var{Dispose} or \var{Freemem} with an invalid pointer
     \item in case \var{New} or \var{GetMem} is called, and there is no more memory 
    -available. The behaviour in this case depends on the setting of 
    +available. The behavior in this case depends on the setting of 
     \var{ReturnNilIfGrowHeapFails}. If it is \var{True}, then \var{Nil} is returned. 
     if \var{False}, then runerror 204 is raised.
     \end{itemize}
    
    user.tex.patch (1,898 bytes)
  • fpdoc.tex.patch (976 bytes)
    --- fpdoc.tex~	2019-03-24 16:28:42.220006164 +0000
    +++ fpdoc.tex	2019-03-24 16:28:42.220006164 +0000
    @@ -812,7 +812,7 @@
     \label{suse:disableprivate}
     If this option is specified, then no \tag{element} tags will be generated
     for private methods or fields of classes or objects. 
    -The default behaviour is to generate nodes for private methods or fields.
    +The default behavior is to generate nodes for private methods or fields.
     It can be used to generate a skeleton for end-user and developer
     documentation.
     
    @@ -1905,7 +1905,7 @@
     
     Note that if a description node contains a \tag{table}, \tag{pre}, \tag{code}
     or any list tag, then the text surrounding these tags {\em must} be  put 
    -inside a \tag{p} paragraph tag. This is different from the behaviour in HTML.
    +inside a \tag{p} paragraph tag. This is different from the behavior in HTML.
     
     The paragraph tag must always have an opening tag and a closing tag, unlike
     html where only the opening tag may be present.
    
    fpdoc.tex.patch (976 bytes)
  • ide.tex.patch (4,126 bytes)
    --- ide.tex~	2019-03-24 16:44:00.481561571 +0000
    +++ ide.tex	2019-03-24 16:44:00.481561571 +0000
    @@ -347,7 +347,7 @@
     In many cases the IDE displays a dialog window to get user input.
     The main difference to normal windows is that other windows cannot be
     activated while a dialog is active. Also the menu is not accessible while in
    -a dialog. This behaviour is called \emph{modal}. To activate another window,
    +a dialog. This behavior is called \emph{modal}. To activate another window,
     the modal window or dialog must be closed first.
     
     A typical dialog window is shown in \seefig{idedlg}.
    @@ -658,12 +658,12 @@
     be set. These directories will be used when a program or unit is compiled.
     \item[Browser]
     Presents a dialog where the browser options can be set. The browser options
    -affect the behaviour of the symbol browser of the IDE.
    +affect the behavior of the symbol browser of the IDE.
     \item[Tools]
     Presents a dialog to configure the tools menu. For more information, see
     \sees{addingtools}.
     \item[Environment]
    -Presents a dialog to configure the behaviour of the IDE. A sub menu is
    +Presents a dialog to configure the behavior of the IDE. A sub menu is
     presented with the various aspects of the IDE:
     \begin{description}
     \item[Preferences]
    @@ -677,7 +677,7 @@
     \item[Codetemplates]
     Used to define code templates, which can be inserted in an edit window.
     \item[Desktop]
    -Used to control the behaviour of the desktop, i.e. several features can be
    +Used to control the behavior of the desktop, i.e. several features can be
     switched on or off.
     \item[Keyboard \& Mouse] Can be used to select the cut/copy/paste
     convention, control the actions of the mouse, and to assign commands 
    @@ -862,7 +862,7 @@
     \label{se:syntaxhighlighting}
     The IDE is capable of syntax highlighting, i.e. the color of certain
     Pascal elements can be set. As text is entered in an editor window,
    -the IDE will try to recognise the elements, and set the color of the
    +the IDE will try to recognize the elements, and set the color of the
     text accordingly.
     
     
    @@ -1062,7 +1062,7 @@
     After the desired location has been reached, the browser window can be closed
     with the usual commands.
     
    -The behaviour of the browser can be customized with the browser options
    +The behavior of the browser can be customized with the browser options
     dialog, using the \menu{Options|Browser} menu.
     The browser options dialog looks like \seefig{obrowser}.
     
    @@ -1770,7 +1770,7 @@
     only the syntax of the current source should be checked.
     
     The menu item \menu{Compiler|Clear primary file} restores the default
    -behaviour of the IDE, i.e. the 'compile' and 'run' commands apply to the
    +behavior of the IDE, i.e. the 'compile' and 'run' commands apply to the
     active window.
     %
     % The directory dialog
    @@ -2279,7 +2279,7 @@
     % Editor customization
     %
     \subsection{The Editor}
    -Several aspects of the editor window behaviour can be set in this dialog.
    +Several aspects of the editor window behavior can be set in this dialog.
     The editor preferences dialog is shown in \seefig{oeeditor}. Note that
     some of these options affect only newly opened windows, not already 
     opened windows (e.g. Vertical Blocks, Highlight Column/Row).
    @@ -2362,7 +2362,7 @@
     \subsection{Keyboard \& Mouse}
     \label{se:prefmouse}
     The Keyboard \& mouse options dialog is called by the menu item
    -\menu{Options|Environment|Keyboard \& Mouse}. It allows adjusting the behaviour of the
    +\menu{Options|Environment|Keyboard \& Mouse}. It allows adjusting the behavior of the
     keyboard and mouse as well as the sensitivity of the mouse.
     The keyboard and mouse options dialog is shown in \seefig{oemouse}.
     
    @@ -2380,7 +2380,7 @@
     time between two clicks is very short; slow means that the time between two
     mouse clicks can be quite long.
     \item[Reverse mouse buttons]
    -the behaviour of the left and right mouse buttons can be swapped by
    +the behavior of the left and right mouse buttons can be swapped by
     by checking the checkbox; this is especially useful for left-handed people.
     \item[Ctrl+Right mouse button]
     Assigns an action to a right mouse button click while holding the
    
    ide.tex.patch (4,126 bytes)
  • gorp.tex.patch (778 bytes)
    --- prog.tex~	2019-03-24 16:46:32.359802334 +0000
    +++ prog.tex	2019-03-24 16:46:32.359802334 +0000
    @@ -4261,10 +4261,10 @@
     \section{Entry and exit code}
     
     Each Pascal procedure and function begins and ends with standard
    -epilogue and prologue code.
    +epilog and prolog code.
     
     
    -\subsection{Intel 80x86 standard routine prologue / epilogue}
    +\subsection{Intel 80x86 standard routine prolog / epilog}
     Standard entry code for procedures and functions is as follows on the
     80x86 architecture:
     \begin{verbatim}
    @@ -4284,7 +4284,7 @@
     \sees{RegConvs}.
     
     
    -\subsection{Motorola 680x0 standard routine prologue / epilogue}
    +\subsection{Motorola 680x0 standard routine prolog / epilog}
     
     Standard entry code for procedures and functions is as follows on the
     680x0 architecture:
    
    gorp.tex.patch (778 bytes)

Activities

Kai Burghardt

2019-03-24 02:41

reporter  

doc.patch (5,298 bytes)
--- ref.tex~	2019-03-24 01:37:00.184546085 +0000
+++ ref.tex	2019-03-24 01:37:00.184546085 +0000
@@ -296,8 +296,8 @@
 will accept any combination of upper or lower case letters for reserved words.
 
 We make a distinction between \tp and \delphi reserved words. In \var{TP} mode, 
-only the \tp reserved words are recognised, but the \delphi ones can be redefined. 
-By default, \fpc recognises the \delphi reserved words.
+only the \tp reserved words are recognized, but the \delphi ones can be redefined. 
+By default, \fpc recognizes the \delphi reserved words.
 
 \subsection{Turbo Pascal reserved words}
 \index{Reserved words!Turbo Pascal}
@@ -12849,7 +12849,7 @@
 \end{verbatim}
 The assembler instructions between the \var{Asm} and \var{end} keywords will
 be inserted in the assembler generated by the compiler.
-Conditionals can be used in assembler code, the compiler will recognise them,
+Conditionals can be used in assembler code, the compiler will recognize them,
 and treat them as any other conditionals.
 
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
--- prog.tex~	2019-03-24 01:37:00.184546085 +0000
+++ prog.tex	2019-03-24 01:37:00.184546085 +0000
@@ -1933,7 +1933,7 @@
 
 \subsection{\var{\protect\$DESCRIPTION} : Application description}
 
-This switch is recognised for compatibility only, but is ignored completely
+This switch is recognized for compatibility only, but is ignored completely
 by the compiler. At a later stage, this switch may be activated.
 
 \subsection{\var{\protect\$E} : Emulation of coprocessor}
@@ -1990,7 +1990,7 @@
 
 \subsection{\var{\protect\$G} : Generate 80286 code}
 
-This option is recognised for Turbo Pascal compatibility, but is ignored,
+This option is recognized for Turbo Pascal compatibility, but is ignored,
 since the compiler works only on 32-bit and 64-bit processors.
 
 \subsection{\var{\protect\$IMAGEBASE} : Specify DLL image base location.}
@@ -2034,7 +2034,7 @@
 \subsection{\var{\protect\$L} or \var{\protect\$LOCALSYMBOLS} : Local symbol information}
 
 This switch (not to be confused with the local \var{\{\$L file\}} file linking
-directive) is recognised for Turbo Pascal compatibility, but is ignored.
+directive) is recognized for Turbo Pascal compatibility, but is ignored.
 Generation of symbol information is controlled by the \var{\$D} switch.
 
 \subsection{\var{\protect\$LIBPREFIX} : Specify library filename prefix.}
@@ -2241,13 +2241,13 @@
 
 \subsection{\var{\protect\$N} : Numeric processing }
 
-This switch is recognised for Turbo Pascal compatibility, but is otherwise
+This switch is recognized for Turbo Pascal compatibility, but is otherwise
 ignored, since the compiler always uses the coprocessor for floating point
 mathematics.
 
 \subsection{\var{\protect\$O} : Level 2 Optimizations }
 
-In earlier versions of FPC, this switch was recognised for Turbo Pascal 
+In earlier versions of FPC, this switch was recognized for Turbo Pascal 
 compatibility, but was otherwise ignored: The concept of overlay code 
 is not needed in 32-bit or 64-bit programs.
 
@@ -6965,7 +6965,7 @@
 always stored in the ppu files. This means that it is possible to use a 
 generic RTL for WPO (or, in general, any compiled unit). It does mean that 
 the RTL itself will then not be optimised, the compiled program code and 
-its units can be correctly optimised because the compiler knows everything 
+its units can be correctly optimized because the compiler knows everything 
 it has to know about all RTL units.
 \item The generated WPO feedback file is plain text. The idea is that it should
 be easy to inspect this file by hand, and to add information to it produced
@@ -7056,7 +7056,7 @@
 This option has 2 limitations:
 \begin{enumerate}
 \item Methods that are published, or getters/setters of published properties, can
-never be optimised in this way, because they can always be referred to and
+never be optimized in this way, because they can always be referred to and
 called via the RTTI (which the compiler cannot detect). 
 \item Such optimisations are not yet done for virtual class methods.
 \end{enumerate}
@@ -8465,7 +8465,7 @@
 \subsection{Directory variables}
 
 The first set of variables controls the directories that are
-recognised in the makefile. They should not be set in the
+recognized in the makefile. They should not be set in the
 \file{Makefile.fpc} file, but can be specified on the command line.
 \begin{description}
 \item[INCDIR] This is a list of directories, separated by spaces, that will
@@ -8486,7 +8486,7 @@
 
 \subsection{Compiler command line variables }
 The following variables can be set on the \file{make} command line,
-they will be recognised and integrated in the compiler command line options.:
+they will be recognized and integrated in the compiler command line options.:
 
 \begin{description}
 \item[CREATESMART] If this variable is defined, it tells the compiler to 
@@ -9057,7 +9057,7 @@
 \end{verbatim}
 
 Some other command line options can be used, but the above are the
-minimum. A list of recognised options can be found in \seet{FPCdefines}.
+minimum. A list of recognized options can be found in \seet{FPCdefines}.
 
 \begin{FPCltable}{ll}{Possible defines when compiling FPC}{FPCdefines}
 Define & does what \\ \hline
doc.patch (5,298 bytes)

J. Gareth Moreton

2019-03-24 05:34

developer   ~0115008

Why American English over Commonwealth English?

Michael Van Canneyt

2019-03-24 08:06

administrator   ~0115009

Last edited: 2019-03-24 08:06

View 2 revisions

Indeed, if anything I would prefer to have the British spelling.

J. Gareth Moreton

2019-03-24 11:59

developer   ~0115014

I'm British myself - truth be said, both the 'ise' and 'ize' variants are acceptable... in fact, the Oxford English Dictionary are fighting a losing battle in making the 'ize' versions standard due to it being closer to the Latin root or something!

It leads to some awkwardness though, since I say "Peephole Optimizer" because that is what it's called and is a compound name, and then I talk about optimisation in the same sentence!

The biggest rule though is making sure we don't drop the U from colour!

Michael Van Canneyt

2019-03-24 13:55

administrator   ~0115017

Well, as you point out, both -ise, -ize are acceptable in British English.
Therefor I intend to apply the patch. (need to check it in detail, though)

As far as I know, the -ise form is the oldest, I suppose it stems from French, which itself of course is rooted in Latin. It seems they agree at Oxford English Dictionary:
https://blog.oxforddictionaries.com/2011/03/28/ize-or-ise/

But I wholeheartedly agree that we should honour the colourful nature of our British neighbours ;)

Bart Broersma

2019-03-24 16:37

reporter   ~0115021

> But I wholeheartedly agree that we should honour the colourful nature of our British neighbours ;)

Does this still apply after the Brexit ;-)

J. Gareth Moreton

2019-03-24 17:05

developer   ~0115024

Last edited: 2019-03-24 17:09

View 2 revisions

Actually Michael, that link you provided confirms that -ize is older, not -ise. But -ise has been more widely adopted in British English.

And yes, it still applies after Brexit, if it happens. I don't know, it's a complete mess, but politics is for another day.

Kai Burghardt

2019-03-24 17:17

reporter   ~0115028

> Why American English over Commonwealth English?
Don't get emotional about the issue. It's a general rule, how to write documentation. I tried to guesstimate, what spelling prevails, and thereby I created the patch. Besides, also Pascal seems to favor AE, cf. the keywords “initialization”/“finalization” and “specialize”, but this doesn't mean _all_ Pascal-related documentation has to be in AE. It just should be uniform, though.

Imagine, let's say, someone wants to find out more about our great “peephole optimizer.” Does she perform a grep(1) on “optimizer” or “optimiser”? The reader's probably not aware of the spelling issue and will search for whatever they read first, thus left with an _incomplete_ result set, /not/ finding /all/ occurrences the optimizer's a topic.

The “-our” spelling wasn't too striking, apparently, but then I got even more diff-lines to add.

Kai Burghardt

2019-03-24 17:17

reporter  

ref.tex.patch (3,908 bytes)
--- ref.tex~	2019-03-24 01:37:00.184546085 +0000
+++ ref.tex	2019-03-24 16:10:19.083694320 +0000
@@ -1117,7 +1117,7 @@
 \end{verbatim}
 Here \var{Func} is a function which returns a \var{Boolean} type.
 
-This behaviour is controllable by the \var{\{\$B \}} compiler directive.
+This behavior is controllable by the \var{\{\$B \}} compiler directive.
 \end{remark}
 
 \subsubsection{Enumeration types}
@@ -1165,7 +1165,7 @@
 compiler error.
 \item Enumeration types are stored using a default, independent of the
 actual number of values: the compiler does not try to optimize for space.
-This behaviour can be changed with the \var{\{\$PACKENUM n\}} compiler 
+This behavior can be changed with the \var{\{\$PACKENUM n\}} compiler 
 directive, which tells the compiler the minimal number of bytes to be 
 used for enumeration types.
 For instance
@@ -3297,7 +3297,7 @@
 \item Local initialized variables are initialized each time the procedure is
 entered.
 \end{itemize}
-Note that the behaviour for local initialized variables is different from
+Note that the behavior for local initialized variables is different from
 the one of a local typed constant. A local typed constant behaves like a
 global initialized variable.
 
@@ -3320,7 +3320,7 @@
 \end{enumerate}
 \end{remark}
 
-Note that the behaviour of zeroing out certain variables can result in invalid 
+Note that the behavior of zeroing out certain variables can result in invalid 
 content for variables:
 \begin{verbatim}
 Type
@@ -6960,7 +6960,7 @@
 home: >myb
 mya.DoLocalThings
 \end{verbatim}
-This behaviour is dictated by safety and necessity:
+This behavior is dictated by safety and necessity:
 \begin{enumerate}
 \item A programmer specializing a class has no way of knowing which local
 procedures are used, so he cannot accidentally 'override' it.
@@ -8379,7 +8379,7 @@
 \begin{verbatim}
   a := g(3) + f(2);
 \end{verbatim}
-\var{f(2)} may be executed before \var{g(3)}. This behaviour is distinctly
+\var{f(2)} may be executed before \var{g(3)}. This behavior is distinctly
 different from \delphi{} or \tp{}.
 
 If one expression {\em must} be executed before the other, it is necessary
@@ -8523,7 +8523,7 @@
   If F()=Addone then
     WriteLn ('Functions return same values ');
 \end{verbatim}
-Remark that this last behaviour is not compatible with \delphi syntax. 
+Remark that this last behavior is not compatible with \delphi syntax. 
 Switching on \var{Delphi} mode will allow you to use \delphi syntax.
 
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
@@ -8581,7 +8581,7 @@
 boolean(100);
 Word(@Buffer);
 \end{verbatim}
-This is compatible with \delphi or \tp behaviour.
+This is compatible with \delphi or \tp behavior.
 
 %%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
 % Variable typecasts
@@ -8709,7 +8709,7 @@
 end; 
 \end{verbatim}
 By default, the address operator must be used if a value must be assigned
-to a procedural type variable. This behaviour can be avoided by using the
+to a procedural type variable. This behavior can be avoided by using the
 \var{-Mtp} or \var{-MDelphi} switches, which result in a more compatible 
 \delphi or \tp syntax.
 
@@ -10427,7 +10427,7 @@
 \begin{verbatim}
 Something else
 \end{verbatim}
-This behaviour is by design.
+This behavior is by design.
 \end{remark}
 
 Constant parameters can also be untyped. See \sees{varparams} for more
@@ -11775,7 +11775,7 @@
 Since the types of \var{Z} and \var{R} don't match the types in the
 operator definition.
 
-The reason for this behaviour is that it is possible that a multiplication
+The reason for this behavior is that it is possible that a multiplication
 is not always commutative. E.g. the multiplication of a \var{(n,m)} with a
 \var{(m,n)} matrix will result in a \var{(n,n)} matrix, while the
 multiplication of a \var{(m,n)} with a \var{(n,m)} matrix is a \var{(m,m)}
ref.tex.patch (3,908 bytes)

Kai Burghardt

2019-03-24 17:17

reporter  

prog.tex.patch (3,460 bytes)
--- prog.tex~	2019-03-24 01:37:00.184546085 +0000
+++ prog.tex	2019-03-24 16:10:19.083694320 +0000
@@ -135,7 +135,7 @@
 Local directives can occur more than once in a unit or program,
 If they have a command line counterpart, the command line argument is
 restored as the default for each compiled file. The local directives
-influence the compiler's behaviour from the moment they're encountered
+influence the compiler's behavior from the moment they're encountered
 until the moment another switch annihilates their behaviour, or the end
 of the current unit or program is reached.
 
@@ -625,7 +625,7 @@
 \var{\{\$H\}}: a \var{\{\$MODE DELPHI\}} directive implies a
 \var{\{\$H+\}} statement, all other modes switch it off. As a result,
 you should always put \var{\{\$H+\}} after a mode directive. 
-This behaviour has changed, in older \fpc versions this was not so. 
+This behavior has changed, in older \fpc versions this was not so. 
 
 \subsection{\var{\protect\$HINT} : Generate hint message}
 
@@ -795,7 +795,7 @@
 
 The \var{\{\$I-\}} or \var{\{\$IOCHECKS OFF\}} directive tells the compiler
 not to generate input/output checking code in the program. By default, the
-compiler generates I/O checking code. This behaviour can be controlled
+compiler generates I/O checking code. This behavior can be controlled
 globally with the \var{-Ci} switch.
 
 When compiling using the \var{-Ci} compiler switch, the \fpc compiler inserts
@@ -1469,7 +1469,7 @@
 When an overflow occurs, the run-time library will generate a run-time error 215: 
 it prints a message \var{Overflow at xxx}, and exits the program with exit code 215.
 
-\begin{remark}Overflow checking behaviour is not the same as in
+\begin{remark}Overflow checking behavior is not the same as in
 Turbo Pascal since all arithmetic operations are done via 32-bit or
 64-bit values. Furthermore, the \var{Inc()} and \var{Dec} standard system
 procedures {\em are} checked for overflow in \fpc, while in Turbo
@@ -2759,7 +2759,7 @@
 In MacPas mode, compile time variables can be defined. They are distinct
 from symbols in that they have a value, and they are distinct from macros,
 in that they cannot be used to replace portions of the source text with
-their value. Their behaviour is compatible with compile time variables 
+their value. Their behavior is compatible with compile time variables 
 found in popular pascal compilers for Macintosh. 
 
 A compile time variable is defined like this:
@@ -5651,7 +5651,7 @@
 \item[FreememSize] This function should release the memory pointed to by
 \var{P}. The argument \var{Size} is the expected size of the memory block
 pointed to by P. This should be disregarded, but can be used to check the
-behaviour of the program.
+behavior of the program.
 \item[AllocMem] Is the same as getmem, only the allocated memory should
 be filled with zeros before the call returns.
 \item[ReAllocMem] Should allocate a memory block of the specified \var{Size},
@@ -5659,7 +5659,7 @@
 \var{P}, truncating this to the new size of needed. After that, the memory
 pointed to by P may be deallocated. The return value is a pointer to the
 new memory block. Note that \var{P} may be \var{Nil}, in which case the
-behaviour is equivalent to \var{GetMem}.
+behavior is equivalent to \var{GetMem}.
 \item[MemSize] should return the size of the memory block \var{P}.
 This function may return zero if the memory manager does not allow 
 to determine this information.
prog.tex.patch (3,460 bytes)

Kai Burghardt

2019-03-24 17:18

reporter  

user.tex.patch (1,898 bytes)
--- user.tex~	2019-03-24 16:06:46.832551266 +0000
+++ user.tex	2019-03-24 16:10:19.083694320 +0000
@@ -891,7 +891,7 @@
 % Units libraries and smartlinking
 \section{Units, libraries and smartlinking}
 The \fpc compiler supports smartlinking and the creation of libraries.
-However, the default behaviour is to compile each unit into one big object
+However, the default behavior is to compile each unit into one big object
 file, which will be linked as a whole into your program.
 Shared libraries can be created on most platforms, although current level
 of FPC support may vary (they are e.g. not supported for GO32v2 and OS2
@@ -2826,7 +2826,7 @@
 The \file{infile} parameter is the Pascal file to be processed, and will be written
 to \file{outfile}, overwriting an existing \file{outfile} if it exists.
 
-Some options modify the behaviour of ptop:
+Some options modify the behavior of ptop:
 
 \begin{description}
 \item[-h] Write an overview of the possible parameters and command line syntax.
@@ -2845,7 +2845,7 @@
 \subsection{The ptop configuration file}
 
 Creating and distributing a configuration file for ptop is not necessary,
-unless you want to modify the standard behaviour of \file{ptop}. The configuration
+unless you want to modify the standard behavior of \file{ptop}. The configuration
 file is never preloaded, so if you want to use it you should always specify
 it with a \var{-c ptop.cfg} parameter.
 
@@ -4037,7 +4037,7 @@
 \begin{itemize}
 \item if you call \var{Dispose} or \var{Freemem} with an invalid pointer
 \item in case \var{New} or \var{GetMem} is called, and there is no more memory 
-available. The behaviour in this case depends on the setting of 
+available. The behavior in this case depends on the setting of 
 \var{ReturnNilIfGrowHeapFails}. If it is \var{True}, then \var{Nil} is returned. 
 if \var{False}, then runerror 204 is raised.
 \end{itemize}
user.tex.patch (1,898 bytes)

Kai Burghardt

2019-03-24 17:29

reporter  

fpdoc.tex.patch (976 bytes)
--- fpdoc.tex~	2019-03-24 16:28:42.220006164 +0000
+++ fpdoc.tex	2019-03-24 16:28:42.220006164 +0000
@@ -812,7 +812,7 @@
 \label{suse:disableprivate}
 If this option is specified, then no \tag{element} tags will be generated
 for private methods or fields of classes or objects. 
-The default behaviour is to generate nodes for private methods or fields.
+The default behavior is to generate nodes for private methods or fields.
 It can be used to generate a skeleton for end-user and developer
 documentation.
 
@@ -1905,7 +1905,7 @@
 
 Note that if a description node contains a \tag{table}, \tag{pre}, \tag{code}
 or any list tag, then the text surrounding these tags {\em must} be  put 
-inside a \tag{p} paragraph tag. This is different from the behaviour in HTML.
+inside a \tag{p} paragraph tag. This is different from the behavior in HTML.
 
 The paragraph tag must always have an opening tag and a closing tag, unlike
 html where only the opening tag may be present.
fpdoc.tex.patch (976 bytes)

Kai Burghardt

2019-03-24 17:45

reporter  

ide.tex.patch (4,126 bytes)
--- ide.tex~	2019-03-24 16:44:00.481561571 +0000
+++ ide.tex	2019-03-24 16:44:00.481561571 +0000
@@ -347,7 +347,7 @@
 In many cases the IDE displays a dialog window to get user input.
 The main difference to normal windows is that other windows cannot be
 activated while a dialog is active. Also the menu is not accessible while in
-a dialog. This behaviour is called \emph{modal}. To activate another window,
+a dialog. This behavior is called \emph{modal}. To activate another window,
 the modal window or dialog must be closed first.
 
 A typical dialog window is shown in \seefig{idedlg}.
@@ -658,12 +658,12 @@
 be set. These directories will be used when a program or unit is compiled.
 \item[Browser]
 Presents a dialog where the browser options can be set. The browser options
-affect the behaviour of the symbol browser of the IDE.
+affect the behavior of the symbol browser of the IDE.
 \item[Tools]
 Presents a dialog to configure the tools menu. For more information, see
 \sees{addingtools}.
 \item[Environment]
-Presents a dialog to configure the behaviour of the IDE. A sub menu is
+Presents a dialog to configure the behavior of the IDE. A sub menu is
 presented with the various aspects of the IDE:
 \begin{description}
 \item[Preferences]
@@ -677,7 +677,7 @@
 \item[Codetemplates]
 Used to define code templates, which can be inserted in an edit window.
 \item[Desktop]
-Used to control the behaviour of the desktop, i.e. several features can be
+Used to control the behavior of the desktop, i.e. several features can be
 switched on or off.
 \item[Keyboard \& Mouse] Can be used to select the cut/copy/paste
 convention, control the actions of the mouse, and to assign commands 
@@ -862,7 +862,7 @@
 \label{se:syntaxhighlighting}
 The IDE is capable of syntax highlighting, i.e. the color of certain
 Pascal elements can be set. As text is entered in an editor window,
-the IDE will try to recognise the elements, and set the color of the
+the IDE will try to recognize the elements, and set the color of the
 text accordingly.
 
 
@@ -1062,7 +1062,7 @@
 After the desired location has been reached, the browser window can be closed
 with the usual commands.
 
-The behaviour of the browser can be customized with the browser options
+The behavior of the browser can be customized with the browser options
 dialog, using the \menu{Options|Browser} menu.
 The browser options dialog looks like \seefig{obrowser}.
 
@@ -1770,7 +1770,7 @@
 only the syntax of the current source should be checked.
 
 The menu item \menu{Compiler|Clear primary file} restores the default
-behaviour of the IDE, i.e. the 'compile' and 'run' commands apply to the
+behavior of the IDE, i.e. the 'compile' and 'run' commands apply to the
 active window.
 %
 % The directory dialog
@@ -2279,7 +2279,7 @@
 % Editor customization
 %
 \subsection{The Editor}
-Several aspects of the editor window behaviour can be set in this dialog.
+Several aspects of the editor window behavior can be set in this dialog.
 The editor preferences dialog is shown in \seefig{oeeditor}. Note that
 some of these options affect only newly opened windows, not already 
 opened windows (e.g. Vertical Blocks, Highlight Column/Row).
@@ -2362,7 +2362,7 @@
 \subsection{Keyboard \& Mouse}
 \label{se:prefmouse}
 The Keyboard \& mouse options dialog is called by the menu item
-\menu{Options|Environment|Keyboard \& Mouse}. It allows adjusting the behaviour of the
+\menu{Options|Environment|Keyboard \& Mouse}. It allows adjusting the behavior of the
 keyboard and mouse as well as the sensitivity of the mouse.
 The keyboard and mouse options dialog is shown in \seefig{oemouse}.
 
@@ -2380,7 +2380,7 @@
 time between two clicks is very short; slow means that the time between two
 mouse clicks can be quite long.
 \item[Reverse mouse buttons]
-the behaviour of the left and right mouse buttons can be swapped by
+the behavior of the left and right mouse buttons can be swapped by
 by checking the checkbox; this is especially useful for left-handed people.
 \item[Ctrl+Right mouse button]
 Assigns an action to a right mouse button click while holding the
ide.tex.patch (4,126 bytes)

Kai Burghardt

2019-03-24 17:48

reporter  

gorp.tex.patch (778 bytes)
--- prog.tex~	2019-03-24 16:46:32.359802334 +0000
+++ prog.tex	2019-03-24 16:46:32.359802334 +0000
@@ -4261,10 +4261,10 @@
 \section{Entry and exit code}
 
 Each Pascal procedure and function begins and ends with standard
-epilogue and prologue code.
+epilog and prolog code.
 
 
-\subsection{Intel 80x86 standard routine prologue / epilogue}
+\subsection{Intel 80x86 standard routine prolog / epilog}
 Standard entry code for procedures and functions is as follows on the
 80x86 architecture:
 \begin{verbatim}
@@ -4284,7 +4284,7 @@
 \sees{RegConvs}.
 
 
-\subsection{Motorola 680x0 standard routine prologue / epilogue}
+\subsection{Motorola 680x0 standard routine prolog / epilog}
 
 Standard entry code for procedures and functions is as follows on the
 680x0 architecture:
gorp.tex.patch (778 bytes)

Michael Van Canneyt

2019-03-26 22:20

administrator   ~0115066

Applied the patch.

I very much dislike the text now, but at least it is consistent.

Issue History

Date Modified Username Field Change
2019-03-24 02:41 Kai Burghardt New Issue
2019-03-24 02:41 Kai Burghardt Status new => assigned
2019-03-24 02:41 Kai Burghardt Assigned To => Michael Van Canneyt
2019-03-24 02:41 Kai Burghardt File Added: doc.patch
2019-03-24 02:41 Kai Burghardt Tag Attached: documentation
2019-03-24 05:34 J. Gareth Moreton Note Added: 0115008
2019-03-24 08:06 Michael Van Canneyt Note Added: 0115009
2019-03-24 08:06 Michael Van Canneyt Note Edited: 0115009 View Revisions
2019-03-24 11:59 J. Gareth Moreton Note Added: 0115014
2019-03-24 13:55 Michael Van Canneyt Note Added: 0115017
2019-03-24 16:37 Bart Broersma Note Added: 0115021
2019-03-24 17:05 J. Gareth Moreton Note Added: 0115024
2019-03-24 17:09 J. Gareth Moreton Note Edited: 0115024 View Revisions
2019-03-24 17:17 Kai Burghardt Note Added: 0115028
2019-03-24 17:17 Kai Burghardt File Added: ref.tex.patch
2019-03-24 17:17 Kai Burghardt File Added: prog.tex.patch
2019-03-24 17:18 Kai Burghardt File Added: user.tex.patch
2019-03-24 17:29 Kai Burghardt File Added: fpdoc.tex.patch
2019-03-24 17:45 Kai Burghardt File Added: ide.tex.patch
2019-03-24 17:48 Kai Burghardt File Added: gorp.tex.patch
2019-03-26 22:20 Michael Van Canneyt Fixed in Revision => 1571
2019-03-26 22:20 Michael Van Canneyt Note Added: 0115066
2019-03-26 22:20 Michael Van Canneyt Status assigned => resolved
2019-03-26 22:20 Michael Van Canneyt Fixed in Version => 3.3.1
2019-03-26 22:20 Michael Van Canneyt Resolution open => fixed
2019-03-26 22:20 Michael Van Canneyt Target Version => 3.2.0