View Issue Details

IDProjectCategoryView StatusLast Update
0035279PackagesPackagespublic2020-08-05 04:56
ReporterAndrea Mauri Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status assignedResolutionreopened 
PlatformMacOSmacOS 
Product Version2.1 (SVN) 
Summary0035279: VirtualTreeView rendering on Cocoa
DescriptionVirtualTreeView is not rendering well on MacOS (Cocoa). Even changing DoubleBuffered property. Both fonts, images and directly drawing on canvas.
Steps To ReproduceYou can check Online Package Manager that uses VirtualTreeView.
Additional InformationMaybe related to HiDPI. Seems to work on Linux and Windows, I have not tested on HiDPI monitor on Linux and Windows.
TagsNo tags attached.
Fixed in Revisionr61618
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Andrea Mauri

2019-03-26 08:37

reporter  

Trevor Roydhouse

2019-12-07 05:41

reporter   ~0119672

Seems to be OK in Lazarus trunk r61775M - see attached image

Juha Manninen

2019-12-12 13:23

developer   ~0119792

Most likely fixed with r61618. Resolving.

Andrea Mauri

2019-12-13 11:19

reporter   ~0119813

On my mac it is better but not well defined as the lazarus editor fonts.
Rev 62382. See attached image. Am I doing something wrong?

Wallaby

2020-08-05 04:56

reporter   ~0124573

Not sure if this is the same or different issue, but VirtualTreeView draws itself with blurry fonts on macOS Retina screens.

Everything is OK with Windows even on high DPI, but on MacOS the fonts are blurry on Retina. Non-Retina screens are OK.

I have attached a screen shot.
Ifjvulm.png (214,616 bytes)   
Ifjvulm.png (214,616 bytes)   

Issue History

Date Modified Username Field Change
2019-03-26 08:37 Andrea Mauri New Issue
2019-03-26 08:37 Andrea Mauri File Added: Screen Shot 2019-03-08 at 16.51.16.png
2019-12-07 05:41 Trevor Roydhouse File Added: Screen Shot 2019-12-07 at 15.35.29.png
2019-12-07 05:41 Trevor Roydhouse Note Added: 0119672
2019-12-12 13:22 Juha Manninen Assigned To => Dmitry Boyarintsev
2019-12-12 13:22 Juha Manninen Status new => assigned
2019-12-12 13:23 Juha Manninen Status assigned => resolved
2019-12-12 13:23 Juha Manninen Resolution open => fixed
2019-12-12 13:23 Juha Manninen Fixed in Revision => r61618
2019-12-12 13:23 Juha Manninen LazTarget => -
2019-12-12 13:23 Juha Manninen Widgetset Cocoa => Cocoa
2019-12-12 13:23 Juha Manninen Note Added: 0119792
2019-12-13 11:19 Andrea Mauri File Added: Screen Shot 2019-12-13 at 11.16.48.png
2019-12-13 11:19 Andrea Mauri Note Added: 0119813
2019-12-13 14:05 Andrea Mauri Status resolved => assigned
2019-12-13 14:05 Andrea Mauri Resolution fixed => reopened
2020-08-05 04:56 Wallaby Note Added: 0124573
2020-08-05 04:56 Wallaby File Added: Ifjvulm.png