View Issue Details

IDProjectCategoryView StatusLast Update
0035283FPCDocumentationpublic2019-03-26 21:52
ReporterKai BurghardtAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSGNU/LinuxOS Version4.2.0
Product Version3.0.4Product Build3.0.4+dfsg-11 [2017/12/30] 
Target Version3.2.0Fixed in Version3.3.1 
Summary0035283: programmer's guide suggest manually including heaptrc unit
DescriptionThe subsection “Debugging the heap” in the Programmer's guide suggests it's OK to include the heaptrc unit via the uses-clause. https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/prog.tex?view=markup&root=docs&pathrev=1565#l5590

However http://wiki.freepascal.org/heaptrc#Usage states “Do not add the heaptrc unit manually. The heaptrc unit needs to be loaded before lineinfo and only the compiler can do that.”

The User's guide seconds that: https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/user.tex?view=markup&root=docs&pathrev=1565#l3498

Therefore, please remove any references suggesting it's OK to include heaptrc unit by hand.
Tagsdocumentation
Fixed in Revision1570
FPCOldBugId
FPCTarget
Attached Files

Activities

Thaddy de Koning

2019-03-26 18:13

reporter   ~0115059

Last edited: 2019-03-26 18:18

View 4 revisions

I think that this has duplicates (I reported similar last year) and furthermore that Michael already fixed that for the new release, but that is by my often failing memory.
Although I wrote the last part of the wiki based on that.... ;) and feedback by Florian.
I also edited out wrong example code and replaced it.

Thaddy de Koning

2019-03-26 18:20

reporter   ~0115060

Ah, I see. That may be a regression against part of the documentation indeed.

Kai Burghardt

2019-03-26 19:08

reporter   ~0115061

I always look up what's the state in trunk, since Michael's been committing my documentation-related patches or handling other easy issues pretty fast. Deleting part of a sentence, and possibly inserting a “Don't!”-sentence is also quite easy. Thereby I skip searching for open issues possibly covering mine.

0032061 was about the User's guide. I'm complaining about unfortunate wording in the Programmer's guide.

You had reported 0031480 (in the year 2017, so two years ago 😛).

Michael Van Canneyt

2019-03-26 21:52

administrator   ~0115063

Thanks for pointing it out, well spotted!

Issue History

Date Modified Username Field Change
2019-03-26 16:20 Kai Burghardt New Issue
2019-03-26 16:20 Kai Burghardt Status new => assigned
2019-03-26 16:20 Kai Burghardt Assigned To => Michael Van Canneyt
2019-03-26 16:21 Kai Burghardt Tag Attached: documentation
2019-03-26 18:13 Thaddy de Koning Note Added: 0115059
2019-03-26 18:14 Thaddy de Koning Note Edited: 0115059 View Revisions
2019-03-26 18:14 Thaddy de Koning Note Edited: 0115059 View Revisions
2019-03-26 18:18 Thaddy de Koning Note Edited: 0115059 View Revisions
2019-03-26 18:20 Thaddy de Koning Note Added: 0115060
2019-03-26 19:08 Kai Burghardt Note Added: 0115061
2019-03-26 21:52 Michael Van Canneyt Fixed in Revision => 1570
2019-03-26 21:52 Michael Van Canneyt Status assigned => resolved
2019-03-26 21:52 Michael Van Canneyt Fixed in Version => 3.3.1
2019-03-26 21:52 Michael Van Canneyt Resolution open => fixed
2019-03-26 21:52 Michael Van Canneyt Target Version => 3.2.0
2019-03-26 21:52 Michael Van Canneyt Note Added: 0115063