View Issue Details

IDProjectCategoryView StatusLast Update
0035311FPCCompilerpublic2019-04-10 16:49
ReporterCraig YoungAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformPCOSWindows 10 ProOS Versionlatest
Product VersionProduct Build 
Target VersionFixed in Version3.3.1 
Summary0035311: Windows API call "ReadDirectoryChangesW" is missing
DescriptionI am trying to add the Cromis Directory Watch function to my code and get a compiler error showing the windows api "ReadDirectoryChangesW" is missing. I went on the forum and one of the moderators requested I submit this as a bug.

Craig
Steps To ReproduceInsert this into a test program with "Windows" in the uses clause:

ReadDirectoryChangesW('C:\temp\',false,);

you should get a compile error showing it is not found.
Additional InformationThe program I am trying to add to LAZ32 is:

www.angusj.com/delphi/dirwatch.html
TagsNo tags attached.
Fixed in Revision41857
FPCOldBugId
FPCTarget
Attached Files

Activities

Maxim Ganetsky

2019-04-03 13:34

reporter   ~0115192

This issue seems to belong to FPC project. Moving.

rd0x

2019-04-03 15:29

reporter   ~0115194

add JwaWinBase to uses list

-> https://github.com/graemeg/freepascal/blob/master/packages/winunits-jedi/src/jwawinbase.pas

Marco van de Voort

2019-04-10 16:48

manager   ~0115394

Last edited: 2019-04-10 16:49

View 2 revisions

added, please test.

Note: while testing, make sure jwa* references are gone (to avoid crossing declarations of lpopverlapped and the function)

Issue History

Date Modified Username Field Change
2019-04-03 11:48 Craig Young New Issue
2019-04-03 13:34 Maxim Ganetsky Note Added: 0115192
2019-04-03 13:34 Maxim Ganetsky Project Lazarus => FPC
2019-04-03 15:29 rd0x Note Added: 0115194
2019-04-10 16:48 Marco van de Voort Fixed in Revision => 41857
2019-04-10 16:48 Marco van de Voort Note Added: 0115394
2019-04-10 16:48 Marco van de Voort Status new => resolved
2019-04-10 16:48 Marco van de Voort Fixed in Version => 3.3.1
2019-04-10 16:48 Marco van de Voort Resolution open => fixed
2019-04-10 16:48 Marco van de Voort Assigned To => Marco van de Voort
2019-04-10 16:49 Marco van de Voort Note Edited: 0115394 View Revisions