View Issue Details

IDProjectCategoryView StatusLast Update
0035371FPCRTLpublic2019-05-08 21:45
ReporterThaddy de KoningAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformallOSallOS Versionall
Product Version3.3.1Product Build41861 
Target VersionFixed in Version 
Summary0035371: Rename Int128Rec to Uint64rec so that one can add signed 128 bit integers in the future.
DescriptionInt128Rec is an unsigned typed record: https://www.freepascal.org/docs-html/rtl/sysutils/int128rec.html
That feels wrong because now you can not define a true unsigned 128 bit integer.

I discovered it because I was implementing just that and ran into this name clash. (So discovering it was already taken)
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Thaddy de Koning

2019-04-13 11:54

reporter   ~0115469

True *signed* of course.

Florian

2019-05-08 21:45

administrator   ~0116083

The type is used for too long to be changed again and it is coherent with the Int64Rec type.

I propose to call an 128 bit signed int type Int128 and the corresponding unsigned type OWord.

Issue History

Date Modified Username Field Change
2019-04-13 11:53 Thaddy de Koning New Issue
2019-04-13 11:54 Thaddy de Koning Note Added: 0115469
2019-05-08 21:45 Florian Assigned To => Florian
2019-05-08 21:45 Florian Status new => resolved
2019-05-08 21:45 Florian Resolution open => no change required
2019-05-08 21:45 Florian FPCTarget => -
2019-05-08 21:45 Florian Note Added: 0116083