View Issue Details

IDProjectCategoryView StatusLast Update
0035470LazarusIDEpublic2020-04-17 19:20
Reporterantispam88 Assigned ToJuha Manninen  
Status resolvedResolutionfixed 
OSWindows 10 Pro 64 
Product Version2.0.2 
Summary0035470: Run parameters are not set in lps file after upgrade from 1.8.4
DescriptionAfter the upgrade the run parameters which are defined in project file are not set for execution.
But just opening the "Run parameters" dialog and confirming it with OK without changing any value corrects the issue.
Here is the difference in the lps file:
      <FormatVersion Value="2"/>
      <Modes Count="0" ActiveMode=""/>
      <FormatVersion Value="2"/>
      <Modes Count="0" ActiveMode="default"/>
Steps To ReproduceOpen a project created with 1.8.4 where one or more parameters are defined and run the project.
TagsNo tags attached.
Fixed in Revisionr61051
Attached Files


related to 0035410 closedJuha Manninen Sanity check when loading LPS run modes 


Juha Manninen

2019-04-30 14:37

developer   ~0115920

Upload an example project please.
The <RunParams> tag in your description has no actual parameters.


2019-04-30 16:41

reporter   ~0115924

In the lps file there are no run params stored.
In the lpi file there is following section:
        <CommandLineParams Value="-test1"/>
      <FormatVersion Value="2"/>
      <Modes Count="1">
        <Mode0 Name="default">
            <CommandLineParams Value="-test1"/>

If you need a sample project I have to set up the old lazarus version.


2019-08-07 23:34

reporter   ~0117589

Sorry for my late answer, but I tried to create an example after my last post - without success.

Now I have installed 2.0.4 on a fresh notebook and got the same error.
I could create a working example (attachement).
If you open the lpi file and just run it should show "'Params: 0". After close + open lazarus again running the project should show then "Params: 1". (129,180 bytes)

Anton Kavalenka

2019-08-08 13:13

reporter   ~0117591

Can confirm the same for Linux. Debugging requires external xserver specified in run options. It will work only if I open run options.

New projects not affected by this problem.

Juha Manninen

2020-04-03 11:41

developer   ~0121860

This was already solved in the related issue. The commit will be merged to fixes_2_0 branch.
Please test with trunk, or with fixes branch after the merge.

Issue History

Date Modified Username Field Change
2019-04-29 22:59 antispam88 New Issue
2019-04-30 14:37 Juha Manninen Note Added: 0115920
2019-04-30 16:41 antispam88 Note Added: 0115924
2019-08-07 23:34 antispam88 File Added:
2019-08-07 23:34 antispam88 Note Added: 0117589
2019-08-08 13:13 Anton Kavalenka Note Added: 0117591
2020-04-03 11:35 Juha Manninen Relationship added related to 0035410
2020-04-03 11:41 Juha Manninen Assigned To => Juha Manninen
2020-04-03 11:41 Juha Manninen Status new => resolved
2020-04-03 11:41 Juha Manninen Resolution open => fixed
2020-04-03 11:41 Juha Manninen Fixed in Revision => r61051
2020-04-03 11:41 Juha Manninen LazTarget => -
2020-04-03 11:41 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-04-03 11:41 Juha Manninen Note Added: 0121860