View Issue Details

IDProjectCategoryView StatusLast Update
0035477LazarusDebuggerpublic2019-05-04 07:43
ReporternanobitAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSWindowsOS Version10
Product Version2.1 (SVN)Product Build 
Target VersionFixed in Version2.2 
Summary0035477: "Unknown type" in Watches?
DescriptionDebugger: gdb with fpdebug
Some revision in fixes/trunk has changed "Unknown type" display in Watches.
example: routine with local: var unk: iinterface;
"Local Variables" shows "Unknown type", but "Watches" shows "{GDB:} ..."
"{GDB:} ..." can lead to crash in Watches if gdb version 8.2.
Crash was not in the original Lazarus 2.0.2
TagsNo tags attached.
Fixed in Revision61133
LazTarget2.2
Widgetset
Attached Files

Activities

Martin Friebe

2019-05-03 23:29

manager   ~0115989

This behaviour was once intended. Watches that FpDebug can not display, should go to GDB. But now FpDebug's missing types are few, so this can be changed. There may still be other cases were values will go to gdb.

Please test and close if ok.

nanobit

2019-05-04 07:43

reporter   ~0115992

Tested and works great. Thanks!

Issue History

Date Modified Username Field Change
2019-05-03 07:46 nanobit New Issue
2019-05-03 07:46 nanobit Status new => assigned
2019-05-03 07:46 nanobit Assigned To => Martin Friebe
2019-05-03 23:29 Martin Friebe Status assigned => resolved
2019-05-03 23:29 Martin Friebe Resolution open => fixed
2019-05-03 23:29 Martin Friebe Fixed in Version => 2.2
2019-05-03 23:29 Martin Friebe Fixed in Revision => 61133
2019-05-03 23:29 Martin Friebe LazTarget => 2.2
2019-05-03 23:29 Martin Friebe Widgetset Win32/Win64 =>
2019-05-03 23:29 Martin Friebe Note Added: 0115989
2019-05-04 07:43 nanobit Status resolved => closed
2019-05-04 07:43 nanobit Note Added: 0115992