View Issue Details

IDProjectCategoryView StatusLast Update
0035523LazarusLCLpublic2019-05-05 17:52
ReporterChris RordenAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacBook 2012 Retina 13"OSDarwinOS Version10.11.6
Product Version2.0.3 (SVN)Product Build61136 
Target VersionFixed in Version2.2 
Summary0035523: Cocoa: leakinfo does not compile
DescriptionI can successfully compile the latest svn with
  make LCL_PLATFORM=cocoa CPU_TARGET=x86_64
however, if I run
  make LCL_PLATFORM=cocoa CPU_TARGET=x86_64 clean bigide
I get an error:

/lazarus/components/leakview/leakinfo.pas(21,21) Fatal: (10022) Can't find unit FpDbgLoader used by leakinfo
Fatal: (1018) Compilation aborted
make[2]: *** [leakview.ppu] Error 1
make[1]: *** [bigide] Error 2
make: *** [bigidecomponents] Error 2

It looks like the recompile does generate the required fpdbgloader.o/fpdbgloader.ppu in
  /Lazarus/components/fpdebug/lib/x86_64-darwin
so I assume this is a path issue.

TagsNo tags attached.
Fixed in Revision61145
LazTarget2.2
WidgetsetCocoa
Attached Files

Activities

Martin Friebe

2019-05-05 13:25

manager   ~0116023

please test and close if ok

Issue History

Date Modified Username Field Change
2019-05-04 20:39 Chris Rorden New Issue
2019-05-05 13:24 Martin Friebe Assigned To => Martin Friebe
2019-05-05 13:24 Martin Friebe Status new => assigned
2019-05-05 13:25 Martin Friebe Status assigned => resolved
2019-05-05 13:25 Martin Friebe Resolution open => fixed
2019-05-05 13:25 Martin Friebe Fixed in Version => 2.2
2019-05-05 13:25 Martin Friebe Fixed in Revision => 61145
2019-05-05 13:25 Martin Friebe LazTarget => 2.2
2019-05-05 13:25 Martin Friebe Widgetset Cocoa => Cocoa
2019-05-05 13:25 Martin Friebe Note Added: 0116023
2019-05-05 17:52 Chris Rorden Status resolved => closed