View Issue Details

IDProjectCategoryView StatusLast Update
0035532FPCFCLpublic2019-05-06 17:49
ReporterMaris-SAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2.0.2Product Build 
Target VersionFixed in Version3.3.1 
Summary0035532: Incorrect redirect code
DescriptionComponent: fcl-web
File: src/base/fphttpclient.pp

class function TFPCustomHTTPClient.IsRedirect(ACode: Integer): Boolean;
begin
  Case ACode of
    301,
    302,
    303,
    307,808 : Result:=True;
  else
    Result:=False;
  end;
end;

Wiki list with status codes:
https://en.wikipedia.org/wiki/List_of_HTTP_status_codes

Incorrect set of redirect codes. 808 should be changed to 308.
TagsNo tags attached.
Fixed in Revision42012
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-05-06 17:49

administrator   ~0116050

Seems to be a typo. Fixed, thanks for reporting !

Issue History

Date Modified Username Field Change
2019-05-06 17:35 Maris-S New Issue
2019-05-06 17:48 Michael Van Canneyt Project Packages => FPC
2019-05-06 17:49 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-05-06 17:49 Michael Van Canneyt Status new => resolved
2019-05-06 17:49 Michael Van Canneyt Resolution open => fixed
2019-05-06 17:49 Michael Van Canneyt Fixed in Version => 3.3.1
2019-05-06 17:49 Michael Van Canneyt Fixed in Revision => 42012
2019-05-06 17:49 Michael Van Canneyt FPCTarget => 3.2.0
2019-05-06 17:49 Michael Van Canneyt Note Added: 0116050