View Issue Details

IDProjectCategoryView StatusLast Update
0035549PackagesPackagespublic2019-08-22 15:35
ReporterRégent Gaudreau Assigned To 
Status feedbackResolutionopen 
Product Version2.0.2 
Summary0035549: idemake.cfg not found if accute in file path
DescriptionWith lazarus 2.0.0 RC3 and below all was working fine when rebuilding IDE after adding package

with 2.0.0 finale and 2.0.2 install goes well and IDE opens, but if i add a package and try to rebuild IDE i get

C:\Users\RÙgent\AppData\Local\lazarus\idemake.cfg is missing

it should be:

If i un-install all and re-install 2.0.0 RC3 all is working again when i rebuild the IDE
Additional Informationseems there is a string conversion error when the new IDE reads the config file
TagsNo tags attached.
Fixed in Revision
Attached Files


Régent Gaudreau

2019-05-09 13:10

reporter   ~0116100

If you need to reproduce, it think you will need to create a new user with a acute in it: (ie: Régent) in windows and then go in profile and add package and build IDE


2019-05-21 11:35

reporter   ~0116303

I have the same error.

Fatal: Unable to open file C:\Users\+юЁюфхЎъшщ.BGEM\AppData\Local\lazarus\idemake.cfg

It looks like the compiler doesn't understand any unicode symbols in the User profile name. And I can't change that profile name due to domain policies...

Amr Aboughazala

2019-06-22 14:09

reporter   ~0116835

I have the same Error when I want to build IDE packages although the user name is normal and only Amr


2019-08-09 08:04

reporter   ~0117598

2.0.4 is still a problem:
Fatal: Unable to open file C:\Users\whitÚ\AppData\Local\lazarus\idemake.cfg
kep.PNG (14,966 bytes)   
kep.PNG (14,966 bytes)   

Juha Manninen

2019-08-11 12:20

developer   ~0117642

Your description means there was a regression between 2.0 RC3 and 2.0 final. Over 100 revisions were backported then. See:
Please find out which revision causes the regression. The easiest way to do it is bisecting. See:


2019-08-21 14:20

reporter   ~0117763

works with the config directory parameter

In Windows you cannot use ~ so use instead for example a shortcut in the desktop with the following parameters to call Lazarus:
\path\to\lazarus.exe --primary-config-path=lazarusconf

Juha Manninen

2019-08-21 22:34

developer   ~0117772

Last edited: 2019-08-22 02:11

View 2 revisions

The error message must come from "make". The path is somehow passed wrongly to it.
I added a debug line in r61742, called when idemake.cfg file name is used.
Could you guys with Windows please check which revision in Lazarus 2.0 fixes branch caused the regression.
This looks like related to an old issue 0028991 but those revisions were not merged after 2.0RC3.


2019-08-22 06:36

reporter   ~0117779


installed program: lazarus-2.0.4-fpc-3.0.4-win32.exe
bug.PNG (69,462 bytes)   
bug.PNG (69,462 bytes)   

Juha Manninen

2019-08-22 15:35

developer   ~0117783

wsoft-hu, idemake.cfg and fpcdefines.xml are two different things.
Please find the revision in Lazarus 2.0 fixes branch that caused the regression!

Issue History

Date Modified Username Field Change
2019-05-09 02:46 Régent Gaudreau New Issue
2019-05-09 13:10 Régent Gaudreau Note Added: 0116100
2019-05-21 11:35 legoru Note Added: 0116303
2019-06-22 14:09 Amr Aboughazala Note Added: 0116835
2019-08-09 08:04 wsoft-hu File Added: kep.PNG
2019-08-09 08:04 wsoft-hu Note Added: 0117598
2019-08-11 12:20 Juha Manninen Note Added: 0117642
2019-08-11 12:23 Juha Manninen Status new => feedback
2019-08-11 12:23 Juha Manninen LazTarget => -
2019-08-21 14:20 wsoft-hu Note Added: 0117763
2019-08-21 22:34 Juha Manninen Note Added: 0117772
2019-08-22 02:11 Juha Manninen Note Edited: 0117772 View Revisions
2019-08-22 06:36 wsoft-hu File Added: bug.PNG
2019-08-22 06:36 wsoft-hu Note Added: 0117779
2019-08-22 15:35 Juha Manninen Note Added: 0117783