View Issue Details

IDProjectCategoryView StatusLast Update
0035555LazarusLCLpublic2020-05-27 01:44
ReporterM.AUDIO Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformx86_64OSMacOS 
Product Version2.1 (SVN) 
Summary0035555: Cocoa flat TSpeedButton draws incorrectly
Descriptionon Windows and Linux (gtk2) the drawing of a flat TSpeedButton inserted on a TPanel which has a custom background is correct. as in screenshots. but in MacOS (cocoa) the drawing is incorrect.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetCocoa
Attached Files

Relationships

related to 0037127 closedDmitry Boyarintsev Cocoa Flat SpeedButton renders differently depending macOS version 

Activities

M.AUDIO

2019-05-10 12:00

reporter  

M.AUDIO

2019-05-10 12:08

reporter  

M.AUDIO

2019-05-10 12:08

reporter   ~0116113

macos screenshot

M.AUDIO

2019-05-10 12:08

reporter   ~0116114

windows screenshot
win32_flat_tspeedbutton.gif (8,535 bytes)   
win32_flat_tspeedbutton.gif (8,535 bytes)   

M.AUDIO

2019-05-10 12:08

reporter   ~0116115

linux gtk2 screenshot

Dmitry Boyarintsev

2019-06-15 21:09

developer   ~0116740

the issue seems to be fixed then current trunk
please retest and close if ok

Issue History

Date Modified Username Field Change
2019-05-10 12:00 M.AUDIO New Issue
2019-05-10 12:00 M.AUDIO File Added: cocoa_speedbtn_flat_test.zip
2019-05-10 12:08 M.AUDIO File Added: macos_cocoa_flat_tspeedbutton.gif
2019-05-10 12:08 M.AUDIO Note Added: 0116113
2019-05-10 12:08 M.AUDIO File Added: win32_flat_tspeedbutton.gif
2019-05-10 12:08 M.AUDIO Note Added: 0116114
2019-05-10 12:08 M.AUDIO File Added: linux_gtk2_flat_tspeedbutton.gif
2019-05-10 12:08 M.AUDIO Note Added: 0116115
2019-06-15 21:09 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-06-15 21:09 Dmitry Boyarintsev Status new => resolved
2019-06-15 21:09 Dmitry Boyarintsev Resolution open => no change required
2019-06-15 21:09 Dmitry Boyarintsev LazTarget => -
2019-06-15 21:09 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-06-15 21:09 Dmitry Boyarintsev Note Added: 0116740
2020-05-27 01:44 Dmitry Boyarintsev Relationship added related to 0037127