View Issue Details

IDProjectCategoryView StatusLast Update
0035593LazarusWidgetsetpublic2019-05-17 02:05
ReporterHans Luijten Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformCocoaOSmacOS 
Product Version2.0.3 (SVN) 
Summary0035593: Cocoa: IDE causes CPU to spike to 100%
DescriptionIDe and Cocoa applications use 100% CPU after updating from trunk to 61230 and building with:

make LCL_PLATFORM=cocoa CPU_TARGET=x86_64
Steps To ReproduceUpdate to make SVN 61230.
make LCL_PLATFORM=cocoa CPU_TARGET=x86_64
Run Lazarus.

Activity monitor shows 100% and it stays there.
Additional InformationForum post: https://forum.lazarus.freepascal.org/index.php/topic,45435.0.html
TagsNo tags attached.
Fixed in Revision61234
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Hans Luijten

2019-05-17 00:56

reporter   ~0116229

Last edited: 2019-05-17 00:58

View 2 revisions

Note, r61170 does not have this issue.

I've tested r61229, r61228, r61227, r61226, r61225, r61222, 61212, 61210, 61208, ... they all have the same issue.
r61207 does NOT have this issue.

Could this be the cause?

r61208 | dmitry | 2019-05-12 03:20:44 +0200 (Sun, 12 May 2019) | 1 line
cocoa: getting rid of code duplication in event processing

Dmitry Boyarintsev

2019-05-17 01:50

developer   ~0116230

please test and close if ok

Hans Luijten

2019-05-17 02:05

reporter   ~0116231

You're fast Dmitry ;-)
Thanks for the quick fix!

Issue History

Date Modified Username Field Change
2019-05-17 00:30 Hans Luijten New Issue
2019-05-17 00:56 Hans Luijten Note Added: 0116229
2019-05-17 00:58 Hans Luijten Note Edited: 0116229 View Revisions
2019-05-17 01:50 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-05-17 01:50 Dmitry Boyarintsev Status new => resolved
2019-05-17 01:50 Dmitry Boyarintsev Resolution open => fixed
2019-05-17 01:50 Dmitry Boyarintsev Fixed in Revision => 61234
2019-05-17 01:50 Dmitry Boyarintsev LazTarget => -
2019-05-17 01:50 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-05-17 01:50 Dmitry Boyarintsev Note Added: 0116230
2019-05-17 02:05 Hans Luijten Status resolved => closed
2019-05-17 02:05 Hans Luijten Note Added: 0116231