View Issue Details

IDProjectCategoryView StatusLast Update
0035712LazarusWidgetsetpublic2019-06-19 21:04
ReporterZoë PetersonAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version2.0.3 (SVN)Product Build 
Target VersionFixed in Version 
Summary0035712: representedURL should not be set to the application icon
DescriptionRevision 61369 (Implemented form icons) makes LCL apps behave differently than standard Cocoa apps and should be made opt-in.

The window's representedURL/representedFilename is intended to show the path of the document currently open in the application. Right clicking on it gives the path to the represented item, so you can use it for navigation. TextEdit and Pages do not have an icon until you explicitly save, and Mail never has one. Finder and Terminal's icon represents the current directory. Making it point at the app bundle doesn't make sense. In addition to not matching standard macOS behavior, it also conflicts with using representedURL for it's intended purpose, since the widgetset might change it out from under us.
TagsNo tags attached.
Fixed in Revision61377
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Dmitry Boyarintsev

2019-06-13 14:49

developer   ~0116707

In short. This is how LCL icons are working. They're not to define a file opened, they're to define the application a window belongs to.

Explained: https://wiki.freepascal.org/Cocoa_Internals/Forms#Icons

Dmitry Boyarintsev

2019-06-13 15:04

developer   ~0116709

and now it can be turned off.
please test and close if ok

Issue History

Date Modified Username Field Change
2019-06-13 00:02 Zoë Peterson New Issue
2019-06-13 14:49 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-06-13 14:49 Dmitry Boyarintsev Status new => acknowledged
2019-06-13 14:49 Dmitry Boyarintsev LazTarget => -
2019-06-13 14:49 Dmitry Boyarintsev Note Added: 0116707
2019-06-13 15:03 Dmitry Boyarintsev Status acknowledged => resolved
2019-06-13 15:03 Dmitry Boyarintsev Resolution open => fixed
2019-06-13 15:03 Dmitry Boyarintsev Fixed in Revision => 61377
2019-06-13 15:03 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-06-13 15:04 Dmitry Boyarintsev Note Added: 0116709
2019-06-19 21:04 Zoë Peterson Status resolved => closed