View Issue Details

IDProjectCategoryView StatusLast Update
0035721PackagesPackagespublic2020-10-18 17:26
ReporterL_VV Assigned ToJuha Manninen  
Status resolvedResolutionfixed 
PlatformAMD Ryzen 7 2700XOSDebian Linux x86_64 
Product Version2.1 (SVN) 
Summary0035721: Can't install sparta_DockedFormEditor
DescriptionWhen I trying to install sparta_DockedFormEditor, I get the compile error:

Warning: Recompiling chmreader, checksum changed for /opt/fpcupdeluxe/lazarus/components/sparta/generics/lib/x86_64-linux/generics.collections.ppu
chmreader.pas(81,12) Fatal: Can't find unit chmreader used by ChmLangRef
Steps To Reproduce1. Choose main menu item: Package / Install/Uninstall Packages...
2. Select sparta_dockedformeditor.lpk at the right packages list
3. Install selection
4. Save and rebuild IDE
5. Compilation started and stopped this error:
chmreader.pas(81,12) Fatal: Can't find unit chmreader used by ChmLangRef
Tagschm, sparta_dockedformeditor
Fixed in Revisionr62042
WidgetsetGTK 2
Attached Files


related to 0034899 resolvedJuha Manninen Packages Docked form editor does not work 
related to 0036218 feedbackMichl Lazarus Constant flickering and generally unacceptably poor form designer performance recently, with Sparta Docked Form Editor installed 



2019-06-15 21:20



2019-06-15 21:38

reporter   ~0116741

Lazarus Revision: 61397


2019-06-18 10:01

reporter   ~0116768

The same error under Windows 10 Pro x64, Lazarus Revision: 61410
Lazarus_about_2019_06_18.png (184,769 bytes)   
Lazarus_about_2019_06_18.png (184,769 bytes)   


2019-06-19 12:26

reporter   ~0116787

I have attached another screenshot, with the FPC / Lazarus trunk recompiling error (with the last FPCUPdeluxe version).

Perhaps it would be more correct to refer this error not to sparta_DockedFormEditor, but to FPC itself?

FPC revision: 42249
Lazarux revision: 61423


2019-06-19 17:25

reporter   ~0116790

Last edited: 2019-06-19 20:03

View 4 revisions

I found the change after which the compilation of sparta_DockedFormEditor stopped working.

SVN revision: 42124
GIT commit: b36c516

Marco van de Voort committed May 25, 2019


* redone sitemap to support multiple name, local pairs for index.
* rewritten binary index generation. Use natural sort for index.
* updated html scanning for html code.
Still work, ags helpfile still has 70 differences. Possibly however due to sensitive anchors on index level.

git-svn-id: 3ad0048d-3df7-0310-abae-a5850022a9f2

r42124 | marco | 2019-05-25 19:41:18 +0300 (Сб, 25 май 2019) | 5 lines

Changed paths:
   M /trunk/packages/chm/fpmake.pp
   M /trunk/packages/chm/src/chmcmd.lpr
   M /trunk/packages/chm/src/chmfilewriter.pas
   M /trunk/packages/chm/src/chmreader.pas
   M /trunk/packages/chm/src/chmsitemap.pas
   M /trunk/packages/chm/src/chmwriter.pas
   M /trunk/utils/fpdoc/

Before that change (i.e. on revision 42123) sparta_DockedFormEditor compiles successfully.


2019-06-19 21:10

reporter   ~0116795

I think I found the problem. Chmhelp conflicts with sparta_generics (see the IDE message with the line above the error).
If you remove the package links to <PackageName Value="sparta_Generics"/> from \components\sparta\mdi\sparta_mdi.lpk and \components\sparta\toolsapi\sparta_toolsapi.lpk. Then generics.collections from fpc\3.3.1\source\packages\rtl-generics\src will be used, package sparta_dockedformeditor.lpk will be installed, and the IDE (v2.1 rev. 61398) will compile successfully.
Try this solution.


2019-06-19 21:15

reporter   ~0116796

Modified lpk files sparta_toolsapi.lpk and sparta_mdi.lpk. (1,276 bytes)


2019-06-20 04:00

reporter   ~0116803

The entire "sparta_Generics" package should probably just be removed completely soon, FWIW, as like you've seen here it conflicts with trunk.

I also think it's actually an older version of Generics.Collections than trunk.


2019-06-20 17:18

reporter   ~0116808

I think the problem lies in a slightly different area. Because if you remove the chmhelppkg package, then sparta_dockedformeditor.lpk with sparta_Generics will be installed correctly.
Perhaps the problem is in the Free Pascal package manager:

Sven Barth

2019-07-28 15:41

manager   ~0117460

No Akira1364 is probably right. FPC trunk and 3.2 come with their own rtl-generics packages and thus sparta_Generics should only be used if the compiler version is 3.0.4 or older. Don't know if that can be expressed in the package system of the IDE, but that would be the cleanest solution.


2019-08-04 21:49

reporter   ~0117562

Simple removal of "sparta_Generics" is just a hiding of the symptoms of the problem. And can be used as a temporary solution.
II use version Lazarus 2.1 and FPC 3.3.1 and periodically update them. And two or three months ago, everything worked well. However, after the code using fppkg.cfg appeared in Lazarus 2.1, this problem arose with generics packages.
By the way, if you create a regular application, then the Dialogs module will be used from the LCL package, but if you create a console application and add Dialogs in the uses section, then this module will already be from the FPC packages.

Zdravko Gabrovski

2019-08-26 10:37

reporter   ~0117846

I put the files from K155LA3 during the fpcupdeluxe work, after SVN checkout, it compiles OK.
Other way is after fpcupdeluxe fail, to recompile by adding missing paths.
I did it via shell script (attached here).
Please, change /home/zdravko/fpcupdeluxe/ with your fpcupdeluxe location. (975 bytes)   
/home/zdravko/fpcupdeluxe/fpc/bin/x86_64-linux/ -gl -vbqewnhi -Sci -dlclgtk2 -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../components/custom -Fuframes -Fu. -Fu/home/zdravko/fpcupdeluxe/fpcsrc/rtl -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/paszlib -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/fcl-process -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/hash -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/libtar -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/fpmkunit -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/regexpr -Fu/home/zdravko/fpcupdeluxe/fpcsrc/packages/chm/src -Fu/home/zdravko/fpcupdeluxe/lazarus/components/chmhelp/packages/idehelp -Fiinclude -Fiinclude/linux -Fi../images -FE.. -FU../units/x86_64-linux/gtk2 -Cg -Fl/usr/lib/gcc/x86_64-linux-gnu/7 -Flinclude -Fl/etc/*.conf -vw-n-h-l-d-u-t-p-c- -dx86_64 @/home/zdravko/fpcupdeluxe/config_lazarus/idemake.cfg lazarus.pp (975 bytes)   

Juha Manninen

2019-10-13 09:32

developer   ~0118548

Fixed together with the related issue. Please test.


2020-10-18 17:26

reporter   ~0126394

I had the same issue and removed the chmhelppkg package to install the Sparta Docked Form Editor.

Issue History

Date Modified Username Field Change
2019-06-15 21:18 L_VV New Issue
2019-06-15 21:20 L_VV Tag Attached: sparta_dockedformeditor
2019-06-15 21:20 L_VV File Added: Screenshot_20190615_221211.png
2019-06-15 21:38 L_VV Note Added: 0116741
2019-06-18 10:01 L_VV File Added: sparta_DockedFormEditor_compile_error.png
2019-06-18 10:01 L_VV File Added: Lazarus_about_2019_06_18.png
2019-06-18 10:01 L_VV Note Added: 0116768
2019-06-19 12:26 L_VV File Added: FPCUPdeluxe_recompile_trunc_error.png
2019-06-19 12:26 L_VV Note Added: 0116787
2019-06-19 17:25 L_VV File Added: fpc_rev_42123-sparta_DockedFormEditor-OK.png
2019-06-19 17:25 L_VV Note Added: 0116790
2019-06-19 19:53 L_VV Tag Attached: chm
2019-06-19 19:55 L_VV Note Edited: 0116790 View Revisions
2019-06-19 19:57 L_VV Note Edited: 0116790 View Revisions
2019-06-19 20:03 L_VV Note Edited: 0116790 View Revisions
2019-06-19 21:10 K155LA3 Note Added: 0116795
2019-06-19 21:15 K155LA3 File Added:
2019-06-19 21:15 K155LA3 Note Added: 0116796
2019-06-20 04:00 Akira1364 Note Added: 0116803
2019-06-20 17:18 K155LA3 Note Added: 0116808
2019-06-20 17:19 K155LA3 Note View State: 0116808: public
2019-07-28 15:41 Sven Barth Note Added: 0117460
2019-08-04 21:49 K155LA3 Note Added: 0117562
2019-08-26 10:37 Zdravko Gabrovski File Added:
2019-08-26 10:37 Zdravko Gabrovski Note Added: 0117846
2019-10-06 10:49 Juha Manninen Relationship added related to 0034899
2019-10-13 09:32 Juha Manninen Assigned To => Juha Manninen
2019-10-13 09:32 Juha Manninen Status new => assigned
2019-10-13 09:32 Juha Manninen Status assigned => resolved
2019-10-13 09:32 Juha Manninen Resolution open => fixed
2019-10-13 09:32 Juha Manninen Fixed in Revision => r62042
2019-10-13 09:32 Juha Manninen LazTarget => -
2019-10-13 09:32 Juha Manninen Widgetset GTK 2 => GTK 2
2019-10-13 09:32 Juha Manninen Note Added: 0118548
2019-10-27 09:43 Juha Manninen Relationship added related to 0036218
2020-10-18 17:26 neuro Note Added: 0126394
2020-10-18 17:26 neuro File Added: Bildschirmfoto von 2020-10-18 17-16-55.png