View Issue Details

IDProjectCategoryView StatusLast Update
0035747FPCRTLpublic2019-09-20 20:55
ReporterAlfredAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformavr embeddedOSOS Version
Product Version3.3.1Product Buildtrunk latest 
Target VersionFixed in Version 
Summary0035747: Rev 42155 gives [dreaded] error: register r24, r26, r28 or r30 required
DescriptionRev 42155 introduces asm code for move on AVR.
This is cause by: sbiw Z, 1
This instruction leads to: Error: register r24, r26, r28 or r30 required
TagsAVR
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0035752 closedJeppe Johansen Creating avr crosscompiler stops building rtl 

Activities

Alfred

2019-06-22 07:02

reporter   ~0116830

GNU binutils 2.32 are used.

Alfred

2019-06-22 15:51

reporter   ~0116847

http://www.lazarusforum.de/viewtopic.php?f=9&t=12420&sid=2e116f0ea884347d7f24579364b7e344

Issue History

Date Modified Username Field Change
2019-06-22 06:57 Alfred New Issue
2019-06-22 07:02 Alfred Note Added: 0116830
2019-06-22 15:51 Alfred Note Added: 0116847
2019-06-22 17:07 Jonas Maebe Assigned To => Jonas Maebe
2019-06-22 17:07 Jonas Maebe Status new => resolved
2019-06-22 17:07 Jonas Maebe Resolution open => duplicate
2019-06-22 17:07 Jonas Maebe FPCTarget => -
2019-06-22 17:07 Jonas Maebe Relationship added duplicate of 0035752
2019-06-23 14:46 Dimitrios Chr. Ioannidis Tag Attached: AVR