View Issue Details

IDProjectCategoryView StatusLast Update
0035781FPCCompilerpublic2019-06-28 19:20
ReporterSergey BychkowAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version3.0.4Product Build 
Target VersionFixed in Version 
Summary0035781: x86_64 compiler ppcx64.exe fails on Windows when target is x86_64-darwin: Internal error 200208151
Descriptionppcx64.exe fails with internal error 200208151 just after searching system.ppu. All platform-dependent units are in place:

00008000:(1000) Compiler: C:\lazarus\fpc\3.0.4\bin\x86_64-win64\ppcx64.exe
...
00004000:(10002) PPU Name: C:\lazarus\fpc\3.0.4\units\x86_64-darwin\rtl\system.ppu
00004000:(10005) PPU Time: 2017/11/27 01:35:42
00004000:(10003) PPU Flags: 159873
00004000:(10004) PPU Crc: D38DC521
00004000:(10004) PPU Crc: 4EC4106F (intfc)
00004000:(10004) PPU Crc: 9F533260 (indc)
00004000:Number of definitions: 4600
00004000:Number of symbols: 11669
00004000:(10011) PPU Source: system.pp not available
00004000:(10011) PPU Source: sysunixh.inc not available
...
00004000:(10011) PPU Source: sighnd.inc not available
00004000:(10011) PPU Source: ..\x86\x86hnd.inc not available
10000001:Fatal: Internal error 200208151
10000001:Fatal: (1018) Compilation aborted
Additional Informationi386-darwin target has next line instead of error:

00004000:(10056) Finished loading unit SYSTEM
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Relationships

duplicate of 0009262 acknowledged No support for 80 bit softfloat in the compiler (needed for non-x86 to x86 crosscompiling) 

Activities

Jonas Maebe

2019-06-28 19:20

manager   ~0116997

Cross-compiling from Win64 to other x86 platforms is not supported due to a lack of 80 bits extended floating point support.

Issue History

Date Modified Username Field Change
2019-06-28 19:08 Sergey Bychkow New Issue
2019-06-28 19:20 Jonas Maebe Assigned To => Jonas Maebe
2019-06-28 19:20 Jonas Maebe Status new => resolved
2019-06-28 19:20 Jonas Maebe Resolution open => duplicate
2019-06-28 19:20 Jonas Maebe FPCTarget => -
2019-06-28 19:20 Jonas Maebe Note Added: 0116997
2019-06-28 19:20 Jonas Maebe Relationship added duplicate of 0009262