View Issue Details

IDProjectCategoryView StatusLast Update
0035810LazarusIDEpublic2020-03-30 21:45
ReporterAlly Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSWin 10 x64 
Product Version2.0.2 
Summary0035810: The icons in the ActionlistEditor are shown very indistinctly.
DescriptionThe icons are displayed with only approx. 12x12 pixels. The original size is usually 16x16 pixels or more.
The same icons are better displayed in the Object Inspector.
TagsNo tags attached.
Fixed in Revisionr62815
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0022071 feedbackJuha Manninen ActionList Images store 

Activities

Ally

2019-07-07 16:13

reporter  

ActionlistEditor.png (6,958 bytes)   
ActionlistEditor.png (6,958 bytes)   
Objektinspektor.png (5,668 bytes)   
Objektinspektor.png (5,668 bytes)   

Juha Manninen

2020-03-28 12:32

developer   ~0121742

The example project from 0022071 can be used for testing. Form2 and Form3 have an ActionList. I set the project as related.

I fixed the problem in r62815. Please test.
I also fixed an offset error in ImageIndexPropertyEditor (the dropdown in Object Inspector ). The numeric value was slightly lower then the image. I don't understand the reason and the solution was counter-intuitive.
An offset had to be substracted from the rectancle Top instead of adding it.

Juha Manninen

2020-03-30 21:45

developer   ~0121786

Resolving.

Issue History

Date Modified Username Field Change
2019-07-07 16:13 Ally New Issue
2019-07-07 16:13 Ally File Added: ActionlistEditor.png
2019-07-07 16:13 Ally File Added: Objektinspektor.png
2020-03-28 12:04 Juha Manninen Assigned To => Juha Manninen
2020-03-28 12:04 Juha Manninen Status new => assigned
2020-03-28 12:14 Juha Manninen Relationship added related to 0022071
2020-03-28 12:32 Juha Manninen Note Added: 0121742
2020-03-30 21:45 Juha Manninen Status assigned => resolved
2020-03-30 21:45 Juha Manninen Resolution open => fixed
2020-03-30 21:45 Juha Manninen Fixed in Revision => r62815
2020-03-30 21:45 Juha Manninen LazTarget => -
2020-03-30 21:45 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-03-30 21:45 Juha Manninen Note Added: 0121786