View Issue Details

IDProjectCategoryView StatusLast Update
0035843FPCCompilerpublic2019-07-13 11:38
ReporterAkira1364Assigned ToSven Barth 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSWindowsOS Version10
Product Version3.3.1Product BuildTrunk 
Target VersionFixed in Version3.3.1 
Summary0035843: The recently merged attributes functionality attempts to use a scanner error that does not exist.
DescriptionI noticed this after pulling the changes into my multi-line strings branch and attempting to build the compiler.

Specifically, at the problem is at line 1146 of pdecobj.pas:

Message1(scan_e_unresolved_attribute,trtti_attribute(rtti_attrs_def.rtti_attributes[0]).typesym.prettyname);

There is no such "scan_e_unresolved_attribute" in errore.msg. My workaround was to replace it with the "parser_e_unbound_attribute" error that does exist, however this is likely not what was actually intended.
Steps To ReproduceAttempt to build the latest revision of FPC.
TagsNo tags attached.
Fixed in Revision42413
FPCOldBugId
FPCTarget-
Attached Files

Activities

Sven Barth

2019-07-13 11:38

manager   ~0117242

Sometimes I really hate Git...

Please test and close if okay.

Issue History

Date Modified Username Field Change
2019-07-13 06:49 Akira1364 New Issue
2019-07-13 11:38 Sven Barth Assigned To => Sven Barth
2019-07-13 11:38 Sven Barth Status new => resolved
2019-07-13 11:38 Sven Barth Resolution open => fixed
2019-07-13 11:38 Sven Barth Fixed in Version => 3.3.1
2019-07-13 11:38 Sven Barth Fixed in Revision => 42413
2019-07-13 11:38 Sven Barth FPCTarget => -
2019-07-13 11:38 Sven Barth Note Added: 0117242