View Issue Details

IDProjectCategoryView StatusLast Update
0035848LazarusIDEpublic2019-07-14 16:40
ReporterJohn ShandAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSUSE TumbleweedOS VersionTumbleweed
Product Version2.0.3 (SVN)Product Build61587 
Target VersionFixed in Version 
Summary0035848: Lazarus IDE doesn't start
Descriptionsince the last update of the fpc compiler, i have been unable to load lazarus ide.

you get the error:

buffer error in a dialogue box
Steps To ReproduceClick on Lazarus shortcut
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

John Shand

2019-07-14 01:21

reporter   ~0117251

Last edited: 2019-07-14 06:20

View 2 revisions

i am using lazarus 2.0.3 fixes branch revision 61587 and fpc 3.2.0 fixes branch revision 42438

John Shand

2019-07-14 05:56

reporter   ~0117252

i also tried to run startlazarus from the command line and i got this error:

[FORMS.PP] ExceptionOccurred
  Sender=Edecompressionerror
  Exception=buffer error
  Stack trace:
  $00000000006B9604
  $00000000006AA9F2
  $00000000006AB2DE
  $000000000069089B
  $000000000059E360
  $000000000058C78B
  $000000000058C667
  $000000000059DF88
  $000000000059FC1F
  $0000000000485D0C
  $000000000041F019

John Shand

2019-07-14 07:15

reporter   ~0117253

i might have to start only updating the fixes stack once a month so i won't bump into these annoying bugs, as i can no longer work on my projects. very unhappy

Juha Manninen

2019-07-14 09:31

developer   ~0117254

AFAIK many people use the combination of FPC 3.2 + Lazarus fixes_2_0 branch and it works for them.
You should ask questions about your local configuration or distro related problems in forum or mailing list instead of opening a bug report.

Michael Van Canneyt

2019-07-14 10:18

administrator   ~0117255

Last edited: 2019-07-14 10:19

View 2 revisions

@Juha,

This is 99% sure caused by the changes in TStream.Read() that were merged to 3.2 fixes.
They need accompagnying changes in the compiler in order to work. I had forgotten that when merging.

I will ask if it is OK to merge these changes too or undo the merge of the TStream changes to 3.2

Michael Van Canneyt

2019-07-14 10:56

administrator   ~0117257

I undid the merge of the TStream buffer changes in FPC fixes 3.2.0.
Please test and close if OK.

Juha Manninen

2019-07-14 16:40

developer   ~0117259

Ok, thanks Michael.

Issue History

Date Modified Username Field Change
2019-07-14 01:19 John Shand New Issue
2019-07-14 01:21 John Shand Note Added: 0117251
2019-07-14 05:56 John Shand Note Added: 0117252
2019-07-14 06:20 John Shand Note Edited: 0117251 View Revisions
2019-07-14 07:15 John Shand Note Added: 0117253
2019-07-14 09:31 Juha Manninen Note Added: 0117254
2019-07-14 10:18 Michael Van Canneyt Note Added: 0117255
2019-07-14 10:18 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-07-14 10:18 Michael Van Canneyt Status new => assigned
2019-07-14 10:19 Michael Van Canneyt Note Edited: 0117255 View Revisions
2019-07-14 10:56 Michael Van Canneyt Status assigned => resolved
2019-07-14 10:56 Michael Van Canneyt Resolution open => fixed
2019-07-14 10:56 Michael Van Canneyt LazTarget => -
2019-07-14 10:56 Michael Van Canneyt Widgetset GTK 2 => GTK 2
2019-07-14 10:56 Michael Van Canneyt Note Added: 0117257
2019-07-14 16:40 Juha Manninen Note Added: 0117259