View Issue Details

IDProjectCategoryView StatusLast Update
0035877FPCCompilerpublic2019-09-13 21:37
ReporterDenis GolovanAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0035877: Trunk compiler fails with 200510032
DescriptionHi

Attached project fails to build with latest trunk fpc.
The last working revision I used was 42189.

Bisect didn't narrow the issue a lot as non-testable builds (see error below) are all over the place.
project1.lpr:(.text.n_p$project1$_$tsimplerpcreqhandler2_$__$$_readresp$tsimplerpcresponse2+0x1a5): undefined reference to `.Lj7475'
project1.lpr(32,1) Error: Error while linking
project1.lpr(32,1) Fatal: There were 1 errors compiling module, stopping

I attached a list of possibly offending commit as per "git bisect".
TagsNo tags attached.
Fixed in Revision42987
FPCOldBugId
FPCTarget-
Attached Files
  • project1.lpr (675 bytes)
  • bisect-results.txt (9,128 bytes)
    commit e902e36eb6c439b59fbea23d10ebd959b780ccc4
    Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 2/3]
    
    Regenerated compiler/msgidx.inc and compiler/msgtxt.inc.
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42357 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 25828e408ea1845821dfd266bd4da983fdd0281a
    Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 3/3]
    
    Added FPC_REQUIRES_PROPER_ALIGNMENT to TUnitInfo definition. Added FPC_HAS_EXTENDED_RTTI define.
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42358 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit a634f9ffa4a4270bfea7a99a8221fe6a78aed3b6
    Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 1/3]
    
    Implemented attributes for class types and properties (based on work by Joost van der Sluis). Added TCustomAttribute - a base class for attributes. Added TUnitInfo record to RTTI. It contains the unit name and unit options (for now only a flag which specifies if the unit contains attributes). Added several tests for attributes.
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42356 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 005c4e840487a412515ee477c0312406c09a1e4b
    * rename trtti_attributesdef to trtti_attributes_list
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42359 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 03986656d2937eeba72aa2216963a0d0b83d226b
    pastojs: fixed createcallback inside anonymous method
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42355 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 7890415438f45e71abdf272047c59bb381b9c4cb
    * write a name for the none property access entry (looks nicer than a "(Nil)" at the start of the line)
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42354 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 938b351780e263fb28dbac348745b1cd51b22994
    * change boolean parameters for try_consume_unitsym to a set
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42360 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 06807cc5da18f90eeca1273bf17c0573aa2dd3c5
    * write an entry name for the property options
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42353 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit aa1c4ed8ace41ff2e2e8fc464baa4722cdd2265e
    * rename custom attributes related tests to something more sensible
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42361 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 4e6c609cf6b20acc5c2c0da31c9a11d197f1f7c6
    * instead of declaring another type with a 'attribute' suffix, *search* for another type with a 'ATTRIBUTE' suffix (Delphi allows declaring both a TFoo and TFooAttribute in the same unit)
    + added test
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42362 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 512641dd6815e52d6ce30d502d50efbe41602eb7
    * ensure that the toString constant is used instead of TObject's ToString method
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42352 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 8c73aeb57092da6cc835565aa7b8e3eb9e043dac
    * Fix bug ID 0035817
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42351 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 9c1f831e0b3543a831fc0189d125941ea2717ca2
    * fix typo
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42363 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 0222fee847f799f275ac9a91516352a4bbbf0758
    * also check for invalid attribute data in tests
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42364 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit d2f6c08d53d16f0cc33405879e05b147123ce5db
    * Always try to show the field name when possible
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42350 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 0d1329aa961dc727dc3f1356768e50ed21fc8a9f
    * instead of embedding the attributes inside the class' and property's type data only store a reference to a table of attributes
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42365 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 1b7ecd41301c59977eac3618158f1ddb444ca38d
    * Always try to show the field name when possible
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42349 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 450971413de3325779def60e1f3a83f49049aa4e
    * it's more correct for GetPropAttribute to return a TCustomAttribute instead of a TObject
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42366 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit dee51bd6581a788fa6cf9384109fc8bf01a0e260
    fcl-passrc: fixed helper in other unit
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42348 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 4a6a97560624c71cf1ddb3dbdb209a68a88d7fbb
    fcl-passrc: fixed parsing class var a:t;b:t
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42347 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit bcdcba9f42e642733ee46344de9a375b4d09a2ab
    * use a Word instead of a Byte for the attribute index (after all the compiler writes a Word to the count field)
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42367 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit aea456e1e5c935a95c95dfb9f55a53c196e59903
    * always write a class' reference to the attribute table, even if the unit does not have attributes
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42368 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit f37fed52a7b081b9563dc121f7995912f96b9f08
    + parse the IMPDEF record in TOmfObjInput.ReadImpDef
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42346 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 95e4e35c778eb1c8f41960996ce7c6be5d08e005
    - remove unit info and related code again as that will be handled similar, but differently with dynamic packages
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42369 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit cf59e4af0f69025b3b43df88f7ce6da3ed144a22
    * Fix bug ID 35796, codepage issue when getting string as variant
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42344 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 3804789a69cef7ed828b22bbb2cbd20c2a281b65
    * fix TClassData by including the AttributeTable at the right location
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42370 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit b0ded3f4be0a476d784a00a211618147ed604207
    * Patch from Maciej Izak to allow loading multiple times
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42343 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 0d8c33acf132aaa210ba0f4457f3d4c0bad27792
    * rename TAttributeData to the more appropriate TAttributeTable
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42371 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 40d31e34116efffa239b6dc94373fcfccedfa646
      * fix tobjectdef.vmt_def to search in the correct symtable
      * always register vmt defs (so they get written to the ppu) in case of llvm,
        because it may need this def in case a method from a class defined in the
        implementation of unit gets called from an inlined routine that gets
        inlined in another unit (normally that vmt def would not get written to
        the ppu file, as it can't be referenced from the interface and it's also
        not necessarily directly referenced from the inline routine's nodes)
        (fixes sdo_dataobject compilation with LLVM after enabling cross-unit
         inlining of methods accessing static symbol table symbols)
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42342 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 3a4815523638e87aa5fcb93b30dbc5aff879ec0e
    * fix test
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42372 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 5495f06affaacd7dd2f80ae213aa598742046982
      * factored out checks whether a procdef's symbol needs to be global, and
        the generation of the procdef's asmsymbols
       o also removed unnecessary definition of procdef alias symbols for Darwin
         (they are already defined in ncgutil.alloc_proc_symbol)
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42341 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit 2ff2895e4fb824c57b71df0c138aff8a9ec495d4
    * streamline retrieval of attributes (both in TypInfo and RTTI units)
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42373 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit b7ffc8faa8a1ebbd82b7a1d6f3320440f1307dc9
      * on Mach-O, PECOFF and ELF platforms, write local symbols as hidden/
        private_extern (or plain global in case of PECOFF, as the effect is
        the same there): visible across object files, but they become local
        when linked into a binary/library. This enables cross-unit inlining
        of functions accessig implementation-only symbols.
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42340 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    commit b51eda3eaff647c2ded6fea3c879ae842852de65
    * considering that at least in theory every symbol and every def can carry RTTI attributes (Delphi only supports property and field symbols), move the rtti_attribute_list to tstoredsym/tstoreddef
    
    git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42374 3ad0048d-3df7-0310-abae-a5850022a9f2
    
    
    bisect-results.txt (9,128 bytes)

Activities

Denis Golovan

2019-07-23 16:05

reporter  

project1.lpr (675 bytes)
bisect-results.txt (9,128 bytes)
commit e902e36eb6c439b59fbea23d10ebd959b780ccc4
Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 2/3]

Regenerated compiler/msgidx.inc and compiler/msgtxt.inc.

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42357 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 25828e408ea1845821dfd266bd4da983fdd0281a
Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 3/3]

Added FPC_REQUIRES_PROPER_ALIGNMENT to TUnitInfo definition. Added FPC_HAS_EXTENDED_RTTI define.

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42358 3ad0048d-3df7-0310-abae-a5850022a9f2

commit a634f9ffa4a4270bfea7a99a8221fe6a78aed3b6
Reintegration of Custom Attributes branch by Joost van der Sluis with patches reworked by Svetozar Belic [patch 1/3]

Implemented attributes for class types and properties (based on work by Joost van der Sluis). Added TCustomAttribute - a base class for attributes. Added TUnitInfo record to RTTI. It contains the unit name and unit options (for now only a flag which specifies if the unit contains attributes). Added several tests for attributes.

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42356 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 005c4e840487a412515ee477c0312406c09a1e4b
* rename trtti_attributesdef to trtti_attributes_list

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42359 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 03986656d2937eeba72aa2216963a0d0b83d226b
pastojs: fixed createcallback inside anonymous method

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42355 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 7890415438f45e71abdf272047c59bb381b9c4cb
* write a name for the none property access entry (looks nicer than a "(Nil)" at the start of the line)

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42354 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 938b351780e263fb28dbac348745b1cd51b22994
* change boolean parameters for try_consume_unitsym to a set

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42360 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 06807cc5da18f90eeca1273bf17c0573aa2dd3c5
* write an entry name for the property options

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42353 3ad0048d-3df7-0310-abae-a5850022a9f2

commit aa1c4ed8ace41ff2e2e8fc464baa4722cdd2265e
* rename custom attributes related tests to something more sensible

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42361 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 4e6c609cf6b20acc5c2c0da31c9a11d197f1f7c6
* instead of declaring another type with a 'attribute' suffix, *search* for another type with a 'ATTRIBUTE' suffix (Delphi allows declaring both a TFoo and TFooAttribute in the same unit)
+ added test

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42362 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 512641dd6815e52d6ce30d502d50efbe41602eb7
* ensure that the toString constant is used instead of TObject's ToString method

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42352 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 8c73aeb57092da6cc835565aa7b8e3eb9e043dac
* Fix bug ID 0035817

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42351 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 9c1f831e0b3543a831fc0189d125941ea2717ca2
* fix typo

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42363 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 0222fee847f799f275ac9a91516352a4bbbf0758
* also check for invalid attribute data in tests

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42364 3ad0048d-3df7-0310-abae-a5850022a9f2

commit d2f6c08d53d16f0cc33405879e05b147123ce5db
* Always try to show the field name when possible

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42350 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 0d1329aa961dc727dc3f1356768e50ed21fc8a9f
* instead of embedding the attributes inside the class' and property's type data only store a reference to a table of attributes

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42365 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 1b7ecd41301c59977eac3618158f1ddb444ca38d
* Always try to show the field name when possible

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42349 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 450971413de3325779def60e1f3a83f49049aa4e
* it's more correct for GetPropAttribute to return a TCustomAttribute instead of a TObject

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42366 3ad0048d-3df7-0310-abae-a5850022a9f2

commit dee51bd6581a788fa6cf9384109fc8bf01a0e260
fcl-passrc: fixed helper in other unit

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42348 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 4a6a97560624c71cf1ddb3dbdb209a68a88d7fbb
fcl-passrc: fixed parsing class var a:t;b:t

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42347 3ad0048d-3df7-0310-abae-a5850022a9f2

commit bcdcba9f42e642733ee46344de9a375b4d09a2ab
* use a Word instead of a Byte for the attribute index (after all the compiler writes a Word to the count field)

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42367 3ad0048d-3df7-0310-abae-a5850022a9f2

commit aea456e1e5c935a95c95dfb9f55a53c196e59903
* always write a class' reference to the attribute table, even if the unit does not have attributes

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42368 3ad0048d-3df7-0310-abae-a5850022a9f2

commit f37fed52a7b081b9563dc121f7995912f96b9f08
+ parse the IMPDEF record in TOmfObjInput.ReadImpDef

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42346 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 95e4e35c778eb1c8f41960996ce7c6be5d08e005
- remove unit info and related code again as that will be handled similar, but differently with dynamic packages

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42369 3ad0048d-3df7-0310-abae-a5850022a9f2

commit cf59e4af0f69025b3b43df88f7ce6da3ed144a22
* Fix bug ID 35796, codepage issue when getting string as variant

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42344 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 3804789a69cef7ed828b22bbb2cbd20c2a281b65
* fix TClassData by including the AttributeTable at the right location

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42370 3ad0048d-3df7-0310-abae-a5850022a9f2

commit b0ded3f4be0a476d784a00a211618147ed604207
* Patch from Maciej Izak to allow loading multiple times

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42343 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 0d8c33acf132aaa210ba0f4457f3d4c0bad27792
* rename TAttributeData to the more appropriate TAttributeTable

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42371 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 40d31e34116efffa239b6dc94373fcfccedfa646
  * fix tobjectdef.vmt_def to search in the correct symtable
  * always register vmt defs (so they get written to the ppu) in case of llvm,
    because it may need this def in case a method from a class defined in the
    implementation of unit gets called from an inlined routine that gets
    inlined in another unit (normally that vmt def would not get written to
    the ppu file, as it can't be referenced from the interface and it's also
    not necessarily directly referenced from the inline routine's nodes)
    (fixes sdo_dataobject compilation with LLVM after enabling cross-unit
     inlining of methods accessing static symbol table symbols)

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42342 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 3a4815523638e87aa5fcb93b30dbc5aff879ec0e
* fix test

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42372 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 5495f06affaacd7dd2f80ae213aa598742046982
  * factored out checks whether a procdef's symbol needs to be global, and
    the generation of the procdef's asmsymbols
   o also removed unnecessary definition of procdef alias symbols for Darwin
     (they are already defined in ncgutil.alloc_proc_symbol)

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42341 3ad0048d-3df7-0310-abae-a5850022a9f2

commit 2ff2895e4fb824c57b71df0c138aff8a9ec495d4
* streamline retrieval of attributes (both in TypInfo and RTTI units)

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42373 3ad0048d-3df7-0310-abae-a5850022a9f2

commit b7ffc8faa8a1ebbd82b7a1d6f3320440f1307dc9
  * on Mach-O, PECOFF and ELF platforms, write local symbols as hidden/
    private_extern (or plain global in case of PECOFF, as the effect is
    the same there): visible across object files, but they become local
    when linked into a binary/library. This enables cross-unit inlining
    of functions accessig implementation-only symbols.

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42340 3ad0048d-3df7-0310-abae-a5850022a9f2

commit b51eda3eaff647c2ded6fea3c879ae842852de65
* considering that at least in theory every symbol and every def can carry RTTI attributes (Delphi only supports property and field symbols), move the rtti_attribute_list to tstoredsym/tstoreddef

git-svn-id: https://svn.freepascal.org/svn/fpc/trunk@42374 3ad0048d-3df7-0310-abae-a5850022a9f2

bisect-results.txt (9,128 bytes)

Denis Golovan

2019-07-23 16:06

reporter   ~0117355

Last edited: 2019-07-23 16:08

View 2 revisions

Tested under Linux x64 svn rev. 42482, if it matters.

nanobit

2019-07-23 19:20

reporter   ~0117359

I got 200510032 in other projects too, then removed the "inline" keyword (would be on item getter in your case) and it worked.

Denis Golovan

2019-07-23 20:19

reporter   ~0117362

Last edited: 2019-07-23 20:39

View 2 revisions

That's clearly a regression, and should be fixed.
Moreover generics.collections is rtl unit and should not be modified.

Denis Golovan

2019-08-16 15:10

reporter   ~0117701

Regression is still there in svn rev.42702

Péter Gábor

2019-08-18 11:16

reporter   ~0117722

Last edited: 2019-08-18 11:50

View 2 revisions

Today I've got this while compiling Lazarus trunk (r61719) using FPC trunk (r42724):
..../components/synedit/synedithighlighterxmlbase.pas(236,31) Fatal: Internal error 200510032

The source code there is the following:

230 function TSynHighlighterXmlRangeList.GetXmlRangeInfo(Index: Integer): TSynXmlRangeInfo;
231 begin
232 if (Index < 0) or (Index >= Count) then begin
233 Result.ElementOpenList := nil;
234 exit;
235 end;
236 Result := TSynXmlRangeInfo((ItemPointer[Index] + FItemOffset)^);
237 end;

The FPC internal error code (200510032) can be found in the compiler source: /compiler/ncgld.pas line: 679

Joost van der Sluis

2019-08-18 11:57

manager   ~0117723

This can never be a regression, as generics.collections has never been released (it was not available in 3.0.4). So it is also possible to change it as/if we want.

Denis Golovan

2019-08-18 13:37

reporter   ~0117726

Generics.collections is just an example which triggered the issue first in my project.
Previous comment shows it's not specific to generics/generics.collections/...

Also your statement that it's not regression seems strange to me.
Who will use it if nobody is willing to support it before some future release?

Denis Golovan

2019-09-02 13:17

reporter   ~0117917

Still present in svn rev. 42896

Denis Golovan

2019-09-13 21:37

reporter   ~0118066

Fix confirmed.
Thanks a lot, Jonas.

Issue History

Date Modified Username Field Change
2019-07-23 16:05 Denis Golovan New Issue
2019-07-23 16:05 Denis Golovan File Added: project1.lpr
2019-07-23 16:05 Denis Golovan File Added: bisect-results.txt
2019-07-23 16:06 Denis Golovan Note Added: 0117355
2019-07-23 16:08 Denis Golovan Note Edited: 0117355 View Revisions
2019-07-23 19:20 nanobit Note Added: 0117359
2019-07-23 20:19 Denis Golovan Note Added: 0117362
2019-07-23 20:39 Denis Golovan Note Edited: 0117362 View Revisions
2019-08-16 15:10 Denis Golovan Note Added: 0117701
2019-08-18 11:16 Péter Gábor Note Added: 0117722
2019-08-18 11:50 Péter Gábor Note Edited: 0117722 View Revisions
2019-08-18 11:57 Joost van der Sluis Note Added: 0117723
2019-08-18 13:37 Denis Golovan Note Added: 0117726
2019-09-02 13:17 Denis Golovan Note Added: 0117917
2019-09-13 21:07 Jonas Maebe Assigned To => Jonas Maebe
2019-09-13 21:07 Jonas Maebe Status new => resolved
2019-09-13 21:07 Jonas Maebe Resolution open => fixed
2019-09-13 21:07 Jonas Maebe Fixed in Version => 3.3.1
2019-09-13 21:07 Jonas Maebe Fixed in Revision => 42987
2019-09-13 21:07 Jonas Maebe FPCTarget => -
2019-09-13 21:37 Denis Golovan Status resolved => closed
2019-09-13 21:37 Denis Golovan Note Added: 0118066