View Issue Details

IDProjectCategoryView StatusLast Update
0035889LazarusIDEpublic2020-04-13 18:23
ReporterTudor Hulban Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version2.0.2 
Summary0035889: Range error in SendMoveSizeMessages appears sometimes when starting the IDE.
DescriptionError shown in screen capture appears sometimes when starting the IDE

OS; Debian 10, LXDE
Steps To ReproduceOpen IDE, go to New, pick up an option.
Additional InformationNo environment.xml:
tudi@j3710:~$ pwd
/home/tudi
tudi@j3710:~$ find ./* -name *.xml | environment.xml
bash: environment.xml: command not found
tudi@j3710:~$ ls -la fpcupdeluxe/lazarus/lazarus
-rwxr-xr-x 1 tudi tudi 115478000 Jul 26 14:15 fpcupdeluxe/lazarus/lazarus

TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0034377 feedback Size range overflow in MainIDE.SendMoveSizeMessages 
related to 0027830 assignedMattias Gaertner range check with aligning TScrollbox (and several alignment errors) 

Activities

Tudor Hulban

2019-07-26 14:11

reporter  

lazlog.txt (7,096 bytes)   
using config file /home/tudi/fpcupdeluxe/lazarus/lazarus.cfg
TLResourceList.Sort 0 DUPLICATE RESOURCE FOUND: button:PNG
TLResourceList.Sort 2 DUPLICATE RESOURCE FOUND: check:PNG
TLResourceList.Sort 4 DUPLICATE RESOURCE FOUND: color-picker:PNG
TLResourceList.Sort 6 DUPLICATE RESOURCE FOUND: div_center:PNG
TLResourceList.Sort 8 DUPLICATE RESOURCE FOUND: div_justify:PNG
TLResourceList.Sort 10 DUPLICATE RESOURCE FOUND: div_left:PNG
TLResourceList.Sort 12 DUPLICATE RESOURCE FOUND: div_right:PNG
TLResourceList.Sort 14 DUPLICATE RESOURCE FOUND: HTMLForm:PNG
TLResourceList.Sort 16 DUPLICATE RESOURCE FOUND: HTMLList:PNG
TLResourceList.Sort 18 DUPLICATE RESOURCE FOUND: lineedit:PNG
TLResourceList.Sort 20 DUPLICATE RESOURCE FOUND: quick_table:PNG
TLResourceList.Sort 22 DUPLICATE RESOURCE FOUND: radio:PNG
TLResourceList.Sort 24 DUPLICATE RESOURCE FOUND: reset:PNG
TLResourceList.Sort 26 DUPLICATE RESOURCE FOUND: select:PNG
TLResourceList.Sort 28 DUPLICATE RESOURCE FOUND: submit:PNG
TLResourceList.Sort 30 DUPLICATE RESOURCE FOUND: tag_a:PNG
TLResourceList.Sort 32 DUPLICATE RESOURCE FOUND: tag_attribute:PNG
TLResourceList.Sort 34 DUPLICATE RESOURCE FOUND: tag_bold:PNG
TLResourceList.Sort 36 DUPLICATE RESOURCE FOUND: tag_br:PNG
TLResourceList.Sort 38 DUPLICATE RESOURCE FOUND: tag_comm:PNG
TLResourceList.Sort 40 DUPLICATE RESOURCE FOUND: tag_dd:PNG
TLResourceList.Sort 42 DUPLICATE RESOURCE FOUND: tag_dl:PNG
TLResourceList.Sort 44 DUPLICATE RESOURCE FOUND: tag_dt:PNG
TLResourceList.Sort 46 DUPLICATE RESOURCE FOUND: tag_element:PNG
TLResourceList.Sort 48 DUPLICATE RESOURCE FOUND: tag_font:PNG
TLResourceList.Sort 50 DUPLICATE RESOURCE FOUND: tag_h1:PNG
TLResourceList.Sort 52 DUPLICATE RESOURCE FOUND: tag_h2:PNG
TLResourceList.Sort 54 DUPLICATE RESOURCE FOUND: tag_h3:PNG
TLResourceList.Sort 56 DUPLICATE RESOURCE FOUND: tag_h4:PNG
TLResourceList.Sort 58 DUPLICATE RESOURCE FOUND: tag_h5:PNG
TLResourceList.Sort 60 DUPLICATE RESOURCE FOUND: tag_hr:PNG
TLResourceList.Sort 62 DUPLICATE RESOURCE FOUND: tag_i:PNG
TLResourceList.Sort 64 DUPLICATE RESOURCE FOUND: tag_image:PNG
TLResourceList.Sort 66 DUPLICATE RESOURCE FOUND: tag_li:PNG
TLResourceList.Sort 68 DUPLICATE RESOURCE FOUND: tag_nbsp:PNG
TLResourceList.Sort 70 DUPLICATE RESOURCE FOUND: tag_ol:PNG
TLResourceList.Sort 72 DUPLICATE RESOURCE FOUND: tag_pre:PNG
TLResourceList.Sort 74 DUPLICATE RESOURCE FOUND: tag_sub:PNG
TLResourceList.Sort 76 DUPLICATE RESOURCE FOUND: tag_sup:PNG
TLResourceList.Sort 78 DUPLICATE RESOURCE FOUND: tag_table_body:PNG
TLResourceList.Sort 80 DUPLICATE RESOURCE FOUND: tag_table_data:PNG
TLResourceList.Sort 82 DUPLICATE RESOURCE FOUND: tag_table_row:PNG
TLResourceList.Sort 84 DUPLICATE RESOURCE FOUND: tag_tbody:PNG
TLResourceList.Sort 86 DUPLICATE RESOURCE FOUND: tag_td:PNG
TLResourceList.Sort 88 DUPLICATE RESOURCE FOUND: tag_tr:PNG
TLResourceList.Sort 90 DUPLICATE RESOURCE FOUND: tag_u:PNG
TLResourceList.Sort 92 DUPLICATE RESOURCE FOUND: tag_ul:PNG
TLResourceList.Sort 94 DUPLICATE RESOURCE FOUND: tfphttpclient:PNG
TLResourceList.Sort 96 DUPLICATE RESOURCE FOUND: tfphttpserver:PNG
TLResourceList.Sort 98 DUPLICATE RESOURCE FOUND: tfphttpwebclient:PNG
SetPrimaryConfigPath NewValue="/home/tudi/fpcupdeluxe/config_lazarus" -> "/home/tudi/fpcupdeluxe/config_lazarus"
Hint: (lazarus) [TMainIDE.ParseCmdLineOptions] PrimaryConfigPath="/home/tudi/fpcupdeluxe/config_lazarus"
Hint: (lazarus) [TMainIDE.ParseCmdLineOptions] SecondaryConfigPath="/etc/lazarus"
Hint: (lazarus) [TBuildManager.SetBuildTarget] Old=x86_64-linux-gtk2 New=x86_64-linux-gtk2 Changed: OS/CPU=True LCL=False
Hint: (lazarus) [TMainIDE.DoRunProject] INIT
Hint: (lazarus) Project needs building: SrcFile outdated Project
[TCompiler.Compile] CmdLine="/home/tudi/fpcupdeluxe/fpc/bin/x86_64-linux/fpc.sh -B  -MObjFPC -Scghi -Cg -O1 -g -gl -l -vewnhibq -Fi/mnt/tmpfs.ramdisk/lib/x86_64-linux -Fu/home/tudi/fpcupdeluxe/lazarus/components/fpweb/lib/x86_64-linux -Fu/home/tudi/fpcupdeluxe/lazarus/components/sqldb/lib/x86_64-linux/gtk2 -Fu/home/tudi/fpcupdeluxe/lazarus/components/ideintf/units/x86_64-linux/gtk2 -Fu/home/tudi/fpcupdeluxe/lazarus/components/synedit/units/x86_64-linux/gtk2 -Fu/home/tudi/fpcupdeluxe/lazarus/components/lazcontrols/lib/x86_64-linux/gtk2 -Fu/home/tudi/fpcupdeluxe/lazarus/lcl/units/x86_64-linux/gtk2 -Fu/home/tudi/fpcupdeluxe/lazarus/lcl/units/x86_64-linux -Fu/home/tudi/fpcupdeluxe/lazarus/components/codetools/units/x86_64-linux -Fu/home/tudi/fpcupdeluxe/lazarus/components/lazutils/lib/x86_64-linux -Fu/home/tudi/fpcupdeluxe/lazarus/packager/units/x86_64-linux -FE/mnt/tmpfs.ramdisk/lib/x86_64-linux/ -o/mnt/tmpfs.ramdisk/lib/x86_64-linux/httpproject1 -dLCL -dLCLgtk2 /mnt/tmpfs.ramdisk/httpproject1.lpr"
Info: (lazarus) Execute Title="Compile Project, Target: /mnt/tmpfs.ramdisk/lib/x86_64-linux/httpproject1"
Info: (lazarus) Working Directory="/mnt/tmpfs.ramdisk/"
Info: (lazarus) Executable="/home/tudi/fpcupdeluxe/fpc/bin/x86_64-linux/fpc.sh"
Info: (lazarus) Param[0]="-B"
Info: (lazarus) Param[1]="-MObjFPC"
Info: (lazarus) Param[2]="-Scghi"
Info: (lazarus) Param[3]="-Cg"
Info: (lazarus) Param[4]="-O1"
Info: (lazarus) Param[5]="-g"
Info: (lazarus) Param[6]="-gl"
Info: (lazarus) Param[7]="-l"
Info: (lazarus) Param[8]="-vewnhibq"
Info: (lazarus) Param[9]="-Fi/mnt/tmpfs.ramdisk/lib/x86_64-linux"
Info: (lazarus) Param[10]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/fpweb/lib/x86_64-linux"
Info: (lazarus) Param[11]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/sqldb/lib/x86_64-linux/gtk2"
Info: (lazarus) Param[12]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/ideintf/units/x86_64-linux/gtk2"
Info: (lazarus) Param[13]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/synedit/units/x86_64-linux/gtk2"
Info: (lazarus) Param[14]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/lazcontrols/lib/x86_64-linux/gtk2"
Info: (lazarus) Param[15]="-Fu/home/tudi/fpcupdeluxe/lazarus/lcl/units/x86_64-linux/gtk2"
Info: (lazarus) Param[16]="-Fu/home/tudi/fpcupdeluxe/lazarus/lcl/units/x86_64-linux"
Info: (lazarus) Param[17]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/codetools/units/x86_64-linux"
Info: (lazarus) Param[18]="-Fu/home/tudi/fpcupdeluxe/lazarus/components/lazutils/lib/x86_64-linux"
Info: (lazarus) Param[19]="-Fu/home/tudi/fpcupdeluxe/lazarus/packager/units/x86_64-linux"
Info: (lazarus) Param[20]="-FE/mnt/tmpfs.ramdisk/lib/x86_64-linux/"
Info: (lazarus) Param[21]="-o/mnt/tmpfs.ramdisk/lib/x86_64-linux/httpproject1"
Info: (lazarus) Param[22]="-dLCL"
Info: (lazarus) Param[23]="-dLCLgtk2"
Info: (lazarus) Param[24]="/mnt/tmpfs.ramdisk/httpproject1.lpr"
[TCompiler.Compile] end
Hint: (lazarus) [TMainIDE.DoBuildProject] compiler time in s: 0.919999787583947
Info: (lazarus) [TMainIDE.DoBuildProject] Success
[TCmdLineDebugger] Debug PID: 15511
Hint: (lazarus) [TMainIDE.DoRunProject] Debugger=TGDBMIDebugger
Hint: (lazarus) [TMainIDE.DoRunProject] END
TGDBMIDebugger.StartDebugging WorkingDir="/mnt/tmpfs.ramdisk/lib/x86_64-linux/"
----------------
LAZARUS END - cleaning up ...
Hint: (lazarus) [TMainIDE.Destroy] B  -> inherited Destroy... TMainIDE
Hint: (lazarus) [TMainIDE.Destroy] END
lazlog.txt (7,096 bytes)   

Tudor Hulban

2019-07-26 14:13

reporter   ~0117416

https://forum.lazarus.freepascal.org/index.php/topic,46208.msg328632/topicseen.html#new

Juha Manninen

2019-07-26 16:59

developer   ~0117420

Last edited: 2019-07-26 17:06

View 2 revisions

Explicit tests for wrong parameter values were added in r54372 at 2017-03-08, and tweaked in r59274 at 2018-10-09.
They help to track the error even if range checks are off.
The related issue shows a stacktrace about the same problem before the explicit checks were added.
(This is not related to GTK so I removed it from the summary line.)

We would need a systematic way to reproduce the error, or at least more stacktraces to figure out what triggers the error.

Juha Manninen

2020-04-13 18:23

developer   ~0122134

Resolving as duplicate.

Issue History

Date Modified Username Field Change
2019-07-26 14:11 Tudor Hulban New Issue
2019-07-26 14:11 Tudor Hulban File Added: Screenshot from 2019-07-26 14-18-31.png
2019-07-26 14:11 Tudor Hulban File Added: lazlog.txt
2019-07-26 14:13 Tudor Hulban Note Added: 0117416
2019-07-26 15:14 Martin Friebe Summary Error in screen capture appears sometimes when starting the IDE => range check in SendMoveSizeMessages (gtk) // Error in screen capture appears sometimes when starting the IDE
2019-07-26 15:14 Martin Friebe Description Updated View Revisions
2019-07-26 15:14 Martin Friebe Additional Information Updated View Revisions
2019-07-26 15:14 Martin Friebe LazTarget => -
2019-07-26 15:14 Martin Friebe Widgetset GTK 2 => GTK 2
2019-07-26 16:35 Juha Manninen Relationship added related to 0027830
2019-07-26 16:59 Juha Manninen Note Added: 0117420
2019-07-26 17:05 Juha Manninen Summary range check in SendMoveSizeMessages (gtk) // Error in screen capture appears sometimes when starting the IDE => Range error in SendMoveSizeMessages appears sometimes when starting the IDE.
2019-07-26 17:05 Juha Manninen Description Updated View Revisions
2019-07-26 17:05 Juha Manninen Widgetset GTK 2 => GTK 2
2019-07-26 17:06 Juha Manninen Note Edited: 0117420 View Revisions
2020-04-13 18:22 Juha Manninen Relationship added duplicate of 0034377
2020-04-13 18:23 Juha Manninen Assigned To => Juha Manninen
2020-04-13 18:23 Juha Manninen Status new => resolved
2020-04-13 18:23 Juha Manninen Resolution open => duplicate
2020-04-13 18:23 Juha Manninen Widgetset GTK 2 => GTK 2
2020-04-13 18:23 Juha Manninen Note Added: 0122134