View Issue Details

IDProjectCategoryView StatusLast Update
0035941FPCTextmode IDEpublic2019-09-20 18:09
ReporterNitoramiAssigned ToPierre Muller 
PrioritynormalSeverityminorReproducibilityalways
Status confirmedResolutionopen 
PlatformPCOSwin10OS Version
Product Version3.0.4Product Build 
Target VersionFixed in Version 
Summary0035941: Textmode IDE crashes on compiling generic record
DescriptionThe textmode IDE reliably crashes with a signal 291 on the attempt to compile this:

{$mode objfpc}
unit ee_genmat;

INTERFACE

type
  generic TMatrix <zz> = record
    sizex, sizey: integer;
  end;

IMPLEMENTATION
begin
end.

Steps To ReproduceSimply compile the source from the textmode IDE.
Additional InformationIt is not a compiler issue, "fpc ee_genmat" works. It's just the IDE which crashes. Compiler settings don't seem to matter.

The issue is only with records. When changing the type to object or Class, the problem is gone.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files
  • ee_genmat.pas (162 bytes)
    {$mode objfpc}
    
    unit ee_genmat;
    
    INTERFACE
    
    type
      generic TMatrix <zz> = record
        sizex, sizey: integer;
      end;
    
    
    IMPLEMENTATION
    
    begin
    end.
    
    
    ee_genmat.pas (162 bytes)

Relationships

has duplicate 0034138 closedMarco van de Voort [Textmode ide] if unit has "uses classes;" after compilation fp drops out to command shell 

Activities

Nitorami

2019-08-08 20:37

reporter  

ee_genmat.pas (162 bytes)
{$mode objfpc}

unit ee_genmat;

INTERFACE

type
  generic TMatrix <zz> = record
    sizex, sizey: integer;
  end;


IMPLEMENTATION

begin
end.

ee_genmat.pas (162 bytes)

Pierre Muller

2019-08-08 23:17

developer   ~0117595

Hi,

  I just check using the official release of win32 fp IDE for 3.0.4
and got no crash.

  I would need to know more about your configuration:
What is the target OS are you using, is it win32?

The official win32 release of FP prints those lines:
E:\pas\check\win32>fp
■ Free Pascal IDE Version 1.0.12 [2017/10/06]
■ Compiler Version 3.0.4
■ GDB Version GDB 7.4
Do you get the same output?
If it is different, where did you get the IDE from?

Nitorami

2019-08-08 23:42

reporter   ~0117596

Hi
Yes, win32. Tested on my office PC and at home with same result. Reinstalled the compiler from the download link on the freepascal site, same result.
Yes, same output.
I have changed compiler settings, debug/normal mode, several target processors etc. but it always crashes.
Deleted fp.dsk, but same result.

Wait: I have just started the IDE from a new directory, and it compiles ok. Comparing the fp.cfg files line by line - the problem appears to be -bl.
Without that, it works.

Thaddy de Koning

2019-08-09 09:41

reporter   ~0117599

I can not reproduce it either way...

Pierre Muller

2019-08-09 10:18

developer   ~0117606

  The crash indeed only happens if
'Options|Compiler|Browser' is set to either 'Only global browser' or 'Local and global browser'

This means simply that the IDE is not able to handle symbols related to generics.

  Win32 3.0.4 IDE and a recent trunk IDE show the same crash.

Thaddy de Koning

2019-08-09 10:23

reporter   ~0117608

Yes. Now I can confirm it.

Issue History

Date Modified Username Field Change
2019-08-08 20:37 Nitorami New Issue
2019-08-08 20:37 Nitorami File Added: ee_genmat.pas
2019-08-08 23:17 Pierre Muller Assigned To => Pierre Muller
2019-08-08 23:17 Pierre Muller Status new => feedback
2019-08-08 23:17 Pierre Muller FPCTarget => -
2019-08-08 23:17 Pierre Muller Note Added: 0117595
2019-08-08 23:42 Nitorami Note Added: 0117596
2019-08-08 23:42 Nitorami Status feedback => assigned
2019-08-09 09:41 Thaddy de Koning Note Added: 0117599
2019-08-09 10:18 Pierre Muller Status assigned => confirmed
2019-08-09 10:18 Pierre Muller Note Added: 0117606
2019-08-09 10:23 Thaddy de Koning Note Added: 0117608
2019-09-20 18:09 Marco van de Voort Relationship added has duplicate 0034138