View Issue Details

IDProjectCategoryView StatusLast Update
0035949PackagesLCLpublic2020-04-29 11:24
Reporterjamie philbrook Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.4 
Summary0035949: The Lazhelp fails to load the default browser on Win10
Description The helpHtml Example in the Lazarus release, this one and most likely a few before fails to load Microsoft Edge when allowing it to locate the default browser.

  Please look at the posting In the forum group as to what is going on and what I've done to work around it.

 The method used to locate browser by ID is flawed and if I void the function so that following code uses the standard approach of locating the browser, it works.

 Please review the forum post on the issue as this was reported before well before 2.0.4 was released.

https://forum.lazarus.freepascal.org/index.php/topic,46337.0.html
Steps To Reproduce
Set your default browser to Microsoft Edge and run the HelpHtml Example program accompanied with Lazarus distribution.

Then follow the steps taken in the forum post and see how it works ok afterwards.

 
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0035659 resolvedwp Lazarus HtmlHelp example fails to load MicrosoftEdge as the viewer 

Activities

Bart Broersma

2020-04-29 11:24

developer   ~0122517

Please close.

Issue History

Date Modified Username Field Change
2019-08-10 17:42 jamie philbrook New Issue
2020-04-29 11:24 Bart Broersma Assigned To => Bart Broersma
2020-04-29 11:24 Bart Broersma Status new => resolved
2020-04-29 11:24 Bart Broersma Resolution open => duplicate
2020-04-29 11:24 Bart Broersma LazTarget => -
2020-04-29 11:24 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2020-04-29 11:24 Bart Broersma Note Added: 0122517
2020-04-29 11:24 Bart Broersma Relationship added duplicate of 0035659