View Issue Details

IDProjectCategoryView StatusLast Update
0035950LazarusCompilerpublic2019-08-11 10:34
ReportersilvioprogAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformLinuxOSopenSUSEOS VersionTumbleweed/Leap
Product Version2.0.4Product Build 
Target VersionFixed in Version 
Summary0035950: Error: No known file format detected for file '/usr/lib64/lazarus/lcl/units/x86_64-linux/cursors.res'
DescriptionHi.

I've tried to compile a project using Lazarus/FPC installed from zypper on openSUSE Tumbleweed (or Leap), but the build is stopped showing the following error:

Hint: (11030) Start of reading config file /etc/fpc.cfg
Hint: (11031) End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 3.0.4 [2019/07/09] for x86_64
Copyright (c) 1993-2017 by Florian Klaempfl and others
(1002) Target OS: Linux for x86-64
(3104) Compiling /home/risoflora/tmp/project1.lpr
(3104) Compiling unit1.pas
(9022) Compiling resource /home/risoflora/tmp/lib/x86_64-linux/project1.or
Error: No known file format detected for file '/usr/lib64/lazarus/lcl/units/x86_64-linux/cursors.res'
/home/risoflora/tmp/project1.lpr(21,1) Error: (9029) Error while compiling resources
/home/risoflora/tmp/project1.lpr(21,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode
Steps To Reproduce- install openSUSE Tumbleweed or Leap
- sudo zypper lazarus
- try to build the default project opened in IDE
Additional InformationLazarus 2.0.4 rUnknown FPC 3.0.4 x86_64-linux-gtk2
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

silvioprog

2019-08-10 23:40

reporter   ~0117632

Problem solved. Steps:

- zypper rm --clean-deps lazarus
- rm -rf /usr/share/doc/fpc* /usr/share/doc/lazarus* /usr/lib64/fpc /usr/lib64/lazarus
- zypper in lazarus
- use chown to add /usr/lib64/lazarus to your group

Please change the status to Resolved and sorry for disturbing.

Juha Manninen

2019-08-11 10:34

developer   ~0117638

I was going to suggest checking the Project Options -> Miscellaneous -> "Resource type of project", but apparently it was not the problem.
Resolving.

Issue History

Date Modified Username Field Change
2019-08-10 23:20 silvioprog New Issue
2019-08-10 23:40 silvioprog Note Added: 0117632
2019-08-11 10:34 Juha Manninen Assigned To => Juha Manninen
2019-08-11 10:34 Juha Manninen Status new => resolved
2019-08-11 10:34 Juha Manninen Resolution open => no change required
2019-08-11 10:34 Juha Manninen LazTarget => -
2019-08-11 10:34 Juha Manninen Widgetset GTK 2 => GTK 2
2019-08-11 10:34 Juha Manninen Note Added: 0117638