View Issue Details

IDProjectCategoryView StatusLast Update
0035952FPCCompilerpublic2019-08-12 13:54
ReporterThaddy de KoningAssigned ToFlorian 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version3.3.1Product Build42654 
Target VersionFixed in Version3.3.1 
Summary0035952: probably msg files need re-generation.
DescriptionTo me this is not really a problem - I am Dutch. have a Lithuanian wife and can read Russian , but I would expect English, not Russian here, but many people can get confused.

asta@thaddyginaasta:~/fpc $ fpc -v
Компилятор Free Pascal версии 3.3.1-r42654 [2019/08/11] для arm
Copyright (c) 1993-2019 by Florian Klaempfl and others
Фатально: В командной строке отсутствует имя исходного файла
Фатально: Компиляция прервана
Error: /usr/local/bin/ppcarm returned an error exitcode

Steps To Reproducesudo make clean all install REVSTR=42654 REVINC=force PP=/home/asta/ppc304 INSTALL_PREFIX=/usr/local GCCLIBDIR=/usr/lib/gcc/arm-linux-gnueabihf/6.3.0 OPT="-CpARMv7a -OpARMv7a -CfVFPv3 -CX -XXs"
Additional InformationThis is part of my old and trusted build script. Before Friday everything was OK.
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Thaddy de Koning

2019-08-11 21:21

reporter   ~0117645

Last edited: 2019-08-11 21:21

View 2 revisions

fpc 3.3.1-r 42654 Raspbian armhf buster. That fell away, somehow.

Thaddy de Koning

2019-08-11 21:35

reporter   ~0117646

Look at this:

fpc -vwhnql -Fu/usr/local/lib/fpc/3.3.1/units/arm-linux/* -Fl/usr/lib/gcc/arm-linux-gnueabihf/6.3.0 "smartptrdemo.pas" (in directory: /home/asta)
Hint: (11030) Start of reading config file /etc/fpc.cfg
одсказка: (11031) Конец чтения файла конфигурации /etc/fpc.cfg
Компилятор Free Pascal версии 3.3.1-r42654 [2019/08/11] для arm
Copyright (c) 1993-2019 by Florian Klaempfl and others
(1002) Целевая ОС: Linux for ARMHF
(3104) Компиляция smartptrdemo.pas
2 495/1.280 Kb Used
smartptrdemo.pas(9,23) одсказка: (5028) Локальный символ type "TAutoMemoryStream" не используется
smartptrs.pas(7,27) Заметка: (5071) Private type "AutoAttribute$1<CLASSES.TStringList>.T" never used
smartptrs.pas(7,27) Заметка: (5071) Private type "AutoAttribute$1<CLASSES.TMemoryStream>.T" never used
(9015) Компоновка smartptrdemo
(1008) 59 строк скомпилиpовано, 2.7 сек.
(1022) 3 подсказок
(1023) 2 заметок
Compilation finished successfully.

Thaddy de Koning

2019-08-12 09:51

reporter   ~0117648

I discovered something strange:
when I force the language with -Fr/usr/local/lib/$fpcversion/msg/errore.msg the compiler fails because it expands that path to:
/usr/local/lib/$fpcversion//msg/errore.msg resulting in a "can not open file" error
Note the double slash! ^^
It may be the case that the same happens internally. Can that be the cause of the wrong language?

Thaddy de Koning

2019-08-12 10:25

reporter   ~0117649

No. even if I force language I still have a Russian compiler, but not when I revert a week.

Florian

2019-08-12 13:54

administrator   ~0117651

No problem here:

$ ./ppcx64 '-Fr/usr/lib/x86_64-linux-gnu/fpc/3.0.4/msg/errore.msg'
Free Pascal Compiler version 3.3.1 [2019/08/12] for x86_64
Copyright (c) 1993-2017 by Florian Klaempfl and others
Fatal: No source file name in command line
Fatal: Compilation aborted


Please check your local config. Keep in mind that $FPCVERSION is expanded by the shell if not passed in ' ... '.

Issue History

Date Modified Username Field Change
2019-08-11 21:17 Thaddy de Koning New Issue
2019-08-11 21:21 Thaddy de Koning Note Added: 0117645
2019-08-11 21:21 Thaddy de Koning Note Edited: 0117645 View Revisions
2019-08-11 21:35 Thaddy de Koning Note Added: 0117646
2019-08-12 09:51 Thaddy de Koning Note Added: 0117648
2019-08-12 10:25 Thaddy de Koning Note Added: 0117649
2019-08-12 13:54 Florian Assigned To => Florian
2019-08-12 13:54 Florian Status new => resolved
2019-08-12 13:54 Florian Resolution open => unable to reproduce
2019-08-12 13:54 Florian Fixed in Version => 3.3.1
2019-08-12 13:54 Florian FPCTarget => -
2019-08-12 13:54 Florian Note Added: 0117651