View Issue Details

IDProjectCategoryView StatusLast Update
0035975LazarusWidgetsetpublic2019-08-16 22:17
ReporterChris Rorden Assigned ToDmitry Boyarintsev  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacBook 2012 Retina 13"OSDarwin 
Product Version2.0.3 (SVN) 
Summary0035975: Cocoa: Regression TPopupMenu vertically offset from mouse location
DescriptionThe function "PopupMenu1.PopUp;" is expected to display the popup menu at the mouse location. However, in recent SVNs it appears offset vertically (horizontal position seems fine). This seems to be related to the fact that Y-direction is opposite for Cocoa than other widgetsets (e.g. Y= 0 is form bottom in Cocoa coordinates and form top in other coordinates) as the error increases with form height and distance from mouse to form center.
TagsNo tags attached.
Fixed in Revision61708
LazTarget-
WidgetsetCocoa
Attached Files

Activities

Chris Rorden

2019-08-16 20:51

reporter  

popup.zip (56,883 bytes)

Dmitry Boyarintsev

2019-08-16 21:02

developer   ~0117711

please test and close if ok

Issue History

Date Modified Username Field Change
2019-08-16 20:51 Chris Rorden New Issue
2019-08-16 20:51 Chris Rorden File Added: popup.zip
2019-08-16 21:02 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-08-16 21:02 Dmitry Boyarintsev Status new => resolved
2019-08-16 21:02 Dmitry Boyarintsev Resolution open => fixed
2019-08-16 21:02 Dmitry Boyarintsev Fixed in Revision => 61708
2019-08-16 21:02 Dmitry Boyarintsev LazTarget => -
2019-08-16 21:02 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-08-16 21:02 Dmitry Boyarintsev Note Added: 0117711
2019-08-16 22:17 Chris Rorden Status resolved => closed