View Issue Details

IDProjectCategoryView StatusLast Update
0035985FPCFCLpublic2019-08-24 14:19
ReporterSimon AmeisAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
PlatformDesktop PCOSWindows 7, 64 bitOS Version6.1 SP 1
Product Version3.3.1Product BuildTrunk 
Target VersionFixed in Version3.3.1 
Summary0035985: fpjson function VarRecToJSON UnicodeString Support
DescriptionCurrently the function VArRecToJSON doesn't support UnicodeStrings supplied in parameter Element.

Please add the line following line:
      vtUnicodeString: Result:=CreateJSON(UnicodeString(VUnicodeString));
Tagsfpjson, unicode
Fixed in Revision42743
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-08-20 09:04

administrator   ~0117742

Fixed, added test. Thanks for reporting.

Simon Ameis

2019-08-20 22:12

reporter   ~0117752

Thanks for adding.

Later I got the idea, vtWideChar should be supported as well. This would be also a oneliner:

vtWideChar: Result:=CreateJSON(UnicodeString(VWideChar));

Simon Ameis

2019-08-23 19:35

reporter   ~0117810

@Michael:
I mind if you got the update, because I messed up with the status of this bug entry. However I can't modify the status directly

Michael Van Canneyt

2019-08-24 10:55

administrator   ~0117815

No worries. I did see you reopened it, but next time, please report it in a separate report.

Added widestring support in rev 42782.


Issue History

Date Modified Username Field Change
2019-08-19 23:34 Simon Ameis New Issue
2019-08-19 23:34 Simon Ameis Tag Attached: fpjson
2019-08-19 23:34 Simon Ameis Tag Attached: unicode
2019-08-20 09:03 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-08-20 09:03 Michael Van Canneyt Status new => assigned
2019-08-20 09:04 Michael Van Canneyt Status assigned => resolved
2019-08-20 09:04 Michael Van Canneyt Resolution open => fixed
2019-08-20 09:04 Michael Van Canneyt Fixed in Version => 3.3.1
2019-08-20 09:04 Michael Van Canneyt Fixed in Revision => 42743
2019-08-20 09:04 Michael Van Canneyt FPCTarget => 3.2.0
2019-08-20 09:04 Michael Van Canneyt Note Added: 0117742
2019-08-20 22:12 Simon Ameis Status resolved => feedback
2019-08-20 22:12 Simon Ameis Resolution fixed => reopened
2019-08-20 22:12 Simon Ameis Note Added: 0117752
2019-08-23 19:35 Simon Ameis Note Added: 0117810
2019-08-23 19:35 Simon Ameis Status feedback => assigned
2019-08-24 10:55 Michael Van Canneyt Status assigned => resolved
2019-08-24 10:55 Michael Van Canneyt Note Added: 0117815
2019-08-24 14:19 Simon Ameis Status resolved => closed