View Issue Details

IDProjectCategoryView StatusLast Update
0036001LazarusWidgetsetpublic2019-08-28 14:25
ReporterChris RordenAssigned ToDmitry Boyarintsev 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacBook Pro 13 2018OSDarwinOS Version10.14.6
Product Version2.0.3 (SVN)Product Build61749 
Target VersionFixed in Version 
Summary0036001: Cocoa: Regression TrackPad Scrolling
DescriptionThe latest SVNs have an odd behavior, where you can not use a trackpad to scroll up and down. This is easiest to see by opening a large unit in the Source Editor. Note that scrolling works normally using a mouse scroll wheel or array keys. However, if you use the TrackPad to scroll, the text is initially scrolled but on release the scroll position jumps to the very first line of the panel. This bug is only in the vertical direction, left-right scrolling seems fine. Perhaps caused by the patch for issue 35968.
TagsNo tags attached.
Fixed in Revision61771
LazTarget-
WidgetsetCocoa
Attached Files

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2019-08-23 21:50 Chris Rorden New Issue
2019-08-24 19:16 Dmitry Boyarintsev Assigned To => Dmitry Boyarintsev
2019-08-24 19:16 Dmitry Boyarintsev Status new => assigned
2019-08-28 04:57 Dmitry Boyarintsev Status assigned => resolved
2019-08-28 04:57 Dmitry Boyarintsev Resolution open => fixed
2019-08-28 04:57 Dmitry Boyarintsev Fixed in Revision => 61771
2019-08-28 04:57 Dmitry Boyarintsev LazTarget => -
2019-08-28 04:57 Dmitry Boyarintsev Widgetset Cocoa => Cocoa
2019-08-28 14:25 Chris Rorden Status resolved => closed