View Issue Details

IDProjectCategoryView StatusLast Update
0036012FPCRTLpublic2019-09-04 14:46
ReporterKai BurghardtAssigned ToMarco van de Voort 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSGNU/LinuxOS Version4.2.0
Product Version3.0.4Product Build3.0.4+dfsg-11 [2017/12/30] 
Target VersionFixed in Version 
Summary0036012: global compiler directive $S is used, as if it were a local compiler directive
Description{$S} is (documented as) a global compiler directive, yet at multiple occasions it’s used as if it were a local directive:

rtl/inc/system.inc line 946: https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/rtl/inc/system.inc?view=markup#l946

rtl/java/jsystem.inc line 811: https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/rtl/java/jsystem.inc?revision=42109&view=markup#l811

rtl/objpas/sysutils/sysutils.inc line 298: https://svn.freepascal.org/cgi-bin/viewvc.cgi/trunk/rtl/objpas/sysutils/sysutils.inc?view=markup#l298
TagsNo tags attached.
Fixed in Revision 1647
FPCOldBugId
FPCTarget-
Attached Files

Activities

Sven Barth

2019-08-30 15:12

manager   ~0117877

That's because $S *is* in fact a local switch. So the documentation needs to be updated.

Marco van de Voort

2019-09-04 14:46

manager   ~0117951

I moved the section in the prog.tex documentation

Issue History

Date Modified Username Field Change
2019-08-25 21:57 Kai Burghardt New Issue
2019-08-30 15:12 Sven Barth Note Added: 0117877
2019-09-04 14:46 Marco van de Voort Assigned To => Marco van de Voort
2019-09-04 14:46 Marco van de Voort Status new => resolved
2019-09-04 14:46 Marco van de Voort Resolution open => fixed
2019-09-04 14:46 Marco van de Voort Fixed in Revision => 1647
2019-09-04 14:46 Marco van de Voort FPCTarget => -
2019-09-04 14:46 Marco van de Voort Note Added: 0117951