View Issue Details

IDProjectCategoryView StatusLast Update
0036014FPCCompilerpublic2020-08-03 23:56
ReporterImants Gulbis Assigned ToSven Barth  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.3.1 
Fixed in Version3.3.1 
Summary0036014: It is posible to specialize non generic method
DescriptionI run into strange bug. I created generic method and after time I understood that I do not need it as generic and changed it to normal method. But code still compiled even If id did not remove specializations.
It looks like FPC do not check if method I try to specialize can be specialized. It brings code to undefined behavior because in some case it compiles and works, in some cases it compiles and skips method and in some cases linked throws some errors.
Tagsgenerics
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Imants Gulbis

2019-08-26 07:23

reporter  

specialization.zip (1,642 bytes)

Thaddy de Koning

2019-08-28 11:13

reporter   ~0117861

What version of trunk? because I think Sven already attended to this before my 5 day break to Paris and you don't mention the revision.....

Imants Gulbis

2019-08-29 07:29

reporter   ~0117864

I tried it now with 42866 revision compiled today. And bug was still present.

Imants Gulbis

2020-07-23 08:04

reporter   ~0124251

I checked FPC trunk revision 45829 and it seems that this problem is fixed.

Sven Barth

2020-08-03 23:56

manager   ~0124532

Thanks for the test. I've added your testcase in r46219 to be sure.

Issue History

Date Modified Username Field Change
2019-08-26 07:23 Imants Gulbis New Issue
2019-08-26 07:23 Imants Gulbis File Added: specialization.zip
2019-08-28 11:13 Thaddy de Koning Note Added: 0117861
2019-08-29 07:29 Imants Gulbis Note Added: 0117864
2020-07-23 08:04 Imants Gulbis Note Added: 0124251
2020-07-24 09:52 Sven Barth Tag Attached: generics
2020-08-03 23:56 Sven Barth Assigned To => Sven Barth
2020-08-03 23:56 Sven Barth Status new => resolved
2020-08-03 23:56 Sven Barth Resolution open => fixed
2020-08-03 23:56 Sven Barth Fixed in Version => 3.3.1
2020-08-03 23:56 Sven Barth FPCTarget => -
2020-08-03 23:56 Sven Barth Note Added: 0124532