View Issue Details

IDProjectCategoryView StatusLast Update
0036033LazarusIDEpublic2019-10-13 09:46
ReporterVitaly YakuninAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSKubuntuOS Version19.04
Product Version2.0.4Product Build 
Target VersionFixed in Version 
Summary0036033: Strange mouse behavior
DescriptionWe launch Lazarus. And after a short period of time (not immediately), mysticism begins. After selecting the control, when moving with the mouse (the button is not pressed), a rectangle appears, as if the left button was clamped. This can be seen in the screenshot. If you click on the control again, the selection of the control itself is removed, and the selection rectangle disappears. If you click on another control, both become highlighted. It turns out that you can properly select only in the object inspector.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0036015 new Sparta form designer goes to multi select mode (as CTRL key is hold down) 

Activities

Vitaly Yakunin

2019-09-01 07:44

reporter  

lazarus_bag.png (4,234 bytes)
lazarus_bag.png (4,234 bytes)

Juha Manninen

2019-09-01 07:52

developer   ~0117897

You mean it happens in designer?
I cannot reproduce here. It may be related to the Linux distro. The desktop in Kubuntu is KDE which I also have with my Manjaro Linux.

Alexey Tor.

2019-09-01 08:52

reporter   ~0117900

looks like Ctrl or Shift key is pressed by itself? maybe keyboard has problems.

Vitaly Yakunin

2019-09-01 10:21

reporter   ~0117902

2 Juha Manninen: Yes. In the designer.
2 Alexey Tor.: No. The keyboard is fine. Checked with different.

Vitaly Yakunin

2019-09-01 13:17

reporter   ~0117906

This can be reproduced if the controls are located inside the TSrollBox.

Vitaly Yakunin

2019-09-04 07:49

reporter   ~0117944

Same on openSuSE Tumbleweed

Juha Manninen

2019-09-04 13:17

developer   ~0117950

Last edited: 2019-10-09 07:12

View 2 revisions

Do you have Sparta docked forms editor installed as in the related issue?

Juha Manninen

2019-10-09 07:13

developer   ~0118436

Ping...

Juha Manninen

2019-10-13 09:46

developer   ~0118551

No feedback. Assuming this is a duplicate of issue 0036015, so resolving.

Issue History

Date Modified Username Field Change
2019-09-01 07:44 Vitaly Yakunin New Issue
2019-09-01 07:44 Vitaly Yakunin File Added: lazarus_bag.png
2019-09-01 07:52 Juha Manninen Note Added: 0117897
2019-09-01 08:52 Alexey Tor. Note Added: 0117900
2019-09-01 10:21 Vitaly Yakunin Note Added: 0117902
2019-09-01 13:17 Vitaly Yakunin Note Added: 0117906
2019-09-04 07:49 Vitaly Yakunin Note Added: 0117944
2019-09-04 12:01 Martin Friebe Relationship added related to 0036015
2019-09-04 13:17 Juha Manninen Assigned To => Juha Manninen
2019-09-04 13:17 Juha Manninen Status new => feedback
2019-09-04 13:17 Juha Manninen LazTarget => -
2019-09-04 13:17 Juha Manninen Note Added: 0117950
2019-10-09 07:12 Juha Manninen Note Edited: 0117950 View Revisions
2019-10-09 07:13 Juha Manninen Note Added: 0118436
2019-10-13 09:46 Juha Manninen Status feedback => resolved
2019-10-13 09:46 Juha Manninen Resolution open => duplicate
2019-10-13 09:46 Juha Manninen Widgetset GTK 2 => GTK 2
2019-10-13 09:46 Juha Manninen Note Added: 0118551
2019-10-13 09:46 Juha Manninen Relationship replaced duplicate of 0036015