View Issue Details

IDProjectCategoryView StatusLast Update
0036037FPCFCLpublic2019-09-02 15:26
ReporterAlexey Tor.Assigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0036037: fpJSON now shows error on valid json file
Descriptionafter last update in trunk, i get errors like

Cannot read/parse config:
/home/user/cuda/cuda/app/settings/user.json

Invalid character at line 10, pos 0: '
'

for empty lines in json file. file examples attached.
TagsNo tags attached.
Fixed in Revision42904
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Alexey Tor.

2019-09-01 12:32

reporter  

settings.zip (395 bytes)

Michael Van Canneyt

2019-09-01 13:43

administrator   ~0117907

Fixed. Added a testcase for this. Thanks for reporting!

Alexey Tor.

2019-09-02 13:39

reporter   ~0117918

{
  "tab_spaces": true,
  //auto-indent kind:
  // 0: indent like in prev line
  // 1: by spaces
  // 2: by tabs+spaces
  // 3: by tabs only
  "indent_kind": 1,
  "indent_size": 4,

  "saving_trim_spaces": true,

// "config_menus_from": "kv-menu JSON.json",
    "find_hotkey_replace": "Alt+Enter",
    "fold_style": 4,
}

this file user.json now gives error-
Duplicate object member: "saving_trim_spaces"

Alexey Tor.

2019-09-02 13:40

reporter   ~0117919

(note: I have added IgnoreTrailingComma option to DefaultJsonOptions variable)

Michael Van Canneyt

2019-09-02 14:08

administrator   ~0117920

I can't reproduce this. It parses fine here.

Please provide a sample program that produces the error, and open a separate bugreport for it.

Michael Van Canneyt

2019-09-02 14:15

administrator   ~0117921

Forget my last remark, compiled with the wrong version of FPC

Michael Van Canneyt

2019-09-02 14:37

administrator   ~0117922

Fixed.

For additional cases, please use separate bugreports, thank you !

Issue History

Date Modified Username Field Change
2019-09-01 12:31 Alexey Tor. New Issue
2019-09-01 12:32 Alexey Tor. File Added: settings.zip
2019-09-01 13:43 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-09-01 13:43 Michael Van Canneyt Status new => resolved
2019-09-01 13:43 Michael Van Canneyt Resolution open => fixed
2019-09-01 13:43 Michael Van Canneyt Fixed in Version => 3.3.1
2019-09-01 13:43 Michael Van Canneyt Fixed in Revision => 42887
2019-09-01 13:43 Michael Van Canneyt FPCTarget => 3.2.0
2019-09-01 13:43 Michael Van Canneyt Note Added: 0117907
2019-09-01 16:40 Alexey Tor. Status resolved => closed
2019-09-02 13:39 Alexey Tor. Status closed => feedback
2019-09-02 13:39 Alexey Tor. Resolution fixed => reopened
2019-09-02 13:39 Alexey Tor. Note Added: 0117918
2019-09-02 13:40 Alexey Tor. Note Added: 0117919
2019-09-02 13:40 Alexey Tor. Status feedback => assigned
2019-09-02 14:08 Michael Van Canneyt Status assigned => resolved
2019-09-02 14:08 Michael Van Canneyt Resolution reopened => unable to reproduce
2019-09-02 14:08 Michael Van Canneyt Note Added: 0117920
2019-09-02 14:15 Michael Van Canneyt Status resolved => confirmed
2019-09-02 14:15 Michael Van Canneyt Note Added: 0117921
2019-09-02 14:37 Michael Van Canneyt Status confirmed => resolved
2019-09-02 14:37 Michael Van Canneyt Fixed in Revision 42887 => 42904
2019-09-02 14:37 Michael Van Canneyt Note Added: 0117922
2019-09-02 14:37 Michael Van Canneyt Resolution unable to reproduce => fixed
2019-09-02 15:26 Alexey Tor. Status resolved => closed