View Issue Details

IDProjectCategoryView StatusLast Update
0036054Lazarus-public2019-10-01 18:07
ReporterJohn ShandAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinux 64bitOSArch LinuxOS VersionTumbleweed
Product Version2.0Product Build 
Target VersionFixed in Version 
Summary0036054: Fatal: Cannot find FPImage used by InterfaceBase of package LCLBase.
DescriptionLAZARUS Version:

Working Copy Root Path: /home/jshand/lazarus
URL: https://svn.freepascal.org/svn/lazarus/branches/fixes_2_0
Relative URL: ^/branches/fixes_2_0
Repository Root: https://svn.freepascal.org/svn/lazarus
Repository UUID: 4005530d-fff6-0310-9dd1-cebe43e6787f
Revision: 61819
Node Kind: directory
Schedule: normal
Last Changed Author: wp
Last Changed Rev: 61814
Last Changed Date: 2019-09-05 20:21:04 +1200 (Thu, 05 Sep 2019)

FPC Version:

Working Copy Root Path: /home/jshand/fpc
URL: https://svn.freepascal.org/svn/fpc/branches/fixes_3_2
Relative URL: ^/branches/fixes_3_2
Repository Root: https://svn.freepascal.org/svn/fpc
Repository UUID: 3ad0048d-3df7-0310-abae-a5850022a9f2
Revision: 42929
Node Kind: directory
Schedule: normal
Last Changed Author: marco
Last Changed Rev: 42922
Last Changed Date: 2019-09-06 00:17:22 +1200 (Fri, 06 Sep 2019)
Steps To ReproduceRun an application in the IDE
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetQT5
Attached Files

Activities

wp

2019-09-07 01:20

developer   ~0117965

Cannot confirm on Win 10 / 64 bit, fpc fixes r42922, Laz fixes r61822 (32 bit).

Did you do a clean rebuild of the IDE?

John Shand

2019-09-07 02:55

reporter   ~0117966

yes i did do a fresh install. i have no idea where this came from.

Marco van de Voort

2019-09-07 12:16

manager   ~0117967

(Last week fcl-image fixes were merged back to fixes)

John Shand

2019-09-07 21:41

reporter   ~0117978

unfortunately, this error only just started 2 or 3 days ago

wp

2019-09-07 22:37

developer   ~0117979

Can you go back by one revision, first with Lazarus, then with FPC, to find out who's to blame?

John Shand

2019-09-08 12:24

reporter   ~0117989

how would i do this. when i do a download of wither fpc or lazarus with subversion, it gives me up to date files

wp

2019-09-08 13:15

developer   ~0117992

You can update to a specific revision. Not 100% sure about the syntax (I work with tortoisesvn under Windows), try "svn up -r<number>", e.g. "svn up -r42913" for using the fpc-fixes revision before the one of this report, or "svn up -r61738" for laz-fixes (all commands without quotes).

Thaddy de Koning

2019-09-08 16:36

reporter   ~0117995

I can NOT reproduce this issue. Not in 2.0.4 nor in an older 2.0.0

John Shand

2019-09-09 13:20

reporter   ~0118003

this problem seems to have fixed itself. i installed a stable version of manjaro linux (which is based on arch). i set up everything as i normally would, and the problem went away.

how about others??

wp

2019-09-09 16:01

developer   ~0118004

OK, I'll assign this report to myself, keep it up for a few days and then resolve as "cannot reproduce".

John Shand

2019-09-10 03:12

reporter   ~0118011

i have now run back into this problem again. i get this error in the Lazarus IDE:

Fatal: Cannot find FPImage used by InterfaceBase. Make sure all ppu files of a package are in its output directory. ppu in wrong directory=/home/jshand/build/fpc/pkg/fpc/usr/lib/fpc/3.2.0/units/x86_64-linux/fcl-image/fpimage.ppu..

seems to me that this issue was because of the ppu file being in the wrong directory.

wp

2019-09-10 17:38

developer   ~0118019

You write in the Steps to reproduce: "Run an application in the IDE" - I interpret this as "Run any application" and always tested with an empty new project and did not see the error. Maybe this is not enough. Please post a minimal project which leads to the error. When the error cannot be reproduced it cannot be fixed.

John Shand

2019-09-10 23:15

reporter   ~0118024

Here it is. i hope this helps.

bm.tar.gz (128,300 bytes)

wp

2019-09-11 00:21

developer   ~0118028

Project compiles and runs fine here. But I am on Win10/64bit with 32 bit fpc and Laz. Can somebody confirm the issue on a system which is closer to that of John: Linux 64bit (Arch) w/ qt5, fixes for both fpc and laz.

John, did you try to update svn to an older version of fpc and laz (as described above) in order to pin-point the issue?

John Shand

2019-09-11 02:22

reporter   ~0118029

Last edited: 2019-09-11 02:22

View 2 revisions

hi wp. yes i did try something earlier, i just used the stable version from manjaros repos 3.0.4 or 3.0.5 version before i used the fixes svn. same issue happened

wp

2019-09-11 18:40

developer   ~0118038

Last edited: 2019-09-11 18:43

View 2 revisions

Detaching myself. Wasted too many hours today trying to install Manjaro Linux into a VM.

Grrrrh... The new bugtracker software keeps the issue in the "Assigned" colors although nobody really is assigned... Juha, I know that you are a Manjaro expert, therefore, I assign the issue to you.

Bart Broersma

2019-09-11 18:59

developer   ~0118040

@wp: unassigning is not enough, you have to manually set status to e.g. "acknowledged".
IIRC this was also the case in the previous version of Mantis.

Juha Manninen

2019-09-11 23:16

developer   ~0118045

Last edited: 2019-09-11 23:28

View 2 revisions

John Shand, such an error is pretty much always caused by having multiple .ppu files around, or having a single .ppu file compiled for a wrong target.
Here is the issue explained more thoroughly:
 https://wiki.lazarus.freepascal.org/Unit_not_found_-_How_to_find_units
Especially having many FPC versions around at one time is tricky. I have understood the fpcupdeluxe app installs both FPC and Lazarus in a "sandbox", isolated from other versions.
 https://wiki.freepascal.org/fpcupdeluxe
It could solve your problems. Please test it.
I remember you have many bug reports about build errors. Some of them may have a similar root cause. Please ask build instructions in forum or mailing list.
BTW, I did not test yet with the exact same FPC/Lazarus versions as you have, because I am quite confident they don't cause the problem.

John Shand

2019-09-14 11:32

reporter   ~0118069

i just created a new project to test it again. it seems to be a compiler debugger issue. i have left the default settings for my new project as is and it compiles without a problem. however, when i change settings in project options and make all debugging options true, turn off debug symbols and windows options, i get the above error

John Shand

2019-09-14 11:38

reporter   ~0118070

i always save all project info in the lpi file and always build project. still works ok

John Shand

2019-09-14 11:41

reporter   ~0118071

Last edited: 2019-09-14 11:41

View 2 revisions

turned off win32 gui option and got an access violation. i then went out of lazarus and started lazarus again. that error went away seemingly

left other target and configs as default

John Shand

2019-09-14 11:45

reporter   ~0118072

changed the optimization level to 3. compiled fine.

John Shand

2019-09-14 11:47

reporter   ~0118073

went to debugging options and enabled all checks and assertions, turned off generate info for debugging. it then crashed for some reason with the same error above

Juha Manninen

2019-10-01 18:07

developer   ~0118236

I tested with the same versions as you. No problems in compilation whatsoever.
As I wrote such errors are caused by mismatch in compiled .ppu files in your system.
Having many FPC versions around can be tricky. Thus I recommend fpcupdeluxe for you. Load the desired versions of both FPC and Lazarus using it and you are good to go.
Ask more information in forum.
Resolving.

Issue History

Date Modified Username Field Change
2019-09-07 00:41 John Shand New Issue
2019-09-07 01:20 wp Note Added: 0117965
2019-09-07 02:55 John Shand Note Added: 0117966
2019-09-07 12:16 Marco van de Voort Note Added: 0117967
2019-09-07 21:41 John Shand Note Added: 0117978
2019-09-07 22:37 wp Note Added: 0117979
2019-09-08 12:24 John Shand Note Added: 0117989
2019-09-08 13:15 wp Note Added: 0117992
2019-09-08 16:36 Thaddy de Koning Note Added: 0117995
2019-09-09 13:20 John Shand Note Added: 0118003
2019-09-09 16:01 wp Note Added: 0118004
2019-09-09 16:01 wp Assigned To => wp
2019-09-09 16:01 wp Status new => assigned
2019-09-10 03:12 John Shand Note Added: 0118011
2019-09-10 17:38 wp Note Added: 0118019
2019-09-10 23:15 John Shand File Added: bm.tar.gz
2019-09-10 23:15 John Shand Note Added: 0118024
2019-09-11 00:21 wp Note Added: 0118028
2019-09-11 02:22 John Shand Note Added: 0118029
2019-09-11 02:22 John Shand Note Edited: 0118029 View Revisions
2019-09-11 18:40 wp Note Added: 0118038
2019-09-11 18:40 wp Assigned To wp =>
2019-09-11 18:40 wp Assigned To => wp
2019-09-11 18:40 wp Assigned To wp =>
2019-09-11 18:41 wp Assigned To => Juha Manninen
2019-09-11 18:43 wp Note Edited: 0118038 View Revisions
2019-09-11 18:59 Bart Broersma Note Added: 0118040
2019-09-11 23:16 Juha Manninen Note Added: 0118045
2019-09-11 23:28 Juha Manninen Note Edited: 0118045 View Revisions
2019-09-14 11:32 John Shand Note Added: 0118069
2019-09-14 11:38 John Shand Note Added: 0118070
2019-09-14 11:41 John Shand Note Added: 0118071
2019-09-14 11:41 John Shand Note Edited: 0118071 View Revisions
2019-09-14 11:45 John Shand Note Added: 0118072
2019-09-14 11:47 John Shand Note Added: 0118073
2019-10-01 18:07 Juha Manninen Status assigned => resolved
2019-10-01 18:07 Juha Manninen Resolution open => unable to reproduce
2019-10-01 18:07 Juha Manninen LazTarget => -
2019-10-01 18:07 Juha Manninen Widgetset QT5 => QT5
2019-10-01 18:07 Juha Manninen Note Added: 0118236