View Issue Details

IDProjectCategoryView StatusLast Update
0036056FPCDatabasepublic2019-09-08 12:24
ReporterAlexAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Platformwin32OS7OS Version6.1
Product Version3.0.4Product Build61665 
Target VersionFixed in Version 
Summary0036056: UTF8+DBF blobs
DescriptionAs an some architector i think it's all around UTF8 and it's char/bytes counting.
Searching some utf8 text in blobs fails with positioning...
Blobs with dbf still has an issue with view by dbtext.
So also this thing is wet as hell. Blobs is fast blowing up, can't maintain it (pack&other).
Steps To ReproduceSearch utf8 text in dbmemo.
Import broken 1,5G dbf base with blobs, add-remove-pack it. ;)
TagsNo tags attached.
Fixed in Revision
FPCOldBugId
FPCTarget-
Attached Files

Activities

Michael Van Canneyt

2019-09-08 09:41

administrator   ~0117984

Please provide a program that shows the issue.

With this description, I cannot understand what the *exact* problem is, much less fix it.

Thaddy de Koning

2019-09-08 11:43

reporter   ~0117985

Last edited: 2019-09-08 11:44

View 2 revisions

When I use it with UTF8pos the relative positions are correct if the blob is indeed an UTF8 text file. (Pos gives absolute positions)
I think the issue is wrong use of Pos.
Actually I think this should be asked on the forum, and the solution is given here: https://forum.lazarus.freepascal.org/index.php/topic,45446.msg321459.html#msg321459

Michael Van Canneyt

2019-09-08 12:24

administrator   ~0117988

If the problem is what is referenced in the forum post, then the problem is indeed wrong use of Pos.

In Delphi, string equals widestring. In fpc it is not, so the contents is UTF8 and utf8 functions must be used.

Issue History

Date Modified Username Field Change
2019-09-08 09:27 Alex New Issue
2019-09-08 09:41 Michael Van Canneyt Note Added: 0117984
2019-09-08 11:43 Thaddy de Koning Note Added: 0117985
2019-09-08 11:44 Thaddy de Koning Note Edited: 0117985 View Revisions
2019-09-08 12:24 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-09-08 12:24 Michael Van Canneyt Status new => resolved
2019-09-08 12:24 Michael Van Canneyt Resolution open => no change required
2019-09-08 12:24 Michael Van Canneyt FPCTarget => -
2019-09-08 12:24 Michael Van Canneyt Note Added: 0117988