View Issue Details

IDProjectCategoryView StatusLast Update
0036058LazarusOtherpublic2019-09-09 19:16
ReporterHenri MaquoiAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformPC I5 - 3470 3.20GHZOSWindows 7OS Version6.1.7601 SP1
Product Version2.0.4Product Build 
Target VersionFixed in Version 
Summary0036058: Fermeture inopinée d'une fenêtre en fin de procédure liée à un BitBtn de celle-ci.
DescriptionBonjour,
J'observe la fermeture systématique de ma fenêtre lors de la fin du code suivant, qui ne comporte donc AUCUN appel à un CLOSE quelconque.

procedure TFormDisplay.BtnGreyToColorClick(Sender: TObject);
Var
  I, J, MinX, MinY, MaxX, MaxY, Colour, ColRef, Count,
  R, G, B: Integer;
begin
  PB.Position:=0;
  PB.Max:=Image.Picture.BitMap.Height;
  Count:=0;
  For J:=0 to Image.Picture.BitMap.Height-1 do Begin
    PB.Position:=J;
    For I:=0 to Image.Picture.BitMap.Width-1 do Begin
      Colour:=Image.Picture.Bitmap.Canvas.Pixels[I, J];
      R:=red(Colour);
      G:=Green(Colour);
      B:=Blue(Colour);
      If (R=G) and (R=B) Then Begin
        Image.Picture.Bitmap.Canvas.Pixels[I, J]:=clRed;
        Inc(Count);
        Image.Refresh;
      end;
    end;
  end;
  PB.Position:=0;
end;
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0036059 feedback Function BitBtnClick ends with parent window's closing 

Activities

Bart Broersma

2019-09-09 19:16

developer   ~0118007

There is no need to file 2 bugreports about the same issue, one in english and one in french language.
If, by mistake you posted it in french language, you can (in a note) add the correct english title, and some developer (like me) will adjust the title of the original bugreport,

Issue History

Date Modified Username Field Change
2019-09-09 17:25 Henri Maquoi New Issue
2019-09-09 19:16 Bart Broersma Assigned To => Bart Broersma
2019-09-09 19:16 Bart Broersma Status new => resolved
2019-09-09 19:16 Bart Broersma Resolution open => duplicate
2019-09-09 19:16 Bart Broersma LazTarget => -
2019-09-09 19:16 Bart Broersma Widgetset Win32/Win64 => Win32/Win64
2019-09-09 19:16 Bart Broersma Note Added: 0118007
2019-09-09 19:16 Bart Broersma Relationship added duplicate of 0036059