View Issue Details

IDProjectCategoryView StatusLast Update
0036075FPCPackagespublic2019-09-14 16:09
ReporterZeljan RikaloAssigned ToMichael Van Canneyt 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.3.1Product Build 
Target VersionFixed in Version3.3.1 
Summary0036075: FCL-WEB: OnInitSession is called at wrong place in iniwebsession
DescriptionAccording to the wiki page https://wiki.lazarus.freepascal.org/fpWeb_Tutorial
"In case of a new session, OnNewSession will be called. Initialize your session variables here."
Actually there's no way to initialize eg variables Session.Variables["myvariable"] := '2' since FIniFile is not created yet.
We even do not get Session ID inside OnNewSession ....

I cannot create patch because of technical problems...so please move
    If Assigned(OnNewSession) then
      OnNewSession(Self);
after
    FSessionStarted := True; inside iniwebsession.pp (TIniWebSession.InitSession)
TagsNo tags attached.
Fixed in Revision42993
FPCOldBugId
FPCTarget3.2.0
Attached Files

Activities

Michael Van Canneyt

2019-09-14 15:05

administrator   ~0118074

Fixed, thanks for reporting !

Zeljan Rikalo

2019-09-14 16:09

reporter   ~0118076

That was pretty fast :)
Thanks !

Issue History

Date Modified Username Field Change
2019-09-14 13:19 Zeljan Rikalo New Issue
2019-09-14 15:03 Michael Van Canneyt Assigned To => Michael Van Canneyt
2019-09-14 15:03 Michael Van Canneyt Status new => assigned
2019-09-14 15:05 Michael Van Canneyt Status assigned => resolved
2019-09-14 15:05 Michael Van Canneyt Resolution open => fixed
2019-09-14 15:05 Michael Van Canneyt Fixed in Version => 3.3.1
2019-09-14 15:05 Michael Van Canneyt Fixed in Revision => 42993
2019-09-14 15:05 Michael Van Canneyt FPCTarget => 3.2.0
2019-09-14 15:05 Michael Van Canneyt Note Added: 0118074
2019-09-14 16:09 Zeljan Rikalo Status resolved => closed
2019-09-14 16:09 Zeljan Rikalo Note Added: 0118076